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Trademarks and Copyright Notice 

©2025 TSC Auto ID Technology Co., Ltd. 

All trademarks mentioned in this document are the property of their respective owners. TSC is a 
trademark of TSC Auto ID Technology Co., Ltd., registered in many jurisdictions worldwide. Unauthorized 
reproduction or use of these trademarks, or any part of this document, is strictly prohibited. 

 

Product Improvements and Updates 

TSC Auto ID continuously strives to improve our products. All specifications, features, and designs are 
subject to change without notice as part of our ongoing product enhancement initiatives. It is 
recommended to regularly consult the latest documentation to ensure the most up-to-date information is 
being used. Product users should validate that any new specifications or feature updates for compatibility 
with their existing applications before implementation.  

 

Proprietary Information and Confidentiality 

This manual contains proprietary information of TSC Auto ID Technology Co., Ltd. (TSC), which is 
intended solely for the use of parties operating and maintaining the equipment described herein. Such 
proprietary information must not be used, reproduced, or disclosed to any third party for any purpose 
without the express written permission of TSC. 

 

Disclaimer 

While TSC Auto ID makes every effort to ensure the accuracy of the information contained in our 
specifications and manuals, errors may still occur. TSC Auto ID reserves the right to correct any errors, 
and disclaims any liability caused by such errors. The information provided in this document is for 
reference only and does not constitute a guarantee of performance or suitability for any particular 
application.  

 

Limitation of Liability 

TSC Auto ID is not responsible for any direct, indirect, incidental, or consequential damages arising from 
the use, inability to use, or performance of our products. This includes, but is not limited to, business 
losses, interruptions, or the loss of business data, even if TSC was advised of the possibility of such 
damages. 

Some jurisdictions may not permit the exclusion of incidental or consequential damages, so the limitations 
and exclusions outlined here may not apply to you. 

 

User Responsibility 

It is the responsibility of the user to comply with all relevant laws and licensing agreements when using 
this document and the associated products. TSC Auto ID disclaims responsibility for any consequences 
arising from improper usage or unauthorized modifications to the products. 
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Security and System Integrity 

TSC Auto ID is not responsible for security vulnerabilities introduced through third-party software, 
unauthorized file uploads, or improper system configurations via any access path. Users are responsible 
for implementing appropriate security measures to prevent potential risks. TSC Auto ID is not liable for any 
malfunctions, disruptions, or security issues resulting from such actions. 

 

Trademark Acknowledgements 

Printronix, IGP, Auto Label Mapping, LinePrinter Plus, PGL, and PrintNet are registered trademarks of 

Printronix, Inc. 

T800, T8000, and T6000 are trademarks of Printronix Auto ID Technology, Inc.  

Code V is a trademark of QMS, Inc. 

QMS is a registered trademark of Quality Micro Systems, Inc. 

IBM is registered trademark of International Business Machines Corp.  

MS-DOS and Windows are registered trademarks of Microsoft Corporation.  

EIA is a registered service mark of Electronic Industries Association. 

ZPL, ZPL II, and Zebra are registered trademarks of Zebra Technologies Corporation. 

TEC is a registered trademark of the Toshiba TEC Corporation. 

Intermec is a registered trademark of Honeywell Corporation.  

SATO is a registered trademark of SATO America, Inc. 

DPL is a trademark and Datamax is a registered trademark of Honeywell Corporation. 

IER is a registered trademark of IER Siège 

Monarch is a registered trademark of Avery-Dennison Corporation. 

SD, SDHC and SDXC are trademarks or registered trademarks of SD-3C, LLC in the United States, 
other countries or both. Also, miniSD, microSD, miniSDHC, microSDHC, microSDXC, smartSD, 
smartSDHC, SDIO and miniSDIO are all trademarks or registered trademarks of SD-3C, LLC in the 
United States, other countries or both. 
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Regulatory Compliance 
 

 

EN 55032:2015 
EN 55024 
EN 60950-1 
 
This is a class A product. In a domestic environment this product may cause radio 

interference in which case the user may be required to take adequate measures. 

 

FCC part 15B, Class A 
ICES-003, Class A 
 
This equipment has been tested and found to comply with the limits for a Class A 

digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to 

provide reasonable protection against harmful interference when the equipment is 

operated in a commercial environment.  

 

Operation is subject to the following two conditions: (1) This device may cause 

harmful interference, and (2) this device must accept any interference received, 

including interference that may cause undesired operation. 

 

This equipment generates, uses, and can radiate radio frequency energy and, if not 

installed and used in accordance with the manufacturer’s instruction manual, may 

cause harmful interference with radio communications. Operation of this equipment 

in a residential area is likely to cause harmful interference, in which case you will 

be required to correct the interference at your own expense. 

 

This Class A digital apparatus complies with Canadian ICES-003. 

Cet appareil numérique de la classe A est conform à la norme NMB-003 du 

Canada.       

 

AS/NZS CISPR 32, Class A 

 

K 60950-1, KN 32 / KN 35 

이 기기는 업무용(A 급) 전자파적합기기로서 판매자 또는 사용자는 이 점을 

주의하시기 바라며, 가정외의 지역에서 사용하는 것을 목적으로 합니다. 

 

GB 4943.1 
GB/T9254, Class A 
GB 17625.1 
此为 A 级产品，在生活环境中，该产品可能会造成无线电干扰， 

在这种情况下，可能需要用户对干扰采取切实可行的措施。 
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NBTC 

 
Class A  

NBTC ID. A56012-19-1903 
เคร่ืองโทรคมนาคมและอุปกรณ์นีม้ีความสอดคล้องตามมาตรฐานหรือข้อก าหนดทางเทคนิคของ กสทช. 

 

IS 13252(Part 1)/ 
IEC 60950-1 

 

UL 60950-1/UL 62368-1 
CAN/CSA-C22.2 No. 60950-1 /62368-1 
 

Mexico CoC UL 60950-1 

 

CNS 13438    警告使用者：此為甲類資訊技術設備，於居 

CNS 14336-1  住環境中使用時，可能會造成射頻擾動，在此種 

CNS 15663    況下，使用者會被要求採取某些適當的對策。 

 

 

TP TC 020 

 

Energy Star for Imaging Equipment Version 3.0 
The menu setting System > Energy Star > Pwr Saver Time is default 

5 minutes and can be modified by user if desired. 

 

Important Safety Instructions: 
1. Read all of these instructions and keep them for later use. 
2. Follow all warnings and instructions on the product. 
3. Disconnect the power plug from the AC source before cleaning.  
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4. Do not use liquid or aerosol cleaners. Using a damp cloth is suitable for cleaning. 
5. The mains socket shall be installed near the equipment and easily accessible. 
6. The unit must be protected against moisture. 
7. Ensure the stability when installing the device, Tipping or dropping could cause damage. 
8. Make sure to follow the correct power rating and power type indicated on marking label provided 

by manufacture. 
9. Please refer to user manual for maximum operation ambient temperature. 

 

CAUTION:  

(For equipment with RTC (CR2032) battery or rechargeable battery pack) 
Risk of explosion if battery is replaced by an incorrect type. 
Dispose of used batteries according to the Instructions as below.  
1. DO NOT throw the battery in fire.  
2. DO NOT short circuit the contacts.  
3. DO NOT disassemble the battery.  
4. DO NOT throw the battery in municipal waste.  

5. The symbol of the crossed out wheeled bin indicates that the battery should not be placed in 
municipal waste. 

 Caution: The printhead may be hot and could cause severe burns. Allow the printhead to 

cool. 

CAUTION:  

Any changes or modifications not expressly approved by the grantee of this device could void the user's 
authority to operate the equipment. 

 
Below statement are for product with optional RF function.  

CE Statement: 
This equipment complies with EU radiation exposure limits set forth for an uncontrolled environment. This 
equipment should be installed and operated with minimum distance 20 cm between the radiator & your 
body. 
 
All operational modes: 
2.4GHz: 802.11b, 802.11g, 802.11n (HT20), 802.11n (HT40) 
5GHz: 802.11a, 802.11ac. 
 
The frequency, mode and the maximum transmitted power in EU are listed below: 
2400 MHz – 2483.5 MHz: 19.88 dBm (EIRP)(Wi-Fi) 
5150 MHz – 5250 MHz: 17.51 dBm (EIRP)(Wi-Fi) 
2402 MHz – 2480 MHz: 6.02 dBm (EIRP)(Bluetooth) 
 
Requirements in  
AT/BE/BG/CZ/DK/EE/FR/DE/IS/IE/IT/EL/ES/CY/LV/LI/LT/LU/HU/MT/NL/NO/PL/PT/RO/SI/SK/TR/FI/SE/C
H/UK/HR. 5150MHz~5350MHz is for indoor use only. 
 
5150-5350MHz for Only indoor use 
5470-5725MHz for indoor/outdoor use 
 
Restrictions In AZE 
National restrictions information is provided below 

Frequency Band Country Remark 

5150-5350MHz Azerbaijan 
No license needed if used indoor and 

power not exceeding 30mW 
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5470-5725MHz 

 
Hereby, PRINTRONIX Auto ID Technology Co., Ltd. declares that the radio equipment type [Wi-Fi] IEEE 
802.11 a/b/g/n/ac is in compliance with Directive 2014/53/EU 
The full text of the EU declaration of conformity is available on our website. 
 
Canada, Industry Canada (IC) Notices  
This Class A digital apparatus complies with Canadian ICES-003 and RSS-210.  
Operation is subject to the following two conditions: (1) this device may not cause interference, and (2) 
this device must accept any interference, including interference that may cause undesired operation of 
the device. 
 
Canada, avis de l'Industry Canada (IC) 
Cet appareil numérique de classe B est conforme aux normes canadiennes ICES-003 et RSS-210. 
Son fonctionnement est soumis aux deux conditions suivantes : (1) cet appareil ne doit pas causer 
d'interférence et (2) cet appareil doit accepter toute interférence, notamment les interférences qui peuvent 
affecter son fonctionnement. 
 
 

NCC 警語: 

經型式認證合格之低功率射頻電機，非經許可，公司、商號或使用者均不得擅自變更頻率、加大功率或變

更原設計之特性及功能。(即低功率電波輻射性電機管理辦法第十二條) 

低功率射頻電機之使用不得影響飛航安全及干擾合法通信；經發現有干擾現象時，應立即停用，並改善至

無干擾時方得繼續使用。 

前項合法通信，指依電信法規定作業之無線電通信。低功率射頻電機須忍受合法通信或工業、科學及醫療

用電波輻射性電機設備之干擾。(即低功率電波輻射性電機管理辦法第十四條) 

BSMI Class A 警語: 

這是甲類的資訊產品，在居住的環境使用中時，可能會造成射頻 干擾，在這種情況下，使用者會被要求採

取某些適當的對策。 

 
限用物質含有情況標示聲明 

單元 Unit 限用物質及其化學符號 

Restricted substances and its chemical symbols 

鉛Lead 

(Pb) 

汞Mercury 

(Hg) 

鎘

Cadmium 

(Cd) 

六價鉻

Hexavalent 

chromium 

(Cr+6) 

多溴聯苯

Polybrominated 

biphenyls 

(PBB) 

多溴二苯醚

Polybrominated 

diphenyl ethers 

(PBDE) 

內外塑膠件 ○ ○ ○ ○ ○ ○ 
內外鐵件 ○ ○ ○ ○ ○ ○ 
滾輪 ○ ○ ○ ○ ○ ○ 

電路板組件 - ○ ○ ○ ○ ○ 
晶片電阻 - ○ ○ ○ ○ ○ 
積層陶瓷表

面黏著電容 ○ ○ ○ ○ ○ ○ 

集成電路-

IC 
○ ○ ○ ○ ○ ○ 

電源供應器 ○ ○ ○ ○ ○ ○ 
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印字頭 ○ ○ ○ ○ ○ ○ 
馬達 - ○ ○ ○ ○ ○ 
插座 ○ ○ ○ ○ ○ ○ 
線材 ○ ○ ○ ○ ○ ○ 

備考 1.〝超出 0.1 wt %〞及〝超出 0.01 wt %〞係指限用物質之百分比含量超出百分比含量基準值。 

Note 1：“Exceeding 0.1 wt %” and “exceeding 0.01 wt %” indicate that the percentage content of the restricted substance exceeds the 

reference percentage value of presence condition. 

備考 2.〝○〞係指該項限用物質之百分比含量未超出百分比含量基準值。 

Note 2：“○” indicates that the percentage content of the restricted substance does not exceed the percentage of reference value of presence. 

備考 3.〝－〞係指該項限用物質為排除項目。 

Note 3：The “−” indicates that the restricted substance corresponds to the exemption. 
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Warnings and Special Information 
For your safety and to protect valuable equipment, read and comply with all information highlighted under 
special headings: 

WARNING Conditions that could harm you and damage the equipment. 

WARNING Achten Sie auf folgendes, um keine Personen in Gefahr zubringen bzw. das 

Gerät zu beschädigen. 

WARNING Condiciones que pueden causar daños a personas y equipos. 

WARNING Conditions à respecter pour éviter tout danger corporel et dommage matériel. 

WARNING Condizioni che possono arrecare danni alle persone e alle apparecchiature. 

CAUTION Conditions that could damage the printer or related equipment. 

IMPORTANT Information vital to proper operation of the printer. 

NOTE:  Information and helpful tips about printer operation. 

Important Safety Instructions 
 
1.  Read all of these instructions and keep them for later use. 
2.  Follow all warnings and instructions on the product. 
3.  Disconnect the power plug from the AC outlet before cleaning or if a fault occurs.  
4. Do not use liquid or aerosol cleaners. Using a damp cloth is suitable for cleaning printer surfaces. 
5.  The mains socket shall be installed near the equipment and easily accessible. 
6.  The unit must be protected against moisture. 
7.  Ensure the stability when installing the device. Tipping or dropping could cause damage. 
8.  Make sure to follow the correct power rating and power type indicated on marking label provided by 

manufacturer. 
9.  Please refer to user manual for maximum operation ambient temperature.  

 
WARNING  Hazardous moving parts, keep fingers and other body parts away. 

 
CAUTION  Risk of explosion if RTC battery is replaced by an incorrect type. Dispose of used 

batteries according to the Instructions listed below.  
• DO NOT throw the battery in fire.  

• DO NOT short circuit the contacts.  

• DO NOT disassemble the battery.  

• DO NOT throw the battery in municipal waste.  

• The symbol of the crossed out wheeled bin indicates that the battery should not be 
placed in municipal waste. 

 

CAUTION  The printhead may be hot and could cause severe burns. Allow the printhead to 

cool before servicing. 
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MFI Bluetooth 

 
 

Use of the Made for Apple badge means that an accessory has been designed to connect specifically to 
the Apple product(s) identified in the badge, and has been certified by the developer to meet Apple 
performance standards. Apple is not responsible for the operation of this device or its compliance with 
safety and regulatory standards.  

For US Model 

Made for iPhone® XS Max, iPhone XS, iPhone XR, iPhone X, iPhone 8, iPhone 8 Plus, iPhone 7, iPhone 7 
Plus, iPhone SE, iPhone 6s, iPhone 6s Plus, iPhone 6, iPhone 6 Plus, iPhone 5s, iPad Pro®  12.9-inch (2nd 
generation), iPad Pro 10.5-inch, iPad®  (6th generation), iPad (5th generation), iPad Pro 9.7-inch, iPad Pro 
12.9-inch (1st generation), iPad Air® 2, iPad mini™ 4, iPad mini 3, iPad Air, iPad mini 2, iPod touch® (6th 
generation) iPad, iPad Air, iPad Pro, iPhone are trademarks of Apple Inc., registered in the U.S. and other 
countries.  

For JP Model 

Made for iPhone XS Max, iPhone XS, iPhone XR, iPhone X, iPhone 8, iPhone 8 Plus, iPhone 7, iPhone 7 
Plus, iPhone SE, iPhone 6s, iPhone 6s Plus, iPhone 6, iPhone 6 Plus, iPhone 5s, iPad Pro 12.9-inch (2nd 
generation), iPad Pro 10.5-inch, iPad (6th generation), iPad (5th generation), iPad Pro 9.7-inch, iPad Pro 
12.9-inch (1st generation), iPad Air 2, iPad mini 4, iPad mini 3, iPad Air, iPad mini 2, iPod touch (6th 
generation) iPad, iPad Air, iPad Pro, iPhone are trademarks of Apple Inc., registered in the U.S. and other 
countries. The trademark “iPhone” is used in Japan with a license from Aiphone K.K.  

Except for US, JP Model 

Made for iPhone XS Max, iPhone XS, iPhone XR, iPhone X, iPhone 8, iPhone 8 Plus, iPhone 7, iPhone 7 
Plus, iPhone SE, iPhone 6s, iPhone 6s Plus, iPhone 6, iPhone 6 Plus, iPhone 5s, iPad Pro 12.9-inch (2nd 
generation), iPad Pro 10.5-inch, iPad (6th generation), iPad (5th generation), iPad Pro 9.7-inch, iPad Pro 
12.9-inch (1st generation), iPad Air 2, iPad mini 4, iPad mini 3, iPad Air, iPad mini 2, iPod touch (6th 
generation) 

iPad, iPad Air, iPad Pro, iPhone are trademarks of Apple Inc., registered in the U.S. and other countries.  
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Manual Conventions 
• Operator panel keys are printed in uppercase letters. 

Example: Press the PAUSE key and then press ENTER. 

• Operator panel keys are often shown by their symbol or icon (located on the control panel directly 
above the key). 

Example: Press the   key for ENTER. 

• Operator panel menu settings are often shown by their full location that includes the ICON name, 
submenu, and then menu, each separated with a ‘>’ sign. 

Example: Change the Media > Image > Label Length menu. 

• Control panel LCD messages are printed in uppercase letters inside quotation marks ( “ ” ). 

Example: When “OFFLINE” appears on the control panel LCD, you may release the PAUSE key. 

• Key combinations are indicated by the + (plus) symbol. 

Example: Press  +  means Press the Up  key and the Down  key at the same time. 
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1 Introduction 

The T800 Family of Printers 
NOTE:  The terms “T800” and “printer” refer to both the T820 (203 DPI) and T830 (300 DPI) models. 

The T800 series consists of a family of high quality, desktop direct thermal and thermal transfer printers 
specifically designed for printing labels and tags from multiple environments: 

• Windows®  

• Unix/Linux 

• MS-DOS®  

• SAP/ERP (PGL-based SAP device type) 

The T800 series is comprised of the products detailed in Table 1. 

 

Table 1. The T800 Series 

 

 

 

 

 

Standard Features 
• Thermal Transfer and Direct Thermal Printing 

• High Resolution Printhead: 203dpi or 300dpi for sharp graphics and text. 

• Sensors: Fixed media Gap, adjustable Black Mark sensor, Head Open, Ribbon End sensors 

• User Interface: 3.5” color LCD screen, with 9 button keyboard 

• 128MB DDR3 memory (fixed). 

• 128MB NAND Flash memory (fixed). 

• Auto Label Mapping® : For compatibility with programs written for Printronix line matrix printers. 

• Bar Codes: Supports multiple types of 1-D and 2-D bar codes. 

• Download: Fonts, forms, and graphics to printer memory. 

• Emulations: 

o Printronix PGL®  for text, barcodes, graphics, lines, and boxes. 

o Printronix LinePrinter Plus®  (LP+) for direct compatibility with Printronix P-Series printers, 
Epson FX-1050, Proprinter IIIXL, and Serial Matrix Printers. 

o Printronix VGL. Emulates the QMS Code V™ Version II programming language. 

Version 
Max Print 

Speed (ips) 
Printing 
Density 

Max Print 
Width 

T820 8 203 4.1 

T830 6 300 4.1 



 

Page | 21 
 

o ZGL interpreter for legacy ZPL (Zebra® ) applications 

o TGL interpreter for legacy TEC (TEC® ) applications 

o IGL interpreter for legacy IPL (Intermec® ) applications 

o STGL interpreter for legacy SPL (SATO® ) applications 

o DGL interpreter for legacy DPL™ (Datamax®) applications 

o IEGL interpreter for legacy IER-520®  (IER® ) applications 

o MGL interpreter for legacy MPCL II®  (Monarch® ) applications 

o EGL interpreter for Eltron®  applications 

• Serial RS-232: DB9 connector 

• USB 2.0 Universal Serial Bus (Type B) 

• USB / host 2.0 (Type A): The USB host port shall be capable of supporting USB memory 
devices. 

• Network Interface Port: This interface allows you to attach the printer to a LAN (Local Area 
Network). The port is visible on the back panel. The Ethernet port is a 10/100Base and supports 
data transfer rates up to 100 Mbps. The PrintNet Enterprise Suite (PNE) remote management 
software can be downloaded from our website at no cost. 

• Real Time Clock (RTC): The RTC has an internal battery. The clock keeps track of the year, 
month, day, hour, minute and second values. It will continue to operate when the printer is off. 
Graphic languages can use the RTC values to program fields in labels to indicate the date and/or 
time. 

• Resident Fonts (Standard Firmware): Letter Gothic Bold (#93779), Courier Bold (#93952), CG 
Triumvirate Bold Condensed (#92250), OCR-A (#90993), OCR-B (#91409), CG Triumvirate 
(#92244), CG Triumvirate Bold (#92248), and CG Times New Roman (#92500). 

• Mini SD memory card slot: Supports SD cards from 4 to 32 GB. 

Optional Features 
Ask your authorized representative about the following enhancement options: 

• Peel Dispenser: Peels off labels one at a time before printing the next label. Liner is ejected to 
front of printer. 

• Media Cutter: Automatically cuts printed media when the media exits the printer.  

• RFID MP2 Encoder: The RFID (Radio Frequency Identification) UHF encoder reads and writes 
information to smart labels (with embedded RFID tags) with a pitch typically two to six inches. 
These labels are used on shipping cartons and pallets. Not available as a field installed option 
(factory only). 

• Premium Asian Fonts: A selection of three different purchasable Asian fonts can be provided 
(one font per SD card). These Asian fonts include Hanzi GB, Kanji SJIS, and Hangul. They are 
available for use when the SD card is installed. 

• Andalé Fonts: A selection of four different purchasable Andale fonts can be provided (one font 
per SD card). The Andale fonts will become active when the SD card is installed. 

• QCMC (Quick Change Memory Card): The QCMC SD card provides the ability to duplicate an 
entire printer’s firmware, saved configurations, and custom files quickly through the printer’s 
control panel with a user friendly interface. 

• Bluetooth 4.2: The BT 4.2 adapter provides wireless communications protocol designed for low 
power usage, within a short range. Not available as a field installed option (factory only). 
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• Wireless Network: This card provides wireless 802.11a/b/g/n/ac/b/g/n connectivity without 
expensive cabling and reconfigurations required from a wired network. Wi-Fi Alliance certified. 
PNE is standard with this option. Not available as a field installed option (factory only). 

For more information about printer options, see Appendix B page 250. 
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2 Operation 

Controls and Indicators 

Power Switch 

The power switch is located on the bottom back left panel of the printer. To apply power, place the switch in 
the  | (ON) position. When you first power on the printer, an initialization sequence will immediately appear 
on the color LCD control panel. 

To remove power, place the power switch in the O (OFF) position. 

Control Panel 

The control panel is located on the top of the printer and includes a Status LED, QVGA color display, 
PAUSE key, FEED key, LEFT SOFT key, RIGHT SOFT key, and navigation keys (buttons) with the 
ENTER button in the center. These are described in the following tables. 

 

 
 
 
 

The QVGA (quarter VGA) screen is a 320 x 240 pixel color display (non-touch). It is comprised of a 
Header that shows the printer state and location with the User Interface (UI), the general display area, 
and a footer used to show the purpose of the LEFT and RIGHT SOFT keys (when available).  
 

The status LED indicates when the printer is ONLINE, OFFLINE, or when there is a fault condition: 

• LED is on solid: ONLINE and Ready to Print. 

• LED is off: OFFLINE and not accepting data.  

• LED is flashing: Fault Indicator. 

Navigation / Enter 
Status LED 

RIGHT SOFT key 

FEED Key 

LEFT SOFT key 

PAUSET key 
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Button Description Functionality 

 

 

PAUSE Key 

Toggles the printer between 

ONLINE and OFFLINE Modes. 

When ONLINE, sets printer to OFFLINE Mode 

and the UI to the Home Screen. 

When OFFLINE, puts the printer back ONLINE. 

 

 

 
 

 
 
 
 
 

FEED Key 
 

 
 
 

 

Advances the media one label length. When 

ONLINE, the menu System Control > Feed Key 

Online must be enabled for this key to function. 

 
 

 
 
 
 
 

Navigational Keys 

The navigational menus consist 
of up, down, left, and right keys 

with a   ENTER button in the 
center for selection. 
 

 
 
 

 

Used to select icons, menu selection, and 

navigation in the UI. 

 
 

 
 
 
 
 

Soft Keys 

There is a LEFT and RIGHT 
SOFT key on the sides of the 
navigational menus. The labels 
on the footer of the UI will 
explain their function. 
 

 
 
 

 

Check the labels on the footer of the UI screen. 

The meaning of the soft keys will vary. 

 

NOTE: The printer is shipped with the ENTER button locked. To unlock, press the UP+DOWN arrow keys 
simultaneously until you see the message “ENTER SWITCH UNLOCKED”.  

Operating Modes 
The operating mode can be selected through the control panel keys or can result from routine operations 
such as powering on the printer. 

Online: In ONLINE mode, the printer can receive and print data sent from the host. Pressing the PAUSE 
key toggles the printer between the ONLINE and OFFLINE modes. The Status LED indicator is on. 

Offline (Home): When the printer goes OFFLINE, the Status LED is off and the UI is in Home Screen. From the 
Home Screen, the user has three different icons to choose from: 1) Wizard, 2) Settings, and 3) Calibrate. The 
green highlighted icon is the current selection. Pressing the PAUSE key toggles the printer from Home 
Screen to ONLINE mode. 

Settings: When Settings is chosen from the Home Screen, the user has access to the printer menus by 
navigating icons and traversing menu lists. Configurations can be saved using the Configs icon or by use of 
the Auto-Save feature when returning ONLINE. 

Wizard: When Wizard is chosen from the Home Screen, the user can perform different areas of printer setup 
with the help of detailed explanations, references to online videos, and other material. On the first power-cycle, 
the user will automatically be taken into the Printer Setup Wizard. 

Fault: In fault mode, a fault condition exists that must be cleared before printing can continue. The Status 
LED indicator flashes, and the UI shows the Fault screen. 

Before normal printing can continue, the fault must be corrected, the message cleared by pressing the 
PAUSE key, and the printer placed ONLINE. 
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Online Screen 
When the printer is ONLINE and ready to receive data, the ONLINE screen is shown. By default, this will 
be the first screen the user sees after the power-up process has completed. In order to demonstrate the 
full features of the ONLINE Screen, the following options are assumed: 

• Model T820 (203 DPI) 

• Network is installed and IP is set 

• Wi-Fi is installed and IP is set 

• The printer has a Network Printer Name 

• The Media > Handling > Print Mode is set to Transfer (ribbons). 

• RFID and Bluetooth are installed and enabled 

• The Active Configuration has been saved under a custom name “Warehouse” 

• The menu option under System > Control > Batch Counter is enabled. 

 

The illustration above has labels associated with each of the ONLINE screen features which are 
described in the table below. Notice there are differences for the wired Ethernet and wireless ONLINE 
screens. 

 

Item Description 

1 The full model name includes the printer width and DPI. 

2 
The Network Printer Name can be set via telnet, SNMP, or the webpage 
and is used with Ethernet or WLAN features. 

3 The Ethernet IP address is displayed if the IP address is set (non-zero). 

4 The active IGP Emulation and the active Host IO (based on last job).  

5 
This area is reserved for messages such as receiving data, batch 
counters, and job status.  

6 
The Bluetooth icon will show when the Bluetooth option is installed and 
active. If installed but not active it will be shown in light gray color. 

7 

The RFID icon will show when the RFID option is installed and active. If 

installed but not active it will be shown disabled.  

8 The last loaded configuration is referred to as the “Active Config”. 

9 
The print head gauge is used to show how much of the print head has 
been used in relationship to the warranty. 

10 The ribbon gauge is used when a ribbon is installed (thermal transfer). 
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Item Description 

11 
The WLAN IP address is displayed if the IP address is set (non-zero). 
There is also a signal strength indicator next to the WLAN address. 

12 The WLAN signal strength is displayed in dBm 

13 The WLAN active channel 

14 The WLAN SSID 

If there is a warning that needs to be displayed while ONLINE, a popup message will come onto the 
screen. For example, entering Power-Saver mode, Print Head Hot, etc. 

Offline (Home) Screen 
When the printer is taken OFFLINE using the PAUSE Key , the UI will show the Home screen. 
The Home screen will be the first screen seen by the user when transitioning from ONLINE to OFFLINE. 
The right corner of the header may include the  symbol in case there are faults in the system not yet 
cleared. 

Using the navigational keys, the user can move among three options: 

• Wizard – Provides Setup Instruction, Web Resources, and other links to the Printronix website via QR 
barcodes for Product Support. 

• Settings – Provides access to the printer menu system for configuration. 

• Calibrate – Makes Calibration convenient and easy to perform when media or ribbon are installed. 

  

There are also functions for the LEFT and RIGHT SOFT keys. The LEFT SOFT key “Cancel Data” is 
present if there is data within the buffer and the setting System > Control > Cancel Operation is enabled. 
The RIGHT SOFT key labeled “Info” will show the current configuration as text on the UI and the user can 
scroll through the data and/or print if desired. 

Wizard  

The Wizard has several resources available as shown in the next figures. The greatest benefit of the 
Wizard is the first subcategory “Wizards”. By highlighting this category (green) and pressing ENTER or 
the RIGHT ARROW key, the user can then select the Wizard of choice to run:  

• Printer Setup will help the user choose the proper display language, install ribbon & media, set media 
and sensor options, calibrate, and run a test pattern to verify the product is working properly.  

• Print Quality helps the user adjust the printer mechanically, and set Print Speed and Intensity of the 
printer. A test printout helps the user in making the choices. 

• Application helps the user setup the menu configuration particular to their label or application coming 
from the host system. 
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 →  

When a Wizard has been completed (all steps executed until the end), the user is required to save their 
configurations per usual procedure (see Configuration). The exception to this is the first time the printer is 
powered up; in this case, the user is automatically taken into the Printer Setup Wizard and the 
configuration is automatically saved to Config 1 when completed. 

The Wizard also has support available in the form of QR barcodes for the other categories such as “Web 
Links”, “Order Supplies”, etc. These QR barcodes provide links to the company website to view online 
videos, manuals, drivers, including places where they can order supplies and register their product. 

 →  

Settings  

The Settings section of the menu represents the heart of the OFFLINE process in which users will peruse 
the full menu set, edit menus, run diagnostics, and save configurations. The Settings section begins with 
two pages of ICONs that can be selected using the navigational keys and the ENTER button. 

 

      

 

NOTE: The printer is shipped with the ENTER button locked. To unlock, press the UP+DOWN arrow keys 
simultaneously until you see the message “ENTER SWITCH UNLOCKED”.  

When an ICON is selected, the user moves into the View Level in which the screen is divided with the 
submenus on the left and the menu subsections on the right. As they traverse the submenus using the 
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up/down arrow keys, the menu subsections on the right change so that users can quickly see the menu 
contents. 

 

 
 

To view the full contents of a particular subsection or edit their menus, the user can either press ENTER 
or use the RIGHT ARROW key to get into the Edit Level. Conversely, the user can hit the LEFT ARROW 
key to return to the previous screen. 

 

When in the Edit Level, the user can scroll the menus and their values using the up/down arrow keys. The 
user can edit any menu that has the icon  by pressing the ENTER key, changing the value, and 
confirming their change using the “Apply” soft key on the right. There is also a “Cancel” soft key on the 
left, if the user does not want to accept the change. 

 

If the menu has a bolt  icon, this is an executable menu and pressing the ENTER key will result in a 
particular action (e.g., running a print test, clearing statistics). If the menu does not have any icon, then it 
is a read-only menu and pressing ENTER key will not have any effect. 
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Calibrate  

Calibration must be performed whenever new media or ribbon is installed or any configuration parameter 
that affects sensors is modified. Selecting this shortcut ICON and pressing the ENTER key will activate 
the Auto-Calibrate function, also available in Sensors > Calibrate > Auto Calibrate. 

Fault  

When faults occur, the user will be notified with the following screen on the display. The red color is used 
to make a clear indication that the printer needs attention. 

 

Users can follow the simple instructions shown in the screen or request additional help with the faults by 
using the RIGHT SOFT key “Fault Help” if available. When Fault Help is selected, the user will be 
provided a set of screens to help them through the process. However, Fault Help is only offered for faults 
that are complex or require several steps with the printer mechanism. 

The user can also choose via the LEFT SOFT key to go the “Home” screen, then to the Settings or 
Wizard sections to adjust menu values (e.g., change media parameters, load Configs, etc.).  

NOTE:  The icon will be shown in the upper right corner as a reminder there is a fault that needs 

to be cleared. Even when the user has completed all the steps necessary, the icon may 

continue to be shown. Some faults are self-clearing in the OFFLINE state while other faults 

are cleared only when returning ONLINE. If any fault was not successfully cleared, the Fault 

screen shown above will reappear when the user attempts to return ONLINE. 

Job in Process 

There is no dedicated LED or status indicator for Job in Process. Users will know the printer is receiving 
data instead via messages in the circled portion of the ONLINE screen as shown below. 

 

When the printer is in ONLINE mode and data is being received and being processed, the message “Job 
in Process” will be shown in the message area. After the job has been printed the message will go away. 
If the user is printing in batch mode and the option System > Control > Batch Counter is enabled, the 
page count will have priority over the ‘Job in Process’ message. 

When the printer is in OFFLINE mode and in the Home screen, the LEFT SOFT key will be labeled 
“Cancel Data” if there is Data in Buffer when the printer is taken OFFLINE. If there is no Data in Buffer, then 
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the LEFT SOFT key label will not show anything. In order for the Cancel Data operation to be available, the 
menu System > Control > Cancel Operation must be enabled. 

Media Handling Modes 
Depending on the media handling options installed, there are up to four modes that can be selected. The 
factory default is Tear-Off Strip. 

• Tear-Off Strip. Prints on the media and sends it out the front until the print buffer is empty. It then 
positions the trail edge of the last label over the tear bar for removal. 

• Continuous. Prints on the media and sends it out the front of the printer. 

• Peel-Off. When the optional peel-off assembly is installed, the printer prints and peels die-cut labels 
from the liner without user assistance. A “Remove Label” message will display to remind you to 
remove the label before the next one can be printed. For more information, see Label Peel-Off. 

• Cut. When the optional media cutter is installed, the printer automatically cuts media after each label 
is printed or can cut the media after a specified number of labels have been printed using the Active 
IGP Emulation cut command. 

 

Once you have decided on the mode, configure the printer. 
 

 

Setting Up the Printer 
This section describes the procedures for loading various types of ribbon and media. 

The term “media” in this manual refers to all the different kinds of paper, label, or tag stock material that 
can be printed on by the printer. Your thermal printer can print on continuous paper, adhesive backed 
labels, or non-adhesive tags packaged in roll or fanfold form. 

For clarity, all operator touch points are blue in color. 

 

IMPORTANT For best result, use only genuine Printronix supplies. See “Supplies and 

Accessories”. 

CAUTION  Do not wear rings or other metallic objects while servicing any interior area of 

the printer. 

CAUTION DO NOT TOUCH the printhead or the electronic components under the pivoting 

deck. The discharge of electrostatic energy that accumulates on the surface of 

the human body or other surfaces can damage or destroy the printhead or 

electronic components used in this device. 

CAUTION Do not close the pivoting deck without label stock installed between the 

printhead and the platen, because debris on the platen may damage the 

printhead. 

IMPORTANT Adhesive backed labels that DO NOT lay flat on the liner can jam the printer. This 

can cause the label to peel off the liner. The exposed edges can stick to the label 

guides and rollers inside the printer. 

  If you run out of labels while printing, do not turn off the printer while reloading 

labels, because you can lose data. 

Loading Ribbon 
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For direct thermal media (no ribbon required), go to “Loading Media” section. 

 

IMPORTANT  Clean the printhead, platen roller, and media sensors every time you change the 

ribbon. See Cleaning the Printhead, Platen Roller, Media Sensors/Damper. 

 

1. Open the printer top cover by pulling the blue levers, located on each side, toward the front of the printer, 

then lift the top cover. 

               
 

2. T800 supports 3 kinds of paper core for ribbon. 

 

▪ For 1 inch paper core without notches, please insert the ribbon spindles into the paper core and 

ribbon.  

 

  
 

 
 

▪ For 1 inch & 0.5 inch paper core with notches, do not need to install the ribbon spindles. 

 

      
 

    
 

3. Install the paper core and ribbon to the hubs. For 0.5 or 1 inch paper roll with notches on both sides, 

please insert them at the hubs directly. 

Note: Please follow the direction when 
installing the ribbon spindle. 
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4. Pull the leader of the ribbon through the print head and stick the leader of the ribbon onto the ribbon 

rewind paper core. 

 

 
 

 

 

 

 

 

5. Turn the blue ribbon rewind hub until the ribbon plastic leader is thoroughly wound and the black 

section of the ribbon covers the print head. 

Note: Please insert the right side of spindle 
first. Then, insert the left side to the 
hole at the left side of the blue hub. 

Ribbon 

Paper core for 
rewinding the used 
ribbon 
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Loading Media 
 
1. Open the printer top cover by pulling the blue levers , located on each side, toward the front of the 

printer, then lift the top cover. 
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2. Separate and hold open the blue media holders. 
 

 
 
3. Place the roll between the holders and close them onto the core. 
 

 
 
4. Separate the blue media guides. 

 

 
 

Note:  
▪ For black mark media or media with notch or holes used to indicate label length, the blue Black 

Mark sensor is moveable. Slide it to correct position for detecting. 
▪ For RFID model, slide the blue antenna slide to the correct position. 
 

Media guide 

Black mark 
sensor 

RFID antenna 
slide (if equipped) 
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5. Place the paper, printing side face up, through the media sensor and place the label leading edge 
onto the platen roller. Move the blue media guides to fit the label width. 

 

     
 
 
6. Press down on both sides of the top cover to close it gently. 
 

 
 

7. Initiate Auto Calibrate via the Home Screen ICON , selecting this shortcut ICON and pressing the 
ENTER key will activate the Auto-Calibrate function. Calibration may also be activated via the 

Sensors  menus within the  Settings  section (Sensors > Calibrate > Auto Calibrate). 
 

Note:  Calibration must be performed whenever new media or ribbon is installed or any configuration 

parameter that affects the sensors is modified. 

 

Your printer is equipped with media sensors that detect the top-of-form position on media with label 

length indicators (gaps, notches, holes, or black marks). These sensors also detect when a Paper Out 

condition exists.  
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Loading External Media 
 
If using either an external media holder or folded labels, feed the media through the rear external label 
entrance chute. 
 
1.  Open the printer top cover by pulling the blue levers, located on each side, toward the front of the 

printer, then lift the top cover. 
 
2.  Separate and hold open the media holders. 
 
3.  Set the media holder lock switch to down to keep the media holders separated. 
 

 
 
4.  Feed the paper from rear external label entrance chute, printing side face up, through the media 

sensor and place the label leading edge onto the platen roller. Move the media guides to fit the label 
width. 

 

 
 
5.  Press down on both sides of the top cover to close it gently. 
 

6.  Initiate Auto Calibrate via the Home Screen ICON , selecting this shortcut ICON and pressing the 

ENTER key will activate the Auto-Calibrate function or initiate calibration via the Sensors  menus 
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within the  Settings  section (Sensors > Calibrate > Auto Calibrate). 

Positioning the Media Sensors 

Your printer is equipped with two media sensors that detect the top-of-form position on media with label 
length indicators (gaps, notches, holes, or black marks). These sensors also detect when a Paper Out 
condition exists. You may select via the Control Panel which sensor will be used, based on the type of 
media to be printed. 

 

 

Black Mark Sensor (Moveable/ Reflective) Gap Sensor (Fixed/ Transmissive) 

The black mark sensor position is moveable. 
Move the triangular mark (▽ ) directly into the 

path of the black mark on the underside of the 
media, or extraneous cut-out (notch or hole) to be 
used for detection. Please make sure there is no 
dark pre-printing or RFID tags that could cause 
false black mark detection or paper out faults 
within the path of the sensor. 

The gap sensor is in a fixed position in the 
center, covering an offset 4 mm to right or 7 mm 
to left from center. The default is located in 
center of offset 4 mm. Please make sure the 
media has no vertical gap, rounded die-cut label 
corners or dark pre-printing that could cause 
false gap detection or paper out faults. 

 

  

 
Gap sensor 
(Transmitter) 

 
Gap sensor (Receiver) 

 
Black Mark sensor 
(Transmitter & 
Receiver) 

Avoid Dark 
Pre-printing 

Extraneous 
Cut-out 

Vertical Gap and 
Rounded Die-cut Label 
Corners 
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Sensing Different Media Types 

The printer’s media sensors can detect the different types of label length indicators on a large variety of 
media types. This is accomplished by selecting the correct sensor option: Gap, Mark, or Disable under 
Sensors > Control > Gap/Mark Sensor menu or within the “Printer Setup” Wizard. 

1. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

2. Find the Settings ICON and press ENTER. 

3. Press the UP + DOWN ARROW keys together until “ENTER SWITCH UNLOCKED” displays. 

4. Find the Sensors ICON and press ENTER. 

5. Select the “Control” submenu and press ENTER. 

6. Find the “Gap/Mark Sensor” option and press ENTER to edit this menu. Find the option that matches 
the type of label length indicators on the installed media displays:  

Disable. Select when using media with no label length indicators (no gaps, notches, holes, or black 
marks) or when you want the printer to ignore all existing label length indicators on the installed media. 

Mark. Select when using media that has horizontal black marks located on the underside of the label 
liner or tag stock or when using media with notches or holes as label length indicators. 

Gap. Select when using media with a liner space between die-cut labels or has horizontal black marks 
located on the topside of the label. 

NOTE:  When you select Disable, the length of each label is based on the Media > Image > Label Length 

menu or the value sent via host software. 

NOTE:  If the printer detects a false PAPER OUT message when you change to Gap or Mark sensing 

or vice-versa, find the Home Screen and run Calibrate  

7. Press ENTER to enable the displayed option or use the RIGHT SOFT key labeled “Apply”. An asterisk 
(*) appears next to the selection. 

8. Press the PAUSE key or the LEFT SOFT key labeled “Home” to return to the Home Screen. 

9. Review Media with Gaps 

10.  

1. Media with a horizontal liner space between die-cut labels or horizontal black marks located on the 
upper side of the label liner. 

2. Select “Gap” in the Sensors > Control > Gap/Mark Sensor menu. 

3. Perform an Auto Calibrate. See Running Auto Calibrate on page 40. 

11. Calibrating the Media Sensors on page 39. Perform the Auto Calibrate procedure per Running Auto 
Calibrate on page 40. 
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Sensors > Control > Gap/Mark Sensor 

The available options specify the sensor type needed for detecting the Top-
of- Form position on media with label length indicators (gaps, notches, 
holes, or black marks). 

Disable 

Select when using media with no label length 
indicators (no gaps, notches, holes, or black marks), 
or when you want the printer to ignore all existing 
label length indicators on the installed media. 

Mark 

Select when using media that has horizontal black 
marks located on the underside of the label liner or 
tag stock. Also used for tag stock with notches, or 
holes used as label length indicators. 

Gap 
Select when using media with a horizontal liner space 
between die-cut labels or horizontal black marks 
located on the upper side of the label liner. 

 
 
 

Media with No Label Length Indicators 

1. When using media without label length indicators (no gaps, notches, holes, or marks) or when you want 
to ignore all existing length indicators, place the triangle mark ▽ on the media sensor assembly in the 

center of the media so it can detect when a Paper Out condition exists. 

2. Select “Disable” in the Sensors > Control > Gap/Mark Sensor menu. See Section “Sensors > Control”. 

3. Perform an Auto Calibrate. 

Media with Underside Horizontal Black Marks 

1. Position the triangle mark ▽ on the media sensor assembly in the center of the horizontal black marks 

located on the underside of media. 

2. Select “Mark” in the Sensors > Control > Gap/Mark Sensor menu. 

3. Perform an Auto Calibrate. 

Media with Gaps, Notches or Holes 
 

1. Position the triangle mark ▽ on the media sensor assembly in the path of the gaps, notches, or holes 

in media. 

2. Select “Mark” in the Sensors > Control > Gap/Mark Sensor menu. 

3. Perform an Auto Calibrate. See Running Auto Calibrate on page 40. 

Media with Gaps 
 

4. Media with a horizontal liner space between die-cut labels or horizontal black marks located on the 
upper side of the label liner. 

5. Select “Gap” in the Sensors > Control > Gap/Mark Sensor menu. 

6. Perform an Auto Calibrate. See Running Auto Calibrate on page 40. 
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Calibrating the Media Sensors 

Due to manufacturing differences in media, the media sensors may have difficulty differentiating between 
the label and the liner or the label and the black mark. When this occurs, the printer may intermittently skip 
a label or display a fault message such as “GAP NOT DETECTED” or “PAPER OUT”. 
 
Media sensor sensitivity and reliability can be improved by changing the Sensors > Control > Gap/Mark 
Thresh and/or Sensors > Control > Paper Out Thresh values. You can change these values manually or 

automatically by performing an Auto Calibrate  or Manual Calibrate procedure from the Sensors > 
Calibrate menu section. (The changes take effect immediately within the current configuration menu.) 

Auto or Manual Calibrate is completed successfully when the displayed Sensed Distance value correctly 
matches that of the installed media. When Gap is selected, the Sensed Distance should match the length 
from the trailing edge of one gap to the trailing edge of the next gap (or one label + one gap). When Mark is 
selected, the Sensed Distance should match the length from the leading edge of one black mark to the 
leading edge of the next black mark. 

When you have completed Auto or Manual Calibrate, you can verify the new values are correct by pressing 
the FEED key several times. Each time you press FEED, media advances one label and stops at the correct 
Top-of-Form position of the next label. 

Once you confirm the correct values, save them to the desired configuration menu before powering off the 
printer. 

Running Auto Calibrate 

You can initiate Auto Calibrate via the Home Screen ICON  or via the Sensors  menus within the  

Settings  section. 

NOTE:  Verify that the Gap/Mark Sensor option (Gap, Mark, or Disable) matches the installed media. 

Check that the media sensors are horizontally positioned to permit sensing of the label length 

indicators. See Positioning the Media Sensors.  

Make sure the Media > Image > Label Length value matches the physical length of the installed 

media. Entering the correct length forces the printer to advance media far enough during 

calibrate for long labels (so actual gaps, notches, and marks can be detected) and reduce the 

amount of media advanced for short labels. 

If you try to do an Auto Calibrate  when Peel-Off Media Handling is enabled, the LCD will 

display “CANNOT CALIBRATE” error. Before you can do an Auto Calibrate, you must select 

another media handling mode. 
 

1. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

2. Select the Calibrate  ICON and press the ENTER key. 

3. Media advances until it can accurately detect the label length indicators and then stops at the Top-of-
Form position. The Sensed Distance value will then display for one second. 

4. Auto Calibrate is successful when the Sensed Distance value correctly matches that of the installed 
media: 

Gap/Mark Sensor = Gap: The Sensed Distance value is the physical length of one label plus the 
length of one gap, notch, or hole. 

Gap/Mark Sensor = Mark: The Sensed Distance value is the physical distance from the leading edge 
of one black mark to the leading edge of the next black mark. 

Gap/Mark Sensor = Disable: Not applicable. If Gap/Mark Sensor is set to Disable, the Sensed Distance 
value will not be updated. 

If “GAP NOT DETECTED” displays, run Auto Calibrate again. 
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If Auto Calibrate continues to end with an incorrect Sensed Distance value displayed or a fault message 
displayed, refer to Running Manual Calibrate on page 43. 

NOTE:  The amount of media sampled during Auto Calibrate is based on the length of a label and 

transitions detected, without error, between a label and its label length indicators. 

5. Press the FEED key several times. Each time you press FEED, the media advances one label length and 
stops. 

NOTE:  After a form feed, the position of the leading edge of the next label depends on the type of 

Media Handling mode selected under Media > Handling > Media Handling menu. Tear-Off Strip 

Media Handling will position the label edge at the tear bar, while Continuous will position the 

label edge under the printhead. 

6. Once the Sensed Distance value is confirmed, you can save them to a desired configuration menu 
before powering off the printer or you can press the PAUSE key and the printer will automatically display 
a reminder message that your changes have not been saved and to select one of four possible choices.  

7. Once completed the printer will go ONLINE. 

Running Media Profile 

The Media Profile printout shows the relationship of the Paper Out Threshold and the Gap/Mark 
Threshold values, illustrates if and when each label length indicator is detected, and shows the difference 
between the label length indicators and the label. The profile printout (shown here) helps you set the 
thresholds for difficult media. This includes pre-printed labels and labels with poor gap/media dynamic 
range. 

Once Media Profile is initiated, the printer will continue to advance media and print the profile in 
landscape orientation until you press ENTER to stop printing. 

NOTE:  Verify the Sensors > Control > Gap/Mark Sensor option (Gap, Mark, or Disable) matches the 

installed media. 

You will need a minimum installed label width of two inches to support the Profile printout. 

Ensure the media sensors are horizontally positioned to permit sensing of the label length 
indicators. Positioning the Media Sensors.  

Ensure the Media > Handling > Print Mode option matches the media installed. Select “Direct” 
for heat sensitive media (no ribbon required) or “Transfer” for thermal transfer media (ribbon 
required). 

1. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

2. Find the Settings ICON and press ENTER. 

3. Press the up and down arrow keys together until “ENTER SWITCH UNLOCKED” displays. 

4. Find the Sensors ICON and press ENTER. 

5. Select the “Diagnostic” submenu and press ENTER. 

6. Find “Media Profile/Profile Print” and then press ENTER to start the profile printing process. 

 The printer will advance media and continue to print a dynamic profile image depicting the 
relationship of the label and any label length indicators detected. 

7. Press  ENTER to stop the profile printing. 

8. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

NOTE:  The Gap/Mark and Paper Out Threshold values shown on the Profile printout represent the 

last values determined from a successful Auto or Manual Calibrate or the factory default 
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values if no Auto or Manual Calibrate was performed.

 
Figure 1 Media Profile Printout 

 

Gap Sensing 

This figure shows a Media Profile printout of a RFID label where the Gap/Mark Sensor is set to Gap in the  
Sensors > Control menu. 

In this example, the gap threshold value the printer selected (represented by the Gap/Mark dotted line) is 
too close to the value seen for the RFID antenna. This may cause the printer to falsely use the antenna as 
the gap (top-of-form).  

NOTE: Refer to the RFID Labeling Reference Manual for full details on how to set up the printer to 
properly run RFID labels. 
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To avoid this problem, increase the Threshold Range value to 60% or 70% in the Sensors > Calibrate> 

Threshold Range (the default is 50%), then perform a Running Auto Calibrate page 40. 

Any changes to Threshold Range will not take effect until you run an Auto Calibrate again. 

This will raise the Gap/Mark threshold high enough so that the printer will not falsely use the antenna as 
the gap (top-of-form). 

 

Running Manual Calibrate 

Manual Calibrate should be performed only when the values derived from Auto Calibrate fail to improve 
the media sensors’ ability to sense label length indicators on the installed media. Manual Calibrate is 
located in the Sensors > Diagnostics section. 

NOTE:  Verify the Gap/Mark Sensor option (Gap, Mark, or Disable) matches the installed media. 

Ensure the media sensors are horizontally positioned to permit sensing of the label length 
indicators. 

Ensure the Media > Handling > Print Mode option matches the media installed. Select “Direct” 
for heat sensitive media (no ribbon required) or “Transfer” for thermal transfer media (ribbon 
required). 

If you try to do a Manual Calibrate when Peel-Off Media Handling is enabled, the LCD will 
display a “CANNOT CALIBRATE” error. Before you can do a Manual Calibrate, you must 
select another media handling mode. 

1. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

2. Find the Settings ICON and press ENTER. 

3. Press the up and down arrow keys together until “ENTER SWITCH UNLOCKED” displays. 

4. Find the Sensors ICON and press ENTER. 
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5. Select the “Diagnostics” submenu and press  ENTER. 

6. Find “Manual Calibrate” and then press  ENTER to start the process. 

7. Follow the instructions displayed on the LCD and press the  ENTER key to move to the next step. 

8. During the last step of Manual Calibrate, the printer will advance the media and attempt to detect the 
label length indicators and stop at the Top-of-Form position. The Sensed Distance value will then 
display for one second. The calibrate is successful when the Sensed Distance value correctly matches 
that of the installed media. If “CALIBRATION FAIL” error displays, run Manual Calibrate again. 

NOTE:  The amount of media sampled during Manual Calibrate is based on the length of a label and 

the transitions detected without error, between a label and its label length indicators. 

9. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

10. Press the FEED key several times. Each time you press FEED, the media advances one label length 
and stops. 

NOTE:  After a form feed, the position of the leading edge of the next label depends on the type of 

Media Handling mode selected via Media > Handling > Media Handling. Tear-Off Strip Media 

Handling positions the label edge at the tear bar, while Continuous positions the label edge 

under the printhead. 

11. Once the correct values are confirmed, save them to the desired configuration menu before powering 
off the printer. 
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Label Peel-Off (Optional) 
You can set up the printer to automatically peel die-cut labels off their liner (backing) and dispense them 
one at a time while rewinding the liner. For installation information, refer to Appendix D. 

Loading Media Using Peel-Off Mode 

1. Please follow Loading Media on page 33 above to load the media and calibrate the sensors before 
the next step to avoid paper jams. 

2. Open the peel-off front door. 
 

   
 

3. Thread the media (label and liner) over the tear bar and around the peel-off roller, then through the 
opening at the bottom of the front door. The label liner will be fed to the floor. 
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4. Close the peel-off front door. 

 

 

 

5. Press down on both sides of the top cover to close. 

 

Configuring the Printer Menu 

1. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

2. Set Media Handling to “Peel-Off” within the Application Wizard or directly in Media > Handling > Media 
Handling menu. 

3.  Back to ONLINE. 

4.  The printer is ready on Label Peel-Off Mode. 

5.  Press the FEED key. The label advances to the peel-off position, and “Remove Label” displays on the 
LCD. 

6.  Manually remove the peeled label from the printer. 
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Media Cutter (Optional) 
You can set up the printer to automatically cut printed media when the media exits the printer. For 
installation information, refer to Appendix C. 

Loading Media Using Cutter Mode 

1. Please follow "Loading Media" above to load the media and calibrate the sensors before the next step 
to avoid paper jams. 

2. Thread the media through the opening at the media cutter. 

                          

 

Configuring the Printer Menu 

1. Press the PAUSE key to place the printer OFFLINE (Home Screen). 

2. Set Media Handling to “Cut” within the Application Wizard or directly in Media > Handling > Media 
Handling menu. 

3. Back to ONLINE. 

4.  The printer is ready on Cut Mode. 

5.  Press FEED key to test. 
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Printing Adjustments 
 

Printhead Burn Line Adjustment 
 

The print head burn line adjustment are used to fine tune the print quality for different thicknesses of 

media. Adjust the print head’s burn line forward or backward as it relates to the platen roller. 

 

The print head burn line default is set for general purpose printing media (plain paper and paper thickness 

less than 0.20mm). In general, print head burn line adjustment will not be required. If you have poor print 

quality, please try changing the print speed or print intensity first, before moving the burn line. 

 

Poor print quality when using paper thicker than 0.20mm may be due to the print head burn line not being 

at the optimized position. Please refer to the steps below to improve the print quality. 

 

1.  Open the printer to remove the front cover. 

 

       
 

2.  Adjust the knobs on right and left sides to get your best print quality. There are 7 levels of adjustment. 

Adjust both knobs to the same level. The default setting is 4. 

 

 
 

3.  Adjust the burn line position and test print as necessary until the printed image is clear. 

 

4.  Re-install the front cover after adjusting. 
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Cleaning 
Depending on the media used, the printer may accumulate residues (media dust, adhesives, etc.) as a 
by-product of normal printing. To maintain top printing quality, you should remove these residues by 
cleaning the printer periodically. 

WARNING Set the printer power switch to O (Off) prior to performing any cleaning tasks. 

Leave the power cord connected to keep the printer grounded and to reduce 

the risk of electrostatic damage. 

IMPORTANT When the printer is powered Off, menu settings that were changed and not 

saved and any print data remaining in the print buffer will be lost. To prevent 

the loss of recent menu changes, see Configuration setting on page 52. 

CAUTION • Do not wear rings or other metallic objects while cleaning any interior area of 

the printer. 

• Use only the cleaning agents recommended in this section. Use of other 
cleaners may damage the printer and void its warranty. 

• Do not spray or drip liquid cleaning solutions directly into the printer. Apply 
the solution on a clean lint-free cloth and then apply the dampened cloth to the 
printer. 

• Do not use canned air in the interior of the printer as it can blow dust and 
debris onto sensors and other critical components. 

• Only use a vacuum cleaner with a nozzle and hose that are conductive and 
grounded to drain off static build up. 

• All reference in these procedures for use of isopropyl alcohol requires that a 
99% or greater isopropyl alcohol content be used to reduce the risk of 
moisture corrosion to the printhead. 

Exterior Cleaning 

Clean the exterior surfaces with a clean, lint-free cloth. If necessary, use a mild detergent or desktop 
cleaning solution. 

Interior Cleaning 

Clean the interior of the printer by removing any dirt and lint with a vacuum cleaner, as described above, 
or use a brush with soft non-metallic bristles. 

Cleaning the Printhead, Platen Roller, Media Sensors/Damper 

NOTE:  Even though the printhead, platen roller, media sensors and media damper are individually 

listed in these cleaning procedures, debris and adhesive on these components can ultimately 

travel to the printhead area and therefore should be cleaned and examined each time the 

printhead is cleaned and in the order shown. 

Printhead Cleaning 

As you use your printer, the printhead may become dirty with ribbon residue and label adhesives which 
can result in poor print quality. Keeping the printhead clean will help maintain its life. 

• Cleaning Agent - Clean the printhead using a Printhead Cleaning Pen, Printronix PN 203502-
002 or an Isopropyl Alcohol Wipe, Printronix PN 254945-901. 

• Schedule - Clean the printhead each time you install a new roll of ribbon (thermal transfer print 
mode) or when you install a new roll or box of media (direct thermal print mode). 
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WARNING  If you have just been printing, allow one minute for the printhead to cool 

down to avoid burns from accidental printhead contact. 

CAUTION • Avoid electrostatic damage to the printhead by first making hand contact with 

an unpainted part of the printer frame or by using an anti-static wrist strap 
grounded to the printer frame. 

• Do not use hard, sharp or abrasive objects to remove residue from the 
printhead. 

• Do not touch the heating element surface of the printhead with your hands to 
avoid printhead corrosion. Any accidental skin contact with the element surface 
should be immediately followed by a thorough cleaning with a Printhead 
Cleaning Pen or an Isopropyl Alcohol Wipe. 

• The heating element surface should be free from any condensation to avoid 
corrosion. 

1. Remove the media and ribbon, if installed. 

2. Clean the printhead by gently rubbing an Isopropyl Alcohol Wipe or the felt tip of a Printhead Cleaning 
Pen across the print heads’ light-brown heating elements area. Allow the printhead to dry for one minute 
before reloading ribbon or media. 

 

NOTE:  Even after a thorough cleaning with a Printhead Cleaning Pen or Alcohol Wipe, you may still 

see printouts with voids or streaks. This may be the result of baked-on ribbon resin that can be 

hard to remove when normal cleaning cycles are not maintained. Try using a Thermal Printer 

Cleaning Card 4”W x 6”L PN TSCCC-4-15. When using a cleaning card, follow the directions 

on the packaging.  

Platen Roller Cleaning 

Label parts, media dust, and adhesive residue on the platen can degrade print quality and cause voids in 
your label image. 

• Cleaning Agent - Use an isopropyl alcohol wipe or small amount of isopropyl alcohol on a clean 
cloth to clean the platen roller. 

• Schedule - Clean the platen roller each time you clean the printhead. 

1. Clean the platen roller by first removing any label parts from its surface by hand. Then use an isopropyl 
alcohol wipe or clean cloth moistened with isopropyl alcohol to remove any remaining paper dust, 
debris, or label adhesive. The platen roller can be rotated forward by hand to access and clean its 
entire surface area. 

NOTE:  Even though power is removed from the platen motor, some drag will be felt as you rotate the 

platen. 

2. Check the platen roller for razor cuts, nicks, and gouges that may cause voids in the printed image. 
This type of damage usually requires platen roller replacement. 

Media Sensor Cleaning 

The upper and lower media sensors should be cleaned to ensure reliable Top of Form and Paper Out 
sensing. 

CAUTION  Do not use isopropyl alcohol, solvents, or abrasive agents to clean the lower 

media sensor as they can damage the sensors lens cover. 

• Cleaning Agent - Use a brush with soft, non-metallic bristles or a vacuum cleaner, described above, 
to remove paper dust. 
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NOTE:  An Isopropyl Alcohol Wipe or Printhead Cleaning Pen can be used to remove label adhesive 

from the upper sensor. 

• Schedule - Clean the media sensors each time you clean the printhead. 

1. Brush away or vacuum any dust or debris from the upper and lower sensor before using the cleaning 
pen or wipe. 

 

Cutter Option Cleaning 

The cutter requires only periodic cleaning. 

WARNING Keep your fingers away from the cutter blades. They are sharp. 

Perform the following procedure whenever too much dust or debris is visible. 

1. Set the printer power switch to O (Off). 

2. Place the cutter in the down (open) position. 

3. Use a vacuum or can of compressed air with a nozzle around the area of the cutter blade to remove 
any dust or debris. 

4. Use a cloth with a light amount of WD-40 oil to clean adhesive from the cutter blade and upper or 
lower stainless steel cutter guides. Adhesive oil must be cleaned from the blade and guides with a dry 
cloth to prevent dust attraction. 

CAUTION  Do not use isopropyl alcohol to clean the cutter blade – it dissolves oils 

required for lubrication. 

5. Place the cutter in the up (closed) position. 

6. Properly route the media through the printer and cutter. 

7. Set the printer power switch to | (On). 

8. Test the printer cutting operation by running a test print within the Tools > Print Tests > Run Test 
menu.  

 

  



 

Page | 52 
 

3 Printer Settings 

Overview 
This chapter provides information about: 

• Setting, saving, modifying, and printing configurations 

• Structure of the configuration 

• Menu and Configuration Parameters 

 

Unlocking the Control Panel 

Press the UP ARROW key and the DOWN ARROW key simultaneously to unlock the Control Panel. This 
step is necessary to save any configurations. 

Setting Printer Configuration Parameters  

Configuration parameters are set from the control panel and stored into the printer’s flash memory. The 
parameters define how the printer will respond to command and interface signals from the host computer. 

The  Settings section is where the complete set of menus and configuration parameters are located. 
The T800 menu system is three levels deep and consists of the ICON Level, View Level, and Edit Level.  

The ICON Level. The top level of the menu system is known as the ICON Level and consists of two screens 
as shown below. The green shading shows the current icon selected. The arrow keys are used to select 
different icons (and even move between screens).  

 

     
 

IMPORTANT  The RFID icon is grey to symbolize that these options are not installed. When 

colored grey, an icon cannot be selected.  

When the desired icon is highlighted, the user must press  ENTER to move into the View Level. 

The View Level. The 2nd level of the menu system is known as the View Level and is separated into a 
left and right screen. On the left side are submenus, and on the right are the actual menus or 
configuration parameters. The up/down arrow keys will move to different submenus (highlighted in green) 
and the right side will show a preview of the configuration parameters available for that submenu. 
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When the desired submenu is highlighted, the user can press  ENTER or the RIGHT ARROW key to move 

into the Edit Level. Likewise, the user can use the LEFT ARROW key to move back to the ICON Level.  
 

The Edit Level. The last level of the menu system is known as the Edit Level and contains all the 
configuration parameters for a given submenu. The user can scroll through the menus using the up/down 
arrow keys to view the current configuration values.  

 

 
 

For menus that have the edit icon , the user can modify the value by pressing the  ENTER key to enter 

Edit Mode. If the menu has a bolt  icon, this is an executable menu and pressing the ENTER key will 
result in a particular action (e.g., running a print test, clearing statistics). If the menu does not have any 
icon, then it is a read-only menu and pressing ENTER key will not have any effect. 

 

IMPORTANT  When entering the Edit Mode, a message “ENTER SWITCH LOCKED” may 

appear. In this case, the user will not be allowed to enter Edit Mode until the 
panel is unlocked. To unlock the configuration, press the UP+DOWN arrow keys 
simultaneously until you see the message “ENTER SWITCH UNLOCKED”.  

 

In the Edit Mode, depending on the type of menu, the user may be given a pull-down menu of options or 
cycle through a set of numbers with an asterisk next to the current value. In cases where large numbers, 
strings, or network IP addresses must be entered, a virtual keyboard will be shown in which users can 
navigate to different characters or numbers. The examples below show Edit Mode with a pull-down menu 
and a virtual keyboard. 
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When users are in Edit Mode, they can change to a new value by either pressing the  ENTER key, or 

using the RIGHT SOFT key to “Apply”. Likewise, the users can exit Edit Mode without any modification to 
the menu by using the LEFT SOFT key to “Cancel” the operation. 

For menus with an action icon , the user can execute the particular action by pressing the  ENTER key. 

For menus without any icon, these are read-only menus and cannot be modified. 

 
IMPORTANT  Some sensitive menu operations require the user to confirm they want to 

proceed. For example, menu operations that clear logs, delete configuration, 
delete files, etc. In these cases, a message will appear on the screen asking them 
to confirm by pressing “OK” with one of the soft keys. 

Users can return to the View Level by pressing the LEFT ARROW key or go to the Home menu screen 
by using the LEFT SOFT key labeled “Home”. 

 

NOTE:  Changing menu values as described in this section only changes the Current Configuration. 

The Current Configuration is stored in DRAM and is in effect only while the printer is powered 

on. To store a configuration permanently into FLASH memory, see Configurations section on 

page 52. 

Saving a Configuration  
 

When you make a change to the configuration menus, your changes reside in the Current Configuration 
saved in DRAM. The Current Configuration is in effect while the printer is powered on. 

If you want to save your configuration permanently into FLASH memory, then you have two options: 

• Save the configuration by following the instructions within the Auto Save feature when you return to 
the ONLINE state. 

• Select the Configs icon under  Settings and save the configuration with Configs > Control > 
Save Config.  

Your printer by default has a Factory Configuration. You can save up to eight different configurations to 
meet unique print job requirements. Using the Configs > Control section, you can save, load, print, delete, 
and choose which configuration will be active at power-up. 
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Auto Save Configuration 

If you make any changes to the current configuration menu items and do not save them manually via the 
Configs > Control > Save Config menu, you will be prompted to save the changes just before you place the 
printer ONLINE with the screen shown below. 

 

The Active Configuration is defined as the power-up configuration or last loaded configuration. There 
are three possible cases with this choice depending on the state of the printer: 

• If the Active Configuration is one of the eight user-defined configurations, the Active Configuration will 
be saved and made the Power-Up Configuration. 

• If the Active Configuration is the Factory Configuration, the printer will save the configuration to the 
first free (unsaved) configuration and make that open configuration the Power-Up Config. 

• If the Active Configuration is the Factory Configuration and there are no free (unsaved) 
configurations, then the user will be informed with a message and asked to save the changes 
manually. The printer will return to the Home Screen. 

The Current Configuration is the configuration stored in DRAM. If the user selects this option, the 
configuration will not be saved into FLASH memory permanently but will continue to be active. 

The user also has the option of cancelling their changes by loading either the Active Configuration or the 
Factory Configuration. 

Once the selection is made, the user will return to the ONLINE state automatically. 

Naming Configurations 

You may specify a 15-character name which can be used to refer to a configuration in the Configs > 
Custom section. The name you enter for a configuration will then be used everywhere within the    

Config section. The names can be cleared by using the Configs > Custom > Reset Cfg Names menu. 
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When a configuration to name is selected, a virtual keyboard will be provided for the user to enter the 
name desired. The navigation keys can be used to find characters with the ENTER button used to select 
them. When the string is complete, the user should use the RIGHT SOFT key labelled “Apply”. 

 

Loading a Configuration 

You can specify any one of the nine configurations (1-8 or Factory) to load into DRAM using the Configs > 
Control > Load Config menu. If the selected configuration has not been saved, the user will be warned 
with a “CONFIG DOES NOT EXIST” message on the panel.Specifying a Power-Up Configuration 

Specifying a Power-Up Configuration 

You can specify any one of the nine configurations (1-8 or Factory) as the power-up configuration using 
the Configs > Control > Power-Up Config menu. If the selected configuration has not been saved, the 
user will be warned with a “CONFIG DOES NOT EXIST” message on the panel. 

Modifying a Saved Configuration 

Configurations can be modified and saved (updated) as often as desired. You can load a configuration of 
choice with Configs > Control > Load Config, change the menu or configuration parameter of interest and 
either use the Auto Save feature or return to the Configs > Control > Save Config menu to save the 
changes.  

Viewing the Current Configuration 

The Current Configuration can be easily viewed on the control panel by selecting the RIGHT SOFT key 
labeled “Info” on the Home screen. This will provide the same information in a Configuration Printout 
except it is viewable on the control panel.  
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As can be seen from the picture, the user can scroll through the configuration values and choose to print 
the configuration using the RIGHT SOFT key labelled “Print”. 
 

Printing a Configuration 

We recommend that you print and store all saved configurations for future reference. The printout 
provides a list of the parameters that were set when you configured the printer. Configuration can be 
printed using the Configs > Control > Print Config menu. That menu has the following options: 

• Current (the default) 

• Factory 

• Power-Up 

• All 

• Saved Configurations 1-8 
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Settings Organization  
This section will show how the configuration menus are organized under the icons in the Settings section. 

 

Screen #1 

Quick Setup  
Media 
Sensors 
Application 
Configs 
Admin User 

Media   
Image 
Speed 
Handling 
Ribbon 
Top of Form 
Faults 
Auto Label Map 

Sensors   
Control 
Calibrate 
Diagnostics  

System   
Control 
Energy Star 
Flash File View  
Flash File Edit 
SD File View1 
SD File Edit1 

USB File View1 
USB File Edit1 
Printer Mgmt 
Date 

Host I/O  

Control 
USB 
Serial 
Bluetooth5 
Host USB6 

 

Network   

Control 
Ethernet3 

WLAN2 
WLAN Params2 

WLAN EAP2 

 

 

Screen #2 

Application  

Control 
PGL … EGL Setup 
LP+ Setup 
P-Series … Setup 
Fonts 

RFID4   
Control 
Tag Calibration 
Calibration Params 
RFID Chip Params 
Profiling Tools 
Diagnostics 
Statistics 

Tools    
Print Tests 
Diagnostics 
Advanced 
PTF Debug 
PTF Flags 
Statistics 
About 

Configs  

Control 
Custom 

 
 

 
NOTE: 

1  The SD or USB related submenus will only show when installed. 
2 WLAN is an option and these submenus are included only when WLAN is installed. 
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3  Ethernet menu is not available if WLAN option is installed unless an Ethernet cable is attached at 
power-up. 

4  RFID is only available when the RFID option is installed. Refer to the RFID Labeling Reference 
Manual for information on these menus. 

5  Bluetooth is an option and these submenus are included only when Bluetooth is installed. 
6 These menus are only available when a Host USB HID device is installed such as a keyboard, 

barcode reader, or scale. 

Quick Setup  
Quick Setup is a collection of the most typical setup parameters from different sections gathered in one 
place. It is designed to help the users quickly find these parameters and get the printer installed and running.  

There is also a feature called “Admin User” that administrators can use to restrict users to the Quick Setup 
functionality and not allow them to go into the other sections. Under the Admin User subsection of Quick 
Setup, the administrator can setup a password (1-10 digits) and enter “Safe Mode” which will then hide all 
the other icons, leaving only Quick Setup. Safe Mode can only be disabled by entering the password. 

Menu Items 

The menu items under Quick Setup are the following: 

 

Quick Setup Menu Description / Location of Menu 

Media   

   Print Intensity Media > Image > Print Intensity 

   Print Speed Media > Speed > Print Speed 

   Media Handling Media > Handling > Media Handling 

   Paper Feed Shift Media > Image > Paper Feed Shift 

   Label Width Media > Image > Label Width 

   Label Length Media > Image > Label Length 

   Vertical Shift Media > Image > Vertical Shift 

   Horizontal Shift Media > Image > Horizontal Shift 

 

Quick Setup Menu Description / Location of Menu 

Sensors  

   Gap/Mark Sensor Sensors > Control > Gap/Mark Sensor 

   Auto Calibrate Sensors > Calibrate > Auto Calibrate 
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Quick Setup Menu Description / Location of Menu 

Application  

   Active IGP Emul Application > Control > Active IGP Emul 

   XXX Diagnostics Application > Control > XXX Diagnostics 

   RFID Active* RFID > Control > RFID Active 

 

* Menu available only when Option is installed 

 

Quick Setup Menu Description / Location of Menu 

Configs  

   Save Config Configs > Control > Save Config 

   Power-Up Config Configs > Control > Power-Up Config 

   Load Config Configs > Control > Load Config 

 

Quick Setup Menu Description / Location of Menu 

Admin User  

   Set Password Only available in Quick Setup when not in Safe Mode. 

   Enter Safe Mode Only available in Quick Setup when not in Safe Mode. 

   Exit Safe Mode Only available in Quick Setup when in Safe Mode. 

 

Entering Safe Mode 

Safe Mode is an optional feature that administrators can use to restrict access to the printer menus and 
settings. The additional benefit of this mode is that once the complete setup has taken place, administrators 
can enable this feature to make it easier for daily users to find and change the most typical menus. 

By default, the printer is not in Safe Mode. The administrator enables Safe Mode by going into Quick Setup 
> Admin Users section and doing the following: 

• Setting up a Password via Quick Setup > Admin Users > Set Password. 

• Entering Safe Mode via Quick Setup > Admin Users > Enter Safe Mode. 

The password can be any string of 1-10 digits. See the screenshots below on how this is done and what to 
expect. Note that once the password is set, it will display when not in Safe Mode. 
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Exiting Safe Mode 

When the administrator wants to exit safe mode, they will also need to return to Quick Setup > Admin 
Users section and enter the Password via Quick Setup > Admin Users > Exit Safe Mode. If the wrong 
password is entered, the following screen be shown. 

 

There is no lockout if you enter the wrong password several times, so you can continue to try. If you 
cannot find or remember the password, then see section Forget the Password below. 

Forgot the Password 

If you forget the password to exit Safe Mode, then contact your Printronix Customer Support team for 
more help unlocking the printer. 
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Media  
IMPORTANT  All distances under Media can be represented in inches or millimeters based 

on the menu System > Control > Media Units. 

Intro: Label Length 

Understanding your media and application is very important when configuring the parameters in the menu 
system. When setting label length, consider the following: 

Label Length can be manually entered via the control panel Media > Image > Label Length menu or sent 
via the host application (e.g., PGL job) using the appropriate software command. If sent via a software 
command, that is referred to as a Host Forms Length or Logical Label Length. 

A Host Forms Length (Label Length) value sent from the host computer can override Media > Image > Label 
Length value if the emulation chooses to do so. Often, the emulations will have a menu to configure that 
behavior (e.g., Application > PGL Setup > Host Form Length). 

Physical Label Length is the actual measurable length of the label. The following list of different media 
types explains how the physical label lengths are determined: 

• Die-cut labels – measurable length of the removable label (leading edge to trailing edge). This does not 
include the liner material or gap. 

• Tag Stock with notches or holes – measurable length from the trailing edge of one notch or hole to the 
leading edge of the next notch or hole. 

• Tag Stock with black marks on underside – measurable length from the leading edge of one black mark 
to the leading edge of the next black mark. 

• Continuous media (no label length indicators) – measurable length should be within ± 1-2% the Label 
Length value entered in the Media > Image > Label Length menu or the value sent via host software 
command. 

Logical Label Length (or Host Forms Length) is the length that a user or programmer bases his printable 
image on. In most cases this length should be slightly less than the Physical Label Length. This allows the 
entire image to be printed within the boundaries of the label length indicators (gaps, notches, holes, or black 
marks). 

When the Logical Label Length is greater than the Physical Label Length and Media > Image > Clip Page 
is “Enable”, the printer will clip the bottom portion of the image that exceeds the Physical Label length. In 
this case, the printable data that was not printed will be lost. There is more on Clip Page menu in the next 
section. 

Intro: Clip Page 

The media sensor looks for the gap, notch, hole, or black mark only after the media has advanced the 
distance specified by the Media > Image > Label Length menu or by the Host Forms Length coming from 
the application. Any gaps, notches, holes, or black marks that exist prior to reaching the Label Length or 
Host Forms Length value are ignored. 

When Media > Image > Clip Page is “Disable”, Mark and Gap media sensing reliability can be improved and 
the sensor problems described below can be fixed: 

• The image starts to print at an erroneous distance from the top-of- form, especially towards the end 
of a roll where the media is severely curled or scalloped. 

• The image is incorrectly positioned as a result of the media sensor triggering off of a dark, pre-
printed image on the label or multiple gaps within the label. 

• The printer starts to print one label and then another all on the same physical label, especially at 
the end of a roll where the media is severely curled. 
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• An occasional blank label appears within a print job (in between printed labels). 

When Clip Page is “Disable”, the printer ignores any pre-printed dark marks or multiple gaps on a label that 
could mistakenly be detected as the next top-of-form position based on the specified Media > Image > Label 
Length value. 

 

IMPORTANT  When Clip Page is “Disable”, the correct Media > Image > Label Length value must 

be entered. If the value is too large, the printer will ignore the actual gap or mark 
it needs to detect.  

• When using Gap sensing, the Label Length value is equal to the physical length of a die cut or 
removable label.  

• When using Mark sensing, the Label Length value is the physical distance from the leading edge 
of one black mark to the leading edge of the next black mark. 

 

When the Logical Label Length is greater than the Physical Label Length and Clip Page is “Disable”, the 
printer will continue to print the image onto the next physical label and ignore the gap or mark based on the 
Media > Image > Label Length value. 

When the Logical Label Length is less than the Physical Label Length, the printer will print the entire image 
and leave blank space the remaining length of the physical label as it advances to the Top-of-Form of the 
next label. This is true regardless of the Media > Image > Clip Page setting. 

Media > Image 
 

Media > Image > Print Intensity 

This option specifies the level of thermal energy from the printhead to be used 
for the type of media and ribbon installed. Large numbers imply more heat 
(thermal energy) to be applied for each dot. This has a significant effect on 
print quality. The print intensity and speed must match the media and ribbon 
type to obtain the best possible print quality and barcode grades. 

Minimum -15  

Maximum +15 

Factory Default -3 

IMPORTANT 

The actual print intensity is the sum of both the 
Print Intensity menu and the Intensity Shift menu. 
For example, if Print Intensity = 5 and Intensity 
Shift = -3, then the actual print intensity used is 2. 
However, the actual intensity is bounded with a 
minimum of -15 and maximum of 20. 
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Media > Image > Intensity Shift 

This menu can be used to shift Print Intensity settings higher or lower. This 
allows for higher print intensity settings for certain media while maintaining a 
compatible Print Intensity value set by the host job. It can also be used to 
make slight adjustments for compatibility with other emulations. 

Minimum Lighter -9  

Maximum Darker +9 

Factory Default 0 

IMPORTANT 

While the shift can swing -9 to +9, the actual print 
intensity value is bounded with a minimum of -15 
and maximum of 20. 

 
 
 

Media > Image > Paper Feed Shift 

This option represents the distance to advance (+ shift) or pull back (– shift) 
the stop position of a label when Tear-Off Strip, Peel-Off, or Cut Media 
Handling option is enabled. Allows .01 inch increments. 

Minimum -1.00 inches  

Maximum Current Label Length (or 12.80 inches maximum) 

Factory Default 0.00 inches 

IMPORTANT 

The pull back (- shift) will be limited to the print 
line position in order to prevent media from being 
pulled back beyond the print head and falling off 
the platen roller. 
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Media > Image > Label Length 

This option specifies the user-selected Label Length. In most applications, 
the user-selected Label Length will match the physical label length. Physical 
label length is the actual label length of the media installed: 

Die-cut Labels: Measurable length of the removable label (leading edge to 
trailing edge). This does not include the liner material or gap. 

Tag Stock with notches or holes: Measurable length from the trailing edge of 
one notch or hole to the leading edge of the next notch or hole. 

Tag Stock with black marks on underside: Measurable length from the leading 
edge of one black mark to the leading edge of the next black mark. 

Continuous media (no label length indicators): Measurable length should be 
within ± 1-2% the Label Length value here or the value sent via host software 
command. 

Minimum 0.1 inches  

Maximum 50.0 inches 

Factory Default 6.0 inches 

IMPORTANT 

This menu can be overridden by the host job (Host 
Form Length) and set to values that do not match 
the physical length. For a full description of how 
Label Length behaves, see the section Intro: Label 
Length on page 62. 

 

Media > Image > Label Width 

This option specifies the physical width of the image to be printed.  

Minimum 0.1 inches  

Maximum Maximum based on printer model/printhead. 

Factory Default 4.1 inches 
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Media > Image > Set Label Length 

This feature selects whether the Sensed Distance value derived from an 
Auto or Manual Calibrate will be used to set the Label Length menu. If no 
calibration is performed, this menu has no effect. 

Manual 
The Sensed Distance will not override or change the 
Label Length value. 

Automatic 

The Sensed Distance value will override and change 
the Label Length value. If Sensors Control > 
Gap/Mark Sensor = Gap, the printer will subtract the 
Sensors > Calibrate > Gap Length value. 

Factory Default Automatic 

IMPORTANT 
For Automatic setting, the Sensors > Calibrate > 
Use Label Length is ignored (treated as disabled). 

 

Media > Image > Clip Page 

This option determines how the printer handles images that are too large for 
one physical page length when using gap or black mark media. 

Disable 

When the user-selected page length (logical length) is 
greater than the physical page length dictated by the 
gap, notch, hole, or black mark on media, the printer 
continues to print the remaining excess data onto the 
next physical page. 

Enable 

The printer clips any excess data to fit the physical 
page. The excess data is lost. The media sensor 
constantly looks for the gap, notch, hole, or black 
mark and when detected, uses it as the TOF position 
for the next label and clips any remaining data. 

Factory Default Enable 

IMPORTANT 
See Intro: Clip Page 62 for more explanation when 
this menu option is disabled. 

  

Media > Image > Vertical Shift 

This option specifies the amount to shift an image vertically up (-) or down 
(+) for precise positioning on the label. The actual height of the image is not 
affected by this parameter. The adjustment is made in .01 inch increments.  

Minimum -1.00 inches 

Maximum Label Length (max 12.80 inches) 

Factory Default 0.00 inches 
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Media > Image > Horizontal Shift 

This option specifies the amount to shift an image horizontally left (-) or right 
(+) for precise positioning on the label. The actual width of the image is not 
affected by this parameter. The adjustment is made in .01 inch increments.  

Minimum -1.00 inches 

Maximum 1.00 inches 

Factory Default 0.00 inches 

 

Media > Image > Orientation 

This menu item selects the image orientation to be used when printing the 
label. See picture below for an illustration. 

Portrait 
Portrait refers to vertical page orientation, where the 
top of the page is at the leading edge. 

Landscape 
Landscape is a rotation of the logical page at 90 
degrees clockwise from Portrait. 

Inv. Portrait 
Inverse Portrait is a rotation of the logical page at 180 
degrees from Portrait. 

Inv. Landscape 
Inverse Landscape is a rotation of the logical page at 
270 degrees clockwise from Portrait. 

Factory Default Portrait 

IMPORTANT 

The orientations shown here are with Print 
Direction set to Head First. Some IGP Emulations 
such as ZGL use Foot First. In that case, the 
orientations would be 180 degrees different for all 
selections shown here. 
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Media > Image > Print Direction 

This option is the compass for print orientation. Not all IGP Emulation 
languages have the same definition of Portrait, Landscape, etc. The 
illustration below shows how Portrait is defined for both Head First and 
Foot First. 

Head First 
With Orientation set to Portrait, the top of the label will 
come out of the printer first. 

Foot First 
With Orientation set to Portrait, the bottom of the label 
will come out of the printer first. 

Factory Default 
Head First for PGL, but Foot First for ZGL. It will 
automatically be set for plug’n play compatibility. 

IMPORTANT 

Print Direction will not change the orientation of 
any print test patterns in the Tools > Print Tests 
menu. 
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Media > Image > Vertical DPI Adj 

Adjusts the vertical print resolution. This can be used to compress or 
expand all printed forms by small amounts.  

Minimum 
195 (203 DPI) 

290 (300 DPI) 

Maximum 
210 (203 DPI) 

310 (300 DPI) 

Factory Default Match Head DPI 

 

Media > Speed 
  

Media > Speed > Print Speed 

This option specifies the speed in inches per second (ips) at which the 
media passes through the printer while printing. 

Minimum 1 ips 

Maximum 
T820: 8 ips 

T830: 6 ips 

Factory Default 6 ips 

 

Media > Speed > Reverse Speed 

This option sets the speed at which the media moves in reverse direction.  

Minimum 1 ips 

Maximum 
T820: 8 ips 

T830: 6 ips 

Factory Default 2 ips 

IMPORTANT 
Speeds above 2 ips may cause ribbon smudging 
depending on ribbon and media. 
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Media > Speed > Slew Speed Control 

Controls how slew speed is chosen. By default, it will match Print Speed. 

Automatic Always the same as the print speed. 

Manual 
Allows you to set the slew speed independently from 
Print Speed by unhiding the Media > Speed > Slew 
Speed menu.  

Factory Automatic 

 

Media > Speed > Slew Speed 

When the Media > Speed > Slew Speed Control is set to Manual, this menu 
is unhidden. The range and defaults are consistent with Print Speed. 

Minimum Same as Print Speed minimum 

Maximum Same as Print Speed maximum 

Factory Default Same as Print Speed 

IMPORTANT 
Only available when Media > Speed > Slew Speed 
Control is set to Manual. 

 

Media > Handling 
  

Media > Handling > Print Mode 

This option specifies the type of printing to be done.  

Transfer Indicates Thermal Transfer printing (ribbon installed). 

Direct 
Indicates Direct Thermal printing (no ribbon) and 
requires special heat sensitive media. 

Factory Default Transfer 
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Media > Handling > Media Handling 

This option specifies how the printer will handle the media (labels or tag 
stock).  

Tear-Off Strip 
Printer prints on the media and sends it out the front 
until the print buffer is empty, then positions the last 
label over the tear bar for removal. 

Peel-Off 

Prints and peels die-cut labels from the liner without 
assistance. The printer waits for you to take away the 
label before printing the next one (on-demand 
printing). A “REMOVE LABEL” message will display 
to remind you to remove the label before the next one 
can be printed. See Label Peel-Off and Media > 
Handling > Peel Present for more information.  

The error message “INCOMPATIBLE WITH CUTTER” 
displays if this mode is selected when the optional 
cutter installed. 

Cut 

When the optional media cutter is installed, it 
automatically cuts media after each label is printed or 
after a specified number of labels have been printed 
when a cut command from the host has been issued. 
It cuts continuous roll paper, labels, or tag stock. 

The error message “OPTION NOT INSTALLED” 
displays if this mode is selected when the optional 
cutter is not installed. 

Continuous 
Printer prints on the media and sends it out the front. 
See Media > Handling > Continuous Mode  

Factory Default Tear-Off Strip 
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Media > Handling > Continuous Mode 

Allows selection of special media modes when Continuous Media Handling 
mode (Continuous Media) is selected.  

Standard 

Labels are printed and sent out the front. The cross 
perforation following the last printed label is not 
aligned at the tear bar. No auto feeding of a blank 
label should exist between print jobs, but you may 
need to press the FEED key to move approximately 
.80 inches of the last printed label from under the 
printhead. If performed, this feed causes a blank label 
at the beginning of the next print job. 

Tear-Off 

Same as Standard, but the cross perforation following 
the last printed label is aligned at the tear bar. No 
blank label is needed to remove the last printed label. 
No blank label should exist between print jobs. A no 
print zone, .80 inches long, exists from the leading 
edge of each printed label. This option supports label 
lengths 1.96” inches or longer. 

Tear Strip Full 

Same as Standard, but the cross perforation following 
the last printed label is automatically aligned at the 
tear bar once the print buffer is empty for a period of 
Tear-Strip Time. (Media does not get aligned at tear 
bar until Tear-Strip Time expires.) When printable 
data is again detected, a blank label is automatically 
fed, resulting in one blank label between each print 
job. This option supports label lengths 2.50 inches or 
longer. Shorter label lengths cause two or more blank 
labels to be automatically fed at the beginning of each 
print job. 

Cut Strip 

When Media Handling is set to Continuous and a 
cutter is installed, Cut Strip will use the respective 
host interface Timeout menu setting to determine the 
End Of Job (EOJ) and cycle the cutter. That is, the 
cutter will be cycled when there is no more data being 
received from the host. The cut will not be done for 
printing that is not initiated by the host such as form 
feeds and test printing or if the host interface is not 
set to Auto Switching. 

Factory Default Standard 
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Media > Handling > Peel Present 

This feature allows you to select which part of a label gets presented to the 
peel bar. 

Next TOF 

Media is moved to next TOF after image printing 
before presenting media to the peel-off position. This 
option is for standard labels where the gap/mark 
length is less than the printhead to peel bar distance 
(about 1/2 inch). 

End of Form 

Media is moved to the end of form after image printing 
before presenting media to the peel-off position. This 
option is for labels that have wide gaps that result in 
labels falling off the peel bar. This setting works with 
non-mark media where the end of form is not the 
same as the next TOF. This setting is useful for die 
cut labels where the physical bottom of the label can 
be detected by the media sensor. 

End of Image 

Image prints and media moves to peel-off position. 
This option is for labels that have wide gap/marks that 
result in labels falling off the peel bar. This selection is 
intended for cases where presenting the next TOF or 
end of form still results in labels falling off the peel 
bar. This menu selection works best if the length of 
the image printed matches the physical length of the 
label. 

Factory Default Next TOF 

IMPORTANT 
This menu only visible when the peel option is 
installed. 

IMPORTANT 
End of Image selection is affected by the Media > 
Image > Clip Page option. 
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MEDIA > Handling > Cal in Peel Mode 

This option allows you to perform a calibration in Peel-Off Media Handling 
mode. Calibration in Peel-Off mode does not stop and wait for you to 
remove peeled labels. Therefore, be prepared to remove the labels as they 
are automatically peeled. 

Disable 
Calibration from the panel when in peel mode is not 
permitted and a warning message will display.  

Enable 
Auto Calibrate can be performed from the front panel 
in peel mode.  

Factory Disable 

IMPORTANT 
This menu only visible when the peel option is 
installed. 

IMPORTANT 
If this menu is set to Disable, then Power-Up 
Action = “Auto-Cal” is ignored. 

 
 

MEDIA > Handling > Label Wait Time 

Media Handling is set to Tear-Off Strip or Continuous (Tear Strip Full): 

Label Wait Time specifies the number of seconds after printing stops that 
the printer will wait before it advances media to the tear bar position.  

Media Handling is set to Peel-Off: 

Label Wait Time specifies the number of seconds the printer will wait after a 
label is removed from the peel/tear bar before starting to print the next label. 

Minimum 0.1 seconds 

Maximum 60.0 seconds 

Factory Default 1.0 seconds 

IMPORTANT 

If the RFID option is installed and the Factory 
Configuration is the power-up default, this menu 
will automatically be changed to 1.0 seconds. 
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Media > Ribbon 
  
 

Media > Ribbon > Ribbon Low 

When enabled and the amount of ribbon remaining on the supply spindle is 
approximately 75 to 50 meters or less, a “Ribbon Low” warning will pop up 
on the ONLINE screen. 

Disable No Ribbon Low warning will appear. 

Enable 
The Ribbon Low warning will appear when the ribbon 
on the supply spindle is 75 meters or less. 

Factory Default Disable 

 

Media > TOF 
  

Media > TOF > TOF Detect Fault 

Allows selection of three different TOF (Top-of-Form) detection faults. The 
printer displays a Gap Not Detected fault and stops printing when media has 
advanced a distance equal to X or more times Media > Image > Label Length. 

1 Label The Gap Not Detected fault is declared after 1 label. 

3 Labels The Gap Not Detected fault is declared after 3 labels. 

9 Labels The Gap Not Detected fault is declared after 9 labels. 

Factory Default 3 Labels 

IMPORTANT 

The correct Label Length value, equal to the 
physical length of the installed label, must be 
entered in Media > Image > Label Length. 
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Media > TOF > Ticket Save Mode 

This option determines the action of the media for Continuous (Standard), 
Tear-Off Strip and Cut Media Handling Modes after the printer is first 
powered up or after the printhead has been opened and then closed. When 
enabled, this option eliminates wasting label(s) or ticket stock when the 
printer advances media to search for the next TOF position. 

Option applies only to 0.5 inch or longer label lengths. 

Disable 

The printer assumes that the media is not at the correct 
TOF position after cycling power or after the printhead is 
opened and then closed. Printing will begin only after the 
next TOF is detected. 

When disabling, Sensors > Calibrate > Online Action 
and Sensors > Calibrate > HeadClose Action will not 
be adjusted. 

Enable 

The printer will assume that media is at the TOF position 
after cycling power or after the printhead is opened and then 
closed. Printing will begin without advancing media to 
search for the next TOF position. 

When enabled, Sensors > Calibrate > Online Action 
and Sensors > Calibrate > HeadClose Action will 
automatically be set to Disable. 

No Seek 

The printer will assume that media is not at the TOF position 
after cycling power but is at the TOF position after the 
printhead is opened and then closed. After powering up, 
printing will begin only after the next TOF is detected.  After 
opening the head, printing will begin without advancing 
media to search for the next TOF position. 

When enabled, Sensors > Calibrate > Online Action 
and Sensors > Calibrate > HeadClose Action will 
automatically be set to Disable. 

Factory Default Disable 

IMPORTANT 

The user must ensure that media is at the correct 
TOF position (cross perforation, liner gap, notch 
or mark at the tear bar edge) before cycling power 
or before closing and locking the pivoting deck. In 
addition, media must be calibrated and the correct 
Media Handling Mode, Label Length and Gap/Mark 
Sensor selected and in Power-Up Config. 
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Media > TOF > TOF Adjust Mode 

This option enables use of the Media > TOF > TOF Adjust Dist. 

Disable The TOF Adjust Dist menu value will not be used. 

Enable The TOF Adjust Dist menu value will be used. 

Factory Default Disable 

 

Media > TOF > TOF Adjust Dist 

This option sets the distance from the Top Of Form (TOF) that is left blank 
(unprinted) after a label has been removed in Tear-Off Strip mode. When 
this mode is enabled the start position for printing can be adjusted in 
increments of 0.01 inch.  

This adjustment can be helpful if a die cut label sticks to the platen by 
means of jagged edges created during a poor die cut label removal using 
the tear bar. By controlling how much blank space there is from TOF, you 
can control how much the media is called back after it is torn off.  

Minimum 0.00 inches 

Maximum 0.40 inches  

Factory Default 0.40 inches 

IMPORTANT Tear-Off Strip mode only 

Media > Fault 
  

Media > Fault > Label Missing 

Allows the Label Taken Sensor to first detect the presence of a label at the 
peel bar.  

Disable 
The printer does not generate a fault condition if a 
missing label is encountered. 

Enable 
The printer generates a fault condition if a missing label 
is encountered.  

Factory Default Enable 
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Media > Fault > Error Recover 

This option determines how the printer handles data that was printing when 
an error occurred.  

Disable 
The printer will not reprint the label that was printing 
when the error condition occurred. 

Enable 
The printer reprints the label that was printing when 
the error condition occurred. 

Factory Default Disable 

 

Media > Fault > Head Warning 

This option determines if the printer will warn the user when the print head 
approaches its limit in terms of inches printed. 

Disable 
Do not show a warning message based on the print 
head inches printed. 

Enable 
When the print head reaches a certain limit, a warning 
message will pop up. 

Factory Default Enable 

 

Media > Auto Label Map 
  

Media > Auto Label Map > Select 

This option specifies the maximum print width to be used by the application. 
The IGP/Auto Label Mapping®  feature allows backward compatibility of 
programs written for Printronix line-matrix printers. It allows the printer to 
print two-up (or other multi-up) labels. Instead of printing multiple labels 
across the printer, it prints the leftmost label and the rightmost label, so the 
printout will be twice as long but half as wide. 

Disable 

Excess data in any program sent to the printer with 
horizontally adjacent labels that exceed the physical 
page width of the printer will be clipped or wrapped 
depending upon how the emulation is designed. 

Enable 

The printer will automatically reposition the 
horizontally adjacent labels to a vertically adjacent 
position, or a combination of horizontal and vertical 
positions based on the values selected under the 
Auto Label Width and Number Labels menu items. 

Factory Default Disable 
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Media > Auto Label Map > Auto Label Width 

The width of a single label to be printed or the maximum width of the media 
that will be used for the print file. The value is selectable from 0.1 inch 
through the maximum print width of the printer.  

Minimum 0.1 inch 

Maximum Media > Image > Label Width value.  

Factory Default Depends on the model width. 

 

Media > Auto Label Map > Number Labels 

The desired number of labels to be printed vertically adjacent on the form. 

Minimum 2 

Maximum 40 or as page memory available. 

Factory Default 2 

 

Auto Label Map Examples 

All of the examples below assume that the logical form length is set to the label length. 

Example 1: Simple Case 

Problem: A file has been constructed with two horizontally adjacent 4.0” labels for a printer with a 
physical width of 8.0”. The user now wants to use this file with a printer that has a 4.0” physical width. 

Solution with Menu Settings:  

• Set Media > Auto Label Map > Auto Label Width to “4.0” (the width of the label) 

• Set Media > Auto Label Map > Number Labels to “2” 

• Set Media > Auto Label Map > Select to “Enable”. 

Printer Operation: The printer will print the first (leftmost) 4.0” label first on the first thermal label, followed 
by the second 4.0” label. These labels will be stacked vertically as shown in the diagram. 
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Example 2: Uneven Number Case 

Problem: A file has been constructed with three horizontally adjacent 2.0” labels. The user now desires to 
use this file with a printer that has a 4.0” physical width. 

Solution #1 with Menu Settings:  

• Set Media > Auto Label Map > Auto Label Width to “2.0” (the width of each labels) 

• Set Media > Auto Label Map > Number Labels to “2” 

• Set Media > Auto Label Map > Select to “Enable”. 

Printer Operation for Solution #1: The printer will print the first two labels at the same time. These first 
two labels will be horizontally adjacent. Once these labels have been completed, the printer will print the 
remaining 2.0” labels along with a blank 2.0” label. See figure below. 

 
 

 
 

Solution #2 with Menu Settings:  

• Set Media > Auto Label Map > Auto Label Width to “2.0” (the width of two labels) 

• Set Media > Auto Label Map > Number Labels to “3” 

• Set Media > Auto Label Map > Select to “Enable”. 
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Printer Operation for Solution #2: The printer will print the first 2.0” label by itself, the second 2.0” label 
by itself, and finally, the last 2.0” label by itself. See figure below. 

 

 
 

Example 3: Past Maximum File Width 

Problem: A file has been constructed with three horizontally adjacent 4.0” labels. The user now desires to 
use this file with a printer that has an 8.0” physical width. The user should have used a solution similar to 
one of the solutions in the examples above, but the user erroneously enters an Media > Auto Label Map > 
Auto Label Width of “12.0” and a Media > Auto Label Map > Number Labels of “3”. 

Printer Operation: The maximum Number Labels = (20”/12”) = 1.67 rounded up to 2. The printer will 
automatically reduce the Media > Auto Label Map > Number Labels to “2”. 

Example 4: Blank Label Case 

Problem: A file exists with two horizontally adjacent 4.0” labels. The user now wants to use this file with a 
printer that has a 4.0” physical width. The user decides to set the Media > Auto Label Map > Number 
Labels to “3” and the Media > Auto Label Map > Label Width to “4.0” despite the fact that these values are 
not optimum. 

Printer Operation: The maximum Number Labels = (20”/4”) = 5. The selected value of 3 is legal. After the 
file is sent, the printer will begin by printing the first 4.0” width label. Once that label is complete, it will print 
the second 4.0” width label. Finally, once both of those labels have been printed, the printer will print a 
blank 4.0” label. 
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Sensors  

Intro: Sensor Types 

When making changes in this section, there are certain implications that need to be understood because 
some menus are intimately related. For example, when the menu Sensors > Control > Gap/Mark Sensor 
is changed, this has an effect on other menu defaults as shown in Table 2 below. 

 

Table 2. Gap/Mark Sensor Effects on other Menu Defaults 

Gap/Mark Sensor 
Paper Out 

Sensor 
Minimum 

Delta 
Gap/Mark 

Thresh 
Paper Out 

Thresh 

Disable Transmissive N/A N/A 1023 

Mark Transmissive 48 250 1023 

Gap Transmissive 80 689 1023 

IMPORTANT When sensors settings are changed, the user must calibrate .   

Sensors > Control 
  

Sensors > Control > Gap/Mark Sensor 

The available options specify the sensor type needed for detecting the Top-
of- Form position on media with label length indicators (gaps, notches, 
holes, or black marks). 

Disable 

Select when using media with no label length 
indicators (no gaps, notches, holes, or black marks), 
or when you want the printer to ignore all existing 
label length indicators on the installed media. 

Mark 

Select when using media that has horizontal black 
marks located on the underside of the label liner, 
notch, hole or tag stock. The Top-of-Form position is 
the leading edge of the black mark (trailing edge of 
the notch, gap or hole). 

Gap 
The Top-of-Form position is the leading edge of the 
die cut label or black mark on top side of label 

Factory Default Gap for non-RFID printers and Mark for RFID printers 

IMPORTANT 

When you select Disable, the length of each label 
is based on the Media > Image > Label Length 
menu or the value sent within the application 
format. 

IMPORTANT 
If the RFID option is installed and powers up with 
the Factory Configuration, Mark will be selected. 
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Sensors > Control > Auto Calibrate 

This executable menu is used to improve the sensitivity and reliability of the 
Media Sensors in detecting gaps, notches, holes, or black marks on the 
installed media, as well as a paper out condition. The operation is 
successful when the Sensed Distance displayed correctly matches that of 
the installed media.  

For Gap: The Sensed Distance should match the length from the trailing 
edge of one gap to the trailing edge of the next gap (one label + one gap).  

For Mark: The Sensed Distance should match the length from the leading 
edge of one black mark to the leading edge of the next black mark. 

IMPORTANT 

Prior to running Auto Calibrate you must enter the 
length of the installed media via the Media > 
Image > Label Length menus. Selecting the 
correct Label Length forces Auto Calibrate to 
increase media advancement for long labels (to 
detect actual gaps, notches, or marks) and 
decrease advancement for short labels. 

Auto Calibrate supports label lengths up to 35 
inches. 

 

 

Sensors > Control > Sensed Distance 

This value represents the distance that was sensed between the TOF of 
one label to the TOF of the next label upon successful calibration. It is a 
read-only value.  

Gapped media: the distance equals the physical label length plus one gap, 
notch, or hole (trailing edge of one gap, notch, or hole to the trailing edge of 
the next gap, notch, or hole).  

Black mark media: the distance equals the leading edge of one black mark 
to the leading edge of the next.  

Setting Automatically calculated upon calibration. 

Factory 0.0 inches 

 



 

Page | 84 
 

Sensors > Control > Gap/Mark Thresh 

This menu item sets a value that, when exceeded by the output of the 
media sensor, is recognized by the printer as a gap (or black mark). Upon 
calibration, the value displayed is equal to the gap/mark threshold value set 
by the procedure. If running the procedure does not provide a reliable Top-
Of-Form detection (e.g., when using unusual media), the Gap/Mark Thresh 
value can be manually set to the desired value. 

Minimum 0  

Maximum 1023 

Factory See Table 2 

 

Sensors > Control > Paper Out Thresh 

This menu item selects a value that, when exceeded by the output of the 
media sensor, is recognized by the printer as a paper out condition. Upon 
calibration, the value displayed is equal to the paper out threshold value set 
by this procedure. If running the procedure does not provide a reliable paper 
out detection, e.g., when using non-standard media, the Paper Out Thresh 
value can be manually set to the desired value. 

Minimum 0  

Maximum 1023 

Factory See Table 2 

 

Sensors > Calibrate 

You can run Auto Calibration from the Home screen, this section, or the Tools > Print Tests > Run Test 
menu. Upon execution, the printer advances media the distance needed to accurately detect the label 
length indicators, then stops at the Top-of-Form position, and momentarily displays the Sensed Distance 
if successful. This process takes a few seconds to complete and results in changes to the values the 
printer uses in the Sensors > Control subsection for Gap/Mark Threshold, Paper Out Threshold, and 
Sensed Distance. These value changes take effect immediately within the current configuration menu. 
  

Sensors > Calibrate > Auto Calibrate 

See Sensors > Diagnostics > Media Profile 
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Sensors > Calibrate > Power-Up Action 

Calibration activities when the printer is powered up.  

Disable No activities at power up. 

Auto-Cal 

Auto Calibrate is performed at power-up. Once the 
Auto Calibrate is complete, the printer will 
momentarily display the Sensed Distance determined 
by the Auto Calibrate. 

Seek TOF 

Assumes user has already calibrated media and used 
gap/mark sensor. This moves the media to Top-of-
Form at power up if Sensors > Control > Gap/Mark 
Sensor is not set to Disable.  

Factory Auto-Cal 

IMPORTANT 
If Media > TOF >Ticket Save Mode is set, Auto-Cal 
and Seek TOF will not be performed. 

 

SENSORS > Calibrate > HeadClose Action 

Selects whether the printer performs a selected action after a print head 
open fault condition is cleared. 

Disable 
No media motion after a print head open fault 
condition is cleared. 

Auto-Cal 
Performs Auto Calibration every time the print head 
open fault condition is cleared. 

Auto-Cal Data 
Pend 

The Auto-Calibration will be done even if there is data 
in buffer pending. Usually, it is ignored with data in 
buffer. 

Seek TOF 

Moves the media to TOF (Top Of Form) when the 
printhead is closed unless Sensors > Control > 
Gap/Mark Sensor is set to Disable.. The media should 
already be calibrated using Gap/Mark sensor. 

Factory Disable 

IMPORTANT 

If Media > TOF > Ticket Save Mode is set, Auto-Cal 
and Seek TOF will not be performed. 

If there is data pending (data in buffer) when the 
head open fault is cleared, Auto-Cal and Seek TOF 
are ignored. 
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Sensors > Calibrate > Online Action 

Whenever the printer is brought ONLINE, it automatically performs an Auto 
Calibrate if enabled. This option should only be set before any data is sent 
to the printer. 

Disable 
No Auto Calibration is performed when going 
ONLINE. 

Auto-Cal 
Once the Auto Calibrate is complete, the printer 
momentarily displays the Sensed Distance and then 
resumes printing any pending jobs. 

Factory Disable 

IMPORTANT 

If Ticket Save mode is enabled, you will not be 
able to enable this menu. A warning message will 
be displayed instead. 

 
 

Sensors > Calibrate > Gap Windowing 

This feature compensates for any early falling edges or spurious peaks and 
troughs that may appear within the gap length in media. These edges or 
peaks and troughs can cause unreliable detection of the leading edge of the 
next label (top-of-form). Use Gap Windowing to resolve the following 
problems: 

▪ Loss of one or more complete (serialized) labels. 

▪ Start of an image printed in the middle of a gap, especially with fanfold, 
perforated media. 

• Top part of an image lost when printing in head-first orientation. 

Disable 

When the leading edge of a gap is detected, the 
printer continuously looks for the leading edge of the 
next label and uses it as the TOF position. 
Perforations or unusual media discrepancies within 
the gap can cause inaccurate TOF detection.  

Enable 

When the leading edge of a gap is detected, the 
printer ignores the first 90% of the gap length value 
specified in the Gap Length menu option. The result is 
that cross perforations or unusual media 
discrepancies within the gap are filtered out, allowing 
the printer to reliably detect the actual leading edge of 
the next label and use it as the TOF position.  

Factory Disable 
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Sensors > Calibrate > Gap Length 

Gap Length is the actual length (height) of a label gap measured in .01 inch 
increments.  

Minimum 0.05 inches  

Maximum 1.00 inches  

Factory 0.12 inches 

WARNING 
You must enter the correct Gap Length. If the Gap 
Length is too long, the image will shift down from 
the leading edge (TOF) of the label. 

 

Sensors > Calibrate > Minimum Delta 

This menu changes the minimum threshold value the sensor(s) require to 
detect the difference between the label and a gap, notch, hole or black 
mark. This allows bolder gaps (such as notches or holes) to be used as the 
TOF while intermediate gaps (liner) can be ignored. Increasing the value 
makes the sensor(s) less sensitive to intermediate gaps and noise. 
Decreasing the value makes the sensor(s) more sensitive for detecting gaps 
on low contrast media, where there is very little difference between the label 
and the gap (liner).  

Minimum 048  

Maximum 200  

Factory 
Gap/Mark Sensor = Disable, Gap, or Mark: 048 

Otherwise: 080 
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Sensors > Calibrate > Use Label Length 

Determines whether or not Media > Image > Label Length is used during 
Auto Calibrate. This resolves problems where the sensor(s) may mistake 
high noise levels or preprinted images within the label as the gap, notch, 
hole, or black mark that could result in a sensed distance value much 
shorter than the actual label length. For example, a 0.2 inch calibrated 
Sensed Distance with a 3.0 inch long label installed. 

Disable 

Auto Calibrate relies exclusively in its ability to detect 
varying transitions between labels and gaps, notches, 
holes, or black marks while advancing media during 
the calibrate process to determine Sensed Distance. 
The amount of media advanced is based on the 
number of transitions detected.  

Enable 

The Label Length is used in the calibrate algorithm. 
This causes the Auto Calibrate process to advance 
media the minimum distance required to detect the 
true gap, notch, hole, or black mark used for TOF 
(Top-of-Form) sensing.  

Factory Enable 

IMPORTANT 

This menu will be ignored when Media > Image 
>Set Label Length is set to “Automatic”. This is 
the Factory default. 

WARNING 

Setting the Label Length value less than half the 
actual length of the label in use will result in 
erroneous Sensed Distance values when Auto 
Calibrate is performed. 
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Sensors > Calibrate > Threshold Range 

This option allows the user to select the optimal threshold range for the label 
stock. The printer defaults to using a threshold range of 50% of the positive 
going pulse (see Sensors > Diagnostics > Media Profile) that represents 
each gap, notch or mark detected after doing an Auto or Manual Calibrate. 
The printer then detects anything within the label with that threshold range 
as TOF. While this range is ideal for most medias, some labels with a 
preprinted image, liner gap or inlay can confuse the media sensor(s) 
causing a false TOF detection. In most cases this can be resolved by 
selecting a higher threshold range so the printer will only trigger on the true 
TOF (gap, notch or mark) position.  

Minimum 5%  

Maximum 95% 

Factory 50%  (75% - RFID equipped printers) 

IMPORTANT 

A new threshold range will not take effect until 
Calibration is successfully performed. A Sensors > 
Diagnostics > Media Profile should be run after a 
Calibrate to visually verify that the new range is 
the best possible selection. 

 

Sensors > Calibrate > Mark TOF Detect 

This menu controls how the TOF will be detected for Mark media. 

Mark Lead 
Edge 

The leading edge of the mark will be used as the TOF 
and printing will be begin here. 

Mark Trail Edge 
The trailing edge of the mark will be used as the TOF 
and printing will be begin here. 

Factory Mark Lead Edge 
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Sensors > Calibrate > Label Window 

This menu controls whether or not media gap detection will be restricted to 
a certain plus/minus region to the current calibrated label length. For 
example, if the calibration resulted in a label length of 6 inches, then this 
menu enabled would restrict future gap detection to 6 inches plus or minus 
a range defined by the menu Lbl Win Len. 

Disable 
Gap or Mark detection will not be restricted and is 
based on the when the sensor detects a gap or mark. 

Enable 
Gap or Mark detection will be restricted to a given 
area defined by Lbl Win Len menu. 

Factory Disable 

 

Sensors > Calibrate > Lbl Win Len 

When the menu Label Window is enabled, this menu defines the plus or 
minus distance to seek gaps or marks. For example, if the calibrated label 
length is 6 inches, then a setting of 10% suggests to restrict gap or mark 
detection to plus or minus 0.6 inches near the expected 6 inch point of the 
label. 

Minimum 1 (percent) 

Maximum 50 (percent) 

Factory 5 (percent) 

 

Sensors > Diagnostics 

 

Sensors > Diagnostics > Media Profile 

This executable menu provides a graphical printout showing the 
relationship of the Paper Out Threshold and the Gap/Mark Threshold. The 
profile printout assists you in setting the thresholds for difficult media. This 
includes pre- printed labels, and labels with poor gap/media dynamic 
range. 

Start 
When “Print Profile” is executed, the printer will 
advance media and print the media profile along the 
length of each label. 

Completed 
The printer will continue to print the profile until you 

press the  ENTER key. 
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Sensors > Diagnostics > Manual Calibrate 

Manual Calibrate is another method of improving the printer’s media 
sensing and is only used when Auto Calibrate has failed or the Gap/Mark 
Threshold or Paper Out Threshold values derived from Auto Calibrate do 
not improve the media sensors’ gap or mark sensing capability.  

Start 
To initiate Manual Calibrate, press  ENTER key 
when “Manual Calibrate” displays. You will then be 
prompted for the remaining steps. 

Completed 

Manual Calibrate is completed successfully when the 
displayed Sensed Distance correctly matches that of 
the installed media. When Gap is selected, the 
Sensed Distance should match the length from the 
trailing edge of one gap to the trailing edge of the next 
gap (or one label + one gap). When Mark is selected, 
the Sensed Distance should match the length from 
the leading edge of one black mark to the leading 
edge of the next black mark. 

Effects 

This process takes longer than Auto Calibrate, and 
the end result is a change to the Gap/Mark Threshold, 
Paper Out Threshold, and Sensed Distance values 
that the printer will use. These value changes take 
effect immediately within the current configuration 
menu.  

IMPORTANT 
Manual Calibrate supports label lengths up to 24 
inches. 
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System  

System > Control 
  

System > Control > Display Language 

This parameter chooses the language that will appear on the control panel: 
English, German, French, Italian, Spanish, Portuguese, Simplified Chinese, 
Traditional Chinese, Korean, and Russian. 

Factory Default English 

 

System > Control > LCD Brightness 

The brightness of the control panel backlight.  

Minimum 0 

Maximum 31 

Factory Default 16 

IMPORTANT 

This value is saved independent of any one 
configuration and will be preserved across 
loading configurations. 

 

System > Control > Power-up State 

Determines if the printer will power-up in the ONLINE state or OFFLINE 
state (Home screen).  

Online ONLINE state 

Offline OFFLINE state 

Factory Default ONLINE 

IMPORTANT 
This OFFLINE selection must be saved as a 
power-up configuration to be used. 
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System > Control > Media Units 

Determines if distances in the MEDIA section are displayed in inches or 
millimeters.  

In Inches Inches are used. 

In Millimeters Millimeters are used. 

Factory Default In Inches 

 

System > Control > Batch Counter 

Displays the number of pages remaining to be printed in a print job on the 
ONLINE screen message area. This feature is supported in PGL and ZGL 
only. 

Disable Remaining pages is not displayed. 

Enable The number of remaining pages is displayed. 

Factory Default Disable 

PGL Syntax ~EXECUTE;formname;[;FC][;ICNTn][;FCNTn] 

ZGL Syntax ^PQ(#Pages) 

WARNING 
If the correct execute command is absent from the 
print file, “0 Pages” will continually display on the 
control panel. 

 

System > Control > Feed Key Online 

This option changes the functionality of the FEED key when the printer is 
ONLINE. 

Feed 
When selected, pressing the FEED key causes the 
printer to feed a form. 

Reprint Last 
When selected, pressing the FEED key causes the 
printer to reprint the last printed form. 

Factory Default Feed 
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System > Control > Cancel Operation 

This option determines if the LEFT SOFT key in the Home screen will be 
used for “Cancel Data”. If so, then the LEFT SOFT key will be active when 
there is data in buffer. 

Disable 
No option will be available to the user to Cancel Data 
from the front panel. 

Enable 
Allow the “Cancel Data” operation to be used. When 
executed, all data in the printer will be cancelled. 

Factory Default Enable 

 

System > Control > Auto Locking 

This option can force the front panel  ENTER key to return to the locked 
status five minutes after the last key press. 

Disable 
The  ENTER key is not automatically locked. It 
remains in its current state until locked manually or 
via power-up. 

Enable 
The  ENTER key is automatically locked five minutes 
after the last key press. 

Factory Default Disable 

 

System > Control > Set Lock Key 

Normally, to lock or unlock the printer menu, the up/down keys are pressed 
at the same time. The Set Lock Key executable menu lets you choose 
different keys to lock or unlock the printer menu. You may choose almost 
any group of keys as the new lock and unlock keys. You cannot use the 

 ENTER key or any key combinations which are already used for other 
functions. One or more keys can used simultaneously. 

Start 
The  ENTER key is used to start the sequence and 
the user will be asked to select a new lock key. 

Completed 

After following all the instructions on the front panel 
(including entering the new lock key twice to confirm), 
the user will be informed the process was completed. 
If not successful, then the user will alerted. 

IMPORTANT 
The new lock combination will remain even if the 
printer is powered off and back on. 
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System > Energy Star 

  

System > Energy Star > Pwr Saver Time 

The time interval you specify for this parameter sets the amount of idle time 
before the printer goes into Power Saver mode. When you enter into Power 
Saver mode, the panel backlight is dimmed, the engine shuts down, and a 
panel message informs the user. 

Pressing any Control Panel key or certain network access to the printer 
removes the Power Saver message from the panel and the turns on the 
backlight (but the engine is still shut down). Sending a print job to the printer 
results in a full exit of Power Saver mode. 

Selections 
The options are 1, 5, 10, 15, 30, 45, 60, and 120 
minutes. 

Factory Default 5 minutes. 

 

System > Energy Star > Pwr Saver Active 

This menu allows you to enable and disable Power Saver mode. If enabled, 
the menu for Power Saver Time is in effect.  

Disable Power Saver mode is disabled and not used. 

Enable Power Saver mode is enabled. 

Factory Default Enable 

System > Flash File View 

This subsection will show all font and user downloaded files in FLASH memory. Files with one of the 
filename extensions Filename Extensions Not Shown in Menus are not shown in this section. The name 
of the file will be shown along with its size in bytes. This is a read-only section. 

System > Flash File Edit 

This subsection can be used to configure how FLASH file storage can be used and allow the users to 
delete files, copy files to the SD card, optimize memory, etc. 
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System > Flash File Edit > Overwrite Files 

This allows you to prevent files from being overwritten by disabling the 
overwrite function.  

Disable 
Files cannot be overwritten either from copying a file 
from an SD card or by the host application. 

Enable Files can be overwritten as needed.  

Factory Default Enable 

IMPORTANT 

When files are overwritten, the FLASH used for 
the original file is not truly deleted. Instead, that 
memory goes to the Flash Reclaimable area and 
cannot be used again until an Optimize & Reboot 
is performed. 

 

System > Flash File Edit > Delete Files 

This allows the user to delete user files in FLASH memory.  

File 1 File 1 is listed and will be deleted if selected. 

…  

File N File N represents the last user file in FLASH.  

IMPORTANT 

When files are deleted, the file cannot be used, 
but the space cannot be used again until an 
Optimize & Reboot is performed. 

 

System > Flash File Edit > Available Space 

Shows the user how much FLASH memory is available for new user files. 
This does not count memory in the Flash Reclaimable area. This is a read-
only menu. 

 

System > Flash File Edit > Flash Reclaimable 

Shows the user how much FLASH memory is available to be reclaimed if 
the user performs the Optimize & Reboot function. This is a read-only menu. 
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System > Flash File Edit > Optimize & Reboot 

This is an executable menu that will reboot the printer and perform FLASH 
optimization which will remove any existing fragmentation (shown in Flash 
Reclaimable) back into the Available Space pool. 

IMPORTANT 

When executed, an “Optimizing Flash Files” 
message will be displayed when the printer is 
rebooting. 

 

System > Flash File Edit > Copy to SD 

This menu is only available when an SD card is found in the printer. This 
menu will transfer the selected file to the root directory of the installed SD 
card.  

File 1 File 1 will be copied to the SD card if selected. 

…  

File N File N will be copied to the SD card if selected. 

IMPORTANT 

The SD card must be installed at the time of 
power-up and cannot be removed until the printer 
is powered off. 

 

System > Flash File Edit > Copy to USB 

This menu is only available when an USB drive is found in the printer. This 
menu will transfer the selected file to the root directory of the installed USB 
drive.  

File 1 File 1 will be copied to the USB drive if selected. 

…  

File N File N will be copied to the USB drive if selected. 

IMPORTANT 

The USB drive must be installed at the time of this 
operation and cannot be removed until the copy is 
complete. 

 

System > Flash File Edit > Print File List 

Prints a summary of the files stored in flash memory and several statistics 
on file system usage. 

System > SD File View 

This subsection will only be available if the SD card is installed at the time of power-up and not removed 
until the printer is powered off. It will show all files in the root directory of the SD card. The name of the file 
will be shown along with its size in bytes. This is a read-only section. 

System > SD File Edit 

This subsection can be used to configure how SD file storage can be used and allow the users to delete 
SD files, copy files from SD to FLASH, view available SD space, and manage the QCMC (Quick Change 
Memory Card) option when included. 
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IMPORTANT  The SD card must be installed at the time of power-up and cannot be removed 

until the printer is powered off. 

 

System > SD File Edit > Overwrite Files 

Like System > Flash File Edit > Overwrite Files, this prevents SD files from 
being overwritten by disabling the overwrite function.  

Disable SD files cannot be overwritten.  

Enable 
SD files can be overwritten either from copying a file 
from FLASH or by the host application. 

Factory Default Enable 

 

System > SD File Edit > Write Protect 

This prevents any writing to the SD card by the emulations as jobs are 
processed. This might be used to protect an SD card purchased with a 
Premium or Andale font, for example. If the SD has a physical switch to 
prevent writing, this takes precedence. 

Disable SD files can be written as usual.  

Enable SD files will not be written. 

Factory Default Disable 

 

System > SD File Edit > Delete Files 

This allows the user to delete user files from SD card root directory.  

File 1 File 1 is listed and will be deleted if selected. 

…  

File N File N is the last file on the SD card root directory.  

 

System > SD File Edit > Print Files 

This allows the user to choose a file to execute like a job sent from the host.  

File 1 File 1 is listed and will be printed if selected. 

…  

File N File N is the last file and will be printed if selected. 
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System > SD File Edit > Available Space 

Shows the user how much SD card memory is available for new user files. 
This is a read-only menu. 

 

System > SD File Edit > Copy from SD 

This menu will transfer the selected file from the SD card root directory to 
the printer FLASH memory.  

File 1 File 1 will be copied from the SD card if selected. 

…  

File N File N will be copied from the SD card if selected. 

 

System > SD File Edit > Print File List 

Prints a summary of the files stored in the SD card root directory and 
several statistics on SD file system usage. 

 

System > SD File Edit > QCMC Update 

This menu can be used to update the configuration within the QCMC image 
stored on the SD card (see Appendix G Quick Change Memory Cartridge 
(QCMC).  

 

System > SD File Edit > QCMC Erase 

This menu can be used to erase the QCMC image stored on the SD card 
(see Appendix G Quick Change Memory Cartridge (QCMC). 

System > USB File View 

This subsection will only be available if a USB drive is installed. It will show all files in the root directory of 
the USB drive. The name of the file will be shown along with its size in bytes. This is a read-only section. 

When reading the USB drive and listing available files, the following are considered valid file names: 

• Digits, uppercase, and lowercase characters 

• Dot ‘.’ 

• Underscore ‘_’ 

• Dash ‘-‘ 

• Ampersand ‘&’ 

• Tilde ‘~’ 

File names that do not conform will not be shown.  

Files that are greater than 2 GB are ignored as well to prevent overwhelming the system. 
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System > USB File Edit 

This subsection can be used to configure how USB file storage can be used and allow the users to delete 
USB drive files, copy files from USB to FLASH, and view available USB space. The idea is that the USB 
can be used at run-time to copy files to and from the FLASH memory. Transfers between USB and SD 
cards can be done on a computer and are not part of the functionality present within the printer. 

IMPORTANT  The USB drive can be inserted and removed during run-time. A message on the 

front panel will be displayed acknowledging the USB was inserted or removed. 

IMPORTANT  Memory transfers are limited by the amount of free RAM in the system. We 

recommend limiting the file transfer size to 20 MB. 

 

System > USB File Edit > Overwrite Files 

Like System > Flash File Edit > Overwrite Files, this prevents USB files from 
being overwritten by disabling the overwrite function.  

Disable USB files cannot be overwritten. 

Enable 
USB files can be overwritten either from copying a file 
from FLASH or by the host application. 

Factory Default Enable 

 

System > USB File Edit > Delete Files 

This allows the user to delete user files from USB card root directory.  

File 1 File 1 is listed and will be deleted if selected. 

…  

File N File N is the last file on the USB card root directory.  

 

System > USB File Edit > Print Files 

This allows the user to choose a file to execute like a job sent from the host.  

File 1 File 1 is listed and will be printed if selected. 

…  

File N File N is the last file and will be printed if selected. 

 

System > USB File Edit > Available Space 

Shows the user how much USB drive memory is available for new user 
files. This is a read-only menu. 
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System > USB File Edit > Copy from USB 

This menu will transfer the selected file from the USB drive root directory to 
the printer FLASH memory.  

File 1 File 1 will be copied from the USB drive if selected. 

…  

File N File N will be copied from the USB drive if selected. 

 

System > USB File Edit > Print File List 

Prints a summary of the files stored in the USB drive root directory and 
several statistics on USB file system usage. 

 

System > Printer Mgmt 
 

System > Printer Mgmt > Rcv. Status Port 

This option defines the interface being used to receive the emulation status 
command.  

Automatic 
When selected, the status command is sent to the 
printer with the print data through the active host 
interface. 

Serial 
When selected, the status command is sent to the 
printer through the serial interface regardless of the 
active host interface.  

Factory Default Automatic 
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System > Printer Mgmt > Ret. Status Port 

This option selects the port for return Status Commands used by the 
emulations.  For PGL, this is the ~STATUS command, and for ZGL, this is 
the ^HS command.  

Automatic 
Sends the data through the same port  used to 
receive the application job. 

Disable Status is not sent back to the host. 

E-NET Data Port Ethernet data port. 

Serial Serial RS-232 port 

E-NET Stat Port Ethernet port as set in Status Port Number menu 

USB USB  

Factory Default Automatic 

 

System > Printer Mgmt > Status Port Number 

This menu selects the port number where the printer sends the emulation 
status.  

Minimum 1025 

Maximum 65535  

Factory Default 3002 

 

System > Printer Mgmt > PNE Port Choice 

This menu selects which port the printer expects PNE (PrintNet Enterprise) 
to connect to, via Ethernet or USB. The factory default is Ethernet.  

Disable PNE communication will be disabled. 

Ethernet Use Ethernet to connect with PNE. 

USB Use USB to connect with PNE. 

Factory Default Ethernet 
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System > Printer Mgmt > PNE Port Number 

This menu selects the port number that the printer expects PNE to connect 
through.  

Minimum 1025 

Maximum 65535  

Factory Default 3001 

 

System > Printer Mgmt > PNE Port Timeout 

If PNE has not communicated to the printer within a timeout period, the PNE 
session closes.  

Minimum 1 second 

Maximum 255 seconds 

Factory Default 100 seconds 

 

System > Printer Mgmt > Mgmt Port Number 

This menu selects the port number that the printer expects the PXML or 
UCP to connect through.  

Minimum 1023 

Maximum 65535  

Factory Default 3007 

 

System > Printer Mgmt > Mgmt Protocol 

Since PXML and UCP management protocols share the same Ethernet 
port, only one can be active at a time. This menu selects the active 
Management Protocol Interface, either PXML or UCP.  

PXML 
Printronix XML management protocol used to control 
and manage the printer. See the XML Programmer 
Reference Guide for more information. 

UCP 
The Universal Control Port that can be used for GPIO 
or CST applications.  

Factory Default PXML 
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System > Date 

This subsection can be used to configure the Date and Time in the printer.  If the Real Time Clock (RTC) 
is installed the values will be saved in the RTC otherwise the values will be reset when the printer is 
powered off.  The Printer Time and Date can also be set by setting the NTP servers in the PrintNet 
Enterprise through the Printer Webpage.  Since the NTP servers return the Date and Time as 
Coordinated Universal Time (UTC), the Time Zone Offset must be set to display the local time.  If the 
NTP servers information is set, the UTC will override the RTC in the printer. 

 

System > Date > Hour 

This option allows you to set the hour. 

Minimum 00 

Maximum 23 

Factory Default 0 

 

System > Date > Minute 

This option allows you to set the minutes. 

Minimum 00 

Maximum 59 

Factory Default 0 

 

System > Date > Year 

This option allows you to set the year. 

Minimum 2018 

Maximum 2037 

Factory Default 2037 

 

System > Date > Month 

This option allows you to set the month. 

Minimum January 

Maximum December 

Factory Default January 
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System > Date > Day 

This option allows you to set the day. 

Minimum 01 

Maximum 31 

Factory Default 01 

 
System > Date > Time Zone Offset 

This option allows you to add a time zone offset to the value to localize the 
UTC time. 

Minimum UTC-12:00 

Maximum UTC+14:00 

Factory Default UTC+00:00 
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Host IO  

Host IO > Control 
  

Host IO > Control > Interface 

This option allows you to send print jobs through any interface with auto- 
switching selected as host interface. It also allows a particular interface 
from the menu to be selected.  

Auto Switching 
Automatically switches interface when host data is 
sent to that interface (and any job in progress is 
completed). 

Serial Serial RS-232 

Ethernet Ethernet Interface 

USB USB Interface 

Bluetooth Bluetooth Interface (if installed) 

Host USB 
Host USB Interface (if Host USB HID device is 
attached) 

Factory Default Auto Switching 

 

Host IO > USB Port 
 

Host IO > USB Port > Buffer (Kbytes) 

This option configures the amount of memory allocated for the USB buffer 
incremented in 1 Kbyte increments. 

Options 1-16, 32, 64, 128, 256, 512, 1024 

Factory Default 16 Kbytes 
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Host IO > USB Port > AutoSW Timeout 

This is the timeout value used for the current port to then check the other 
selected port types for data to print. When the printer has not received data 
from the host after a certain period of time, it needs to time out in order to 
service the other ports. This submenu is only available when Host IO > 
Control > Interface is set to Auto Switching. 

Minimum 10 second 

Maximum 60 seconds 

Factory Default 10 seconds 

 

 

Host IO > USB Port > USB Protocol 

While the USB protocol is a standard, some operating systems like the 
Linux BOSS 5.1 have some unique behaviors that require the printer to 
change its implementation. 

Standard Standard USB Function 

Boss 5.1 Support for the BOSS 5.1 Linux system. 

Factory Default Standard 
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Host IO > Serial Port 

 

Host IO > Serial > Flow Control 

Sets the flow control mode for host IO data transfer. 

Software Only 

In the Software Only mode the data flow control does 
not use any of the Hardware line (RTS/CTS).  

The Serial Debug IO will be active when set to 
Software Only. 

Side Effects: Menu Request to Send and selection 
RTS/CTS from menu Data Protocol are hidden. If 
RTS/CTS was the current setting, then it is changed 
to XON/XOFF. 

Software & 
Hardware 

In the Software & Hardware mode, the data flow 
control also uses the hardware lines (RTS/CTS). 

The Serial Debug IO will not be active when set to 
Software & Hardware. 

Side Effects: Menu Request to Send and selection 
RTS/CTS from menu Data Protocol are unhidden. 

Factory Default Software Only 

IMPORTANT 
Serial Debug is only needed by Field Engineers 
and is not required for normal operation. 

 

 

Host IO > Serial Port > Buffer (Kbytes) 

This option configures the amount of memory allocated for the Serial 

buffer incremented in 1 Kbyte increments. 

Options 1-16, 32, 64, 128, 256, 512, 1024 

Factory Default 16 Kbytes 
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Host IO > Serial Port > Baud Rate 

Sets the baud rate of the serial interface in the printer. Baud rate is the 
speed at which serial data is transferred between the host computer and 
the printer.  

Selections 
600, 1200, 2400, 4800, 9600, 19200, 38400, 57600, 
and 115200 baud. 

Factory Default 9600 baud 

IMPORTANT 

If you select a baud rate that is greater than 19200 
and you experience data loss, you may need to 
lower the baud rate. You also may need to 
increase the Buffer (Kbytes) parameter to improve 
performance. 

 

Host IO > Serial Port > Word Length 

Sets the length of the serial data word. The length of the data word can be 
set to 7 or 8 bits and must match the corresponding data bits setting in the 
host computer.  

7 7 bit data word 

8 8 bit data word 

Factory Default 8 

 

Host IO > Serial Port > Stop Bits 

Sets the number of stop bits in the serial data word. Either 1 or 2 stop bits 
can be selected. The setting must match the corresponding stop bit setting 
in the host computer.  

1 1 stop bit 

2 2 stop bits 

Factory Default 1 

 

Host IO > Serial Port > Parity 

The options are Odd, Even, Mark, Sense, or None. The setting must match 
the corresponding parity setting in the host computer. 

Factory Default None 
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Host IO > Serial Port > Data Protocol 

You can select one of the following serial interface protocols to meet the 
host interface requirements, 

XON / XOFF 

The printer controls the flow of communication from 
the host by turning the transmission on and off. In 
some situations, such as when the buffer is full or the 
timing of signals is too slow or too fast, the printer will 
tell the host to stop transmission by sending an XOFF 
character. An XOFF character is sent when the 
number of empty bytes in the buffer is less than or 
equal to 25 percent of the buffer size. If the host 
keeps sending data after an XOFF is sent, the printer 
firmware will continue to send an XOFF for every 16 
characters received. When cleared, the printer will 
resume receiving data (XON). The data does not 
have any End of Text codes; XON / XOFF is a non- 
block protocol 

ETX / ACK 

End of Text / Acknowledge. The host controls the flow 
of communication to the printer by sending a block of 
data and ending the block with an End of Text (ETX) 
signal. When the printer receives the ETX signal, it 
will acknowledge the ETX, thereby acknowledging it 
has received the entire block of data. 

ACK / NAK 

ACK means acknowledge; the device acknowledges it 
has accepted a transmission. NAK means negative 
acknowledge; the device did not receive the 
transmission 
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Series1 1 Char 

The printer controls the flow of communication from 
the host by turning the transmission on and off using 
response characters sent to the host. If the number of 
valid bytes in the buffer reaches 75 percent of the 
buffer size, the ONLINE or OFFLINE and buffer full 
response character is sent. If the buffer is completely 
full, an ONLINE or OFFLINE buffer full response is 
sent every time a character is sent from the host. 
Whenever the printer state changes to ONLINE or 
OFFLINE, the appropriate response character is sent. 
If the idle response option is enabled, the printer will 
send a response character every two seconds while 
the number of valid bytes in the buffer is less than 75 
percent of the buffer size. If a poll character is 
received (configurable from the Poll Character xx Hex 
option on the front panel from hex 0 through FF), the 
printer will send a response character n milliseconds 
later (configurable from the Poll Character xx MS on 
the front panel from 0 through 30). This n milliseconds 
is called the poll delay. The poll character will be 
removed from the input data stream and will not be 
processed. This may cause problems with the 
transmission of binary data (e.g., control codes, bit 
image, etc.). If a poll delay is started due to the 
receipt of a poll character and another poll character 
is received, the second poll character has no effect 
and is removed from the input data stream. If a 
transition (from buffer full to empty or ONLINE to 
OFFLINE) occurs during a poll delay, the new printer 
state will be sent at the end of the poll delay. See 
Table 3. 

Series1 2 Char 

This protocol behaves exactly the same as the Series 
1 Char except there is a two-character response to the 
host. The response characters are described in Table 
3. 

ENQ / ACK 

The host controls the flow of communication to the 
printer by sending a block of data and ending the 
block with an Enquiry (ENQ) character. When the 
printer receives the ENQ Character, it acknowledges 
the ENQ, thereby acknowledging it has received the 
entire block of data. Status will also be sent before the 
ACK. The status is as shown in Table 4. 

RTS / CTS 

The printer controls the data flow by sending this 
hardware signal to the host. If there is enough room in 
the printer buffer, the printer will send a high signal; if 
the buffer is full, the printer will send a low signal. 
RTS tells the host if it is safe to send more data. (If 
the host sends data during an unsafe condition, data 
will be lost.) 

Factory Default XON / XOFF 
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IMPORTANT 

If the menu Flow Control is set to Software Only 
when this setting is RTS/CTS, then this menu will 
be changed to XON/XOF. 

 

Table 3. Response for Series1 Char 

Printer State 
Series1 1 Char 

Response 
Series1 2 Char 

Response 

ONLINE and Buffer Empty CR 1 CR 

ONLINE and Buffer Full 3 3 CR 

OFFLINE and Buffer Empty 0 0 CR 

OFFLINE and Buffer Full 2 2 CR 

 

Table 4. Response for ENQ / ACK 

Printer State Status 

ONLINE 40 06 

ONLINE or Paper Motion Fault 43 

Platen Open or Paper Out 47 

 
 

Host IO > Serial Port > Request to Send 

This configuration is part of hardware flow control and determines when the 
Request to Send (RTS) signal is generated. This signal indicates whether 
or not the printer is ready to receive data. 

True Continuously asserts the RTS signal. 

On-Line and 
BNF 

Asserts the RTS signal when the printer is ONLINE 
and the internal serial buffer is not full (BNF). 

Off-Line or BF 
Asserts the RTS signal when the printer is OFFLINE 
or the internal serial buffer is full 

On-line Asserts the RTS signal when the printer is ONLINE 

False Never asserts the RTS signal. 

Factory Default On-Line and BNF 

IMPORTANT 
If the menu Flow Control is set to Software Only 
when this menu will be hidden. 
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Host IO > Serial Port > Poll Character 

This option is for the Series1 protocol. Whenever the printer receives this 
character, it sends a response to the host indicating the current state of the 
printer. 

Minimum 00 hex 

Maximum FF hex 

Factory Default 00 hex 

 

Host IO > Serial Port > Poll Response 

This option is for the Series1 protocol. After receiving a poll character, the 
printer will wait the poll response time in milliseconds before sending the 
response. 

Minimum 0 ms 

Maximum 30 ms 

Factory Default 0 ms 

 

Host IO > Serial Port > Idle Response 

This option is for the Series1 protocol and is relevant when the buffer is 
less than 75% full. 

Disable 
The printer does not send a response character when 
the buffer is less than 75% full.. 

Enable 
The printer sends a response character every two 
seconds while the buffer is less than 75% full. 

Factory Default Disable 
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Host IO > Serial Port > One Char Enquiry 

The One Char Enquiry mode uses the Poll Character to detect a request 
from the host and sends a response back to the host. This option also 
allows you to turn this feature on and off.  

 

Printer State Response (hex) 

ONLINE and Buffer Not Full 22 

ONLINE and Buffer Full 23 

OFFLINE and Buffer Not Full 20 

OFFLINE and Buffer Full 21 

 

The Poll Character is removed from the data stream. If the Data Protocol is 
set to ETX/ACK, ACK/NAK, or Series1, One Char Enquiry is automatically 
disabled. 

Disable The feature is disabled 

Enable The feature is enabled 

Factory Default Disable 

 

Host IO > Serial Port > Printer Status 

With this feature, the printer will respond to an ENQ character by sending a 
status byte to the host. The type of status byte is determined by this menu. 
The selections allowed are ENQ/STX and ENQ. 

Disable Printer status is not returned to the host. 

ENQ / STX See Table 5 

ENQ See Table 6 

Factory Default Disable 

IMPORTANT The ENQ is removed from the data stream. 
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Table 5. ENQ/STX Status Byte 

Bit Printer Status 

0 Set when the printer is OFFLINE or the buffer is full. 

1 Set when the printer is OFFLINE. 

2 Clear during a paper out fault. 

3 Always set. 

4 Set during a Head Open fault. 

5 Set during a buffer overflow fault. 

6 Set during a parity or framing error fault. 

7 Always clear. 

 
 

Table 6. ENQ Status Byte 

Bit Printer Status 

0 Set when the label has printed. 

1 Set when the label is presented. 

2 Set while the printer is ONLINE. 

3 Always set. 

4 Set printing in the batch mode. 

5 Set during a Ribbon fault. 

6 Set during a Paper Out fault. 

7 Set during a Head Open fault. 

 
 

Host IO > Serial Port > Framing Errors 

These are possible errors that can occur when serial interface settings of 
the printer do not match those of the host computer. This menu determines 
whether this error is shown on the control panel. 

Disable Feature disabled. 

Enable 
If a framing error occurs, a fault message will display 
on the control panel. 

Factory Default Enable 
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Host IO > Serial Port > Offline Process 

Specifies how data is handled when the printer is OFFLINE. 

Disable 
When set to disable, the printer does not process data 
from the Serial port while OFFLINE. 

Enable 
When set to enable, the printer continues to process 
(but not print) the current job from the Serial port while 
the printer is OFFLINE until the printer's buffer is full. 

Factory Default Disable 

 

Host IO > Serial Port > Report Status 

When a fault condition occurs in the printer, normally only the active port 
reports the fault to the host. With this menu item enabled, this port will 
report any fault even when it is not the current, active port. This submenu is 
only available when Host IO > Control > Interface is set to Auto Switching. 

Disable Will not report the fault unless the active host. 

Enable Will report the fault even if not the active host. 

Factory Default Disable 

 

Host IO > Serial Port > Trickle Time 

When the printer is printing data from a host and a second print job is 
received by the printer from a different host, Trickle Time prevents the 
second host from timing out while it is waiting for its data to be printed. In 
order to support this feature, the port has to be able to accept data from the 
host and store it for future use. 

For example, if the printer is printing a job from the serial port, and then 
receives a second print job from the parallel port, the data from the parallel 
port will “trickle” bit by bit into the printer buffer to prevent a timeout error 
from being sent back to the host connected to the parallel port. 

The selected value is the time that the printer waits before getting the next 
byte of data from the host. The Trickle Time value should be less than the 
host time out value, but not too much shorter or else the printer fills up its 
buffer too fast. 

This submenu is only available when Host IO > Control > Interface is set to 
Auto Switching.. 

Options ¼ , ½ , 1, 2, 4, 8, and 16 seconds 

Off Disable trickling of data. 

Factory Default ¼  second 

 



 

Page | 117 
 

Host IO > Serial Port > AutoSW Timeout 

This is the timeout value used for the current port to then check the other 
selected port types for data to print. When the printer has not received data 
from the host after a certain period of time, it needs to time out in order to 
service the other ports. This submenu is only available when Host IO > 
Control > Interface is set to Auto Switching. 

Minimum 10 second 

Maximum 60 seconds 

Factory Default 10 seconds 

Host IO > Bluetooth 
 

Host IO > Bluetooth > Buffer (Kbytes) 

This option configures the amount of memory allocated for the Blurtooth 
buffer incremented in 1 Kbyte increments. 

Options 1-16, 32, 64, 128, 256, 512, 1024 

Factory Default 16 Kbytes 

 

Host IO > Bluetooth > AutoSW Timeout 

This is the timeout value used for the current port to then check the other 
selected port types for data to print. When the printer has not received data 
from the host after a certain period of time, it needs to time out in order to 
service the other ports. This submenu is only available when Host IO > 
Control > Interface is set to Auto Switching. 

Minimum 10 second 

Maximum 60 seconds 

Factory Default 10 seconds 

 

Host IO > Bluetooth > Connect Name 

A 1-15 character, case-sensitive string that identifies the Printer Bluetooth. 
These characters can be alphanumeric, symbols, or spaces. 

Factory Default BT-PTX 
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Host IO > Bluetooth > PIN Code 

This is the Bluetooth PIN Code 

Factory Default 0000 

 

Host IO > Bluetooth > Pair Method 

The Method used to Pair the printer Bluetooth to the host. 

PASSKEY Use the Pass key to connect. 

SSP_JUSTWORK No security, just connects to the host. 

SSP_NUMERIC_ 

COMPARE 

Require a entering a value sent from host to complete 
connection. 

Factory Default PASSKEY 

 

Host IO > Bluetooth > Mode 

Operation Mode of the Bluetooth Interface. 

Dual Dual Mode 

BT2.1 Bluetooth 2.1 

BT3.0 

 

Bluetooth 3.0 

BT4.0 Bluetooth 4.0 

Factory Default BT3.0 

 

Bluetooth > MAC Address 

This item is the Manufacturer’s Assigned Number, and is unique for each 
Bluetooth. It is read-only. 

IMPORTANT It is read-only. 
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Host IO > Host USB 
 

Host IO > Host USB > AutoSW Timeout 

This is the timeout value used for the current port to then check the other 
selected port types for data to print. When the printer has not received data 
from the host after a certain period of time, it needs to time out in order to 
service the other ports. This submenu is only available when Host IO > 
Control > Interface is set to Auto Switching. 

Minimum 10 second 

Maximum 60 seconds 

Factory Default 10 seconds 

 

Host IO > Host USB > Data 

This selects how the input data is used. 

Panel 
The data is used to control the panel.  This should 
only be selected if the HID device is a Keyboard. 

Data The data is sent to the emulation. 

Debug 
The data is displayed in the debug terminal.  This is 
useful for debugging the data sent by the HID device. 

Factory Default Data 
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Network  
 

For detailed information about using the NIC, refer to the Network Interface Card User’s Manual.  

  
IMPORTANT  Network menus are saved in the separate section of memory.  Loading factory 

configuration will NOT reset these items. 
 

Network > Control 
  

Network > Control > ASCII Data Port 

This option allows you to set the port number for ASCII print jobs. The data 
port number needs to match your host system setting. 

Minimum 1025 

Maximum 65535 

Factory Default 9100 

 

Network > Control > Keep Alive Timer 

This is the time that the Keep Alive Timer will run. Keep in mind that with 
the Keep Alive Timer on, the TCP connection will stay connected even 
after the print job has terminated if the host system does not close the 
connection. 

Minimum 0 minutes 

Maximum 10 minutes 

Factory Default 3 minutes 
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Network > Control > Job Control 

Determines how the end-of-job packet is handled (when the 
acknowledgement is sent back to the host system). 

Standard 
The NIC waits for the entire job to be received before 
it indicates the job is done. 

Enhanced 
The NIC waits for the entire job to be printed before it 
indicates the job is done. 

Fast Standard 

The EOJ (End of Job) packet is acknowledged 
immediately. Use this option if the job is timed out due 
to a delay in the acknowledgement of the EOJ packet 
because of the amount of data being printed. 

Off 
There is no synchronization between the NIC and the 
printer when printing a job. 

Factory Default Standard 

 

Network > Control > Offline Process 

Determines whether the network will process data while OFFLINE. 

Disable 
When set to disable, the printer does not process 
network data while OFFLINE. 

Enable 
When set to enable, the printer continues to process 
(but not print) the current network job while the printer 
is OFFLINE until the printer's buffer is full. 

Factory Default Disable 

 

Network > Control > AutoSW Timeout 

This is the timeout value used for the network to check the other port types 
for data to print. When the printer has not received data from the host after 
a certain period of time, it needs to time out in order to service the other 
ports. 

Minimum 10 second 

Maximum 60 seconds 

Factory Default 10 seconds 
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Network > Control > AutoSW Out 

This menu determines when the autoswitching process will start. 

Data Timeout 
Allows autoswitching when no data has been received 
for the selected Time Out period. 

Session Close 
Allows autoswitching only when the Network Socket is 
closed. 

Factory Default Data Timeout 

 

Network > Control > E-Net to Default 

This executable menu will reset the printer and reset all the Network 
parameters to Factory defaults. 

Network > Ethernet 
 
WARNING  Most of these menu items will not change until configuration of the printer is 

deemed complete by the user and the printer is placed ONLINE. Upon going 
online, the printer will automatically reboot and set these options. 

 

  

Network > Ethernet > IP Address 

This item allows you to set the IP Address for the TCP/IP protocol using a 
virtual keyboard. Make sure you enter the complete IP address, including 
the period symbol between the segments. 

Structure Seg1.Seg2.Seg3.Seg4 

Factory Default 000.000.000.000 

IMPORTANT Disable BootP, ARP or DHCP before trying to 
change the IP address. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > Ethernet > Subnet Mask 

This item allows you to set the Subnet Mask for the TCP/IP protocol using 
a virtual keyboard. Make sure you enter the complete mask, including the 
period symbol between the segments. 

Structure Seg1.Seg2.Seg3.Seg4 

Factory Default 000.000.000.000 

IMPORTANT Disable BootP, ARP or DHCP before trying to 
change the subnet mask. 

IMPORTANT If the printer has not rebooted after disabling 
BootP, ARP or DHCP then the value shown is not 
the static value. You MUST save this value or it 
will be lost when the printer is rebooted. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > Ethernet > Gateway Address 

This item allows you to set the Gateway Address for the TCP/IP protocol 
using a virtual keyboard. Make sure you enter the complete Gateway 
address, including the period symbol between the segments. 

Structure Seg1.Seg2.Seg3.Seg4 

Factory Default 000.000.000.000 

IMPORTANT Disable BootP, ARP or DHCP before trying to 
change the gateway address. 

IMPORTANT If the printer has not rebooted after disabling 
BootP, ARP or DHCP then the value shown is not 
the static value. You MUST save this value or it 
will be lost when the printer is rebooted. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > Ethernet > MAC Address 

This item is the Manufacturer’s Assigned Number, and is unique for each 
NIC. It is read-only. 

IMPORTANT It is read-only. 
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Network > Ethernet > DHCP 

You can enable/disable the DHCP protocol using this option, but consult 
your administrator for the appropriate setting. 

Disable 
DHCP is disabled and you set your own static IP 
address, subnet mask, and gateway address. 

Enable 
DHCP is enabled and IP address, subnet mask, and 
gateway address is assigned dynamically. 

Factory Default Enable 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > Ethernet > BootP 

You can enable/disable the BootP protocol using this option, but consult 
your administrator for the appropriate setting. 

Disable BootP is disabled. 

Enable BootP is enabled. 

Factory Default Disable 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > Ethernet > Ethernet Speed 

This menu appears only if a 10/100Base-T Network Interface Card (NIC) is 
installed. The Ethernet Speed menu has five different speed modes to 
allow compatibility with different systems and networks. 

Auto Select 

Tells the 10/100Base-T NIC to perform an auto 
detection scheme and configure itself to be 10 Half 
Duplex, 10 Full Duplex, 100 Half Duplex, or 100 Full 
Duplex. 

10 Half Duplex 
Tells the 10/100Base-T NIC to communicate at 10 
Megabits per second using half duplex. 

10 Full Duplex 
Tells the 10/100Base-T NIC to communicate at 10 
Megabits per second using full duplex. 

100 Half Duplex 
Tells the 10/100Base-T NIC to communicate at 100 
Megabits per second using half duplex. 

100 Full Duplex 
Tells the 10/100Base-T NIC to communicate at 100 
Megabits per second using full duplex. 

Factory Default Auto Select 

 

Network > WLAN 

 

WARNING  Most of these menu items will not change until configuration of the printer is 

deemed complete by the user and the printer is placed ONLINE. Upon going 
online, the printer will automatically reboot and set these options. 

  

Network > WLAN> IP Address 

This item allows you to set the IP Address for the TCP/IP protocol using a 
virtual keyboard. Make sure you enter the complete IP address, including 
the period symbol between the segments. 

Structure Seg1.Seg2.Seg3.Seg4 

Factory Default 000.000.000.000 

IMPORTANT Disable BootP, ARP or DHCP before trying to 
change the IP address. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN > Subnet Mask 

This item allows you to set the Subnet Mask for the TCP/IP protocol using 
a virtual keyboard. Make sure you enter the complete mask, including the 
period symbol between the segments. 

Structure Seg1.Seg2.Seg3.Seg4 

Factory Default 000.000.000.000 

IMPORTANT Disable BootP, ARP or DHCP before trying to 
change the subnet mask. 

IMPORTANT If the printer has not rebooted after disabling 
BootP, ARP or DHCP then the value shown is not 
the static value. You MUST save this value or it 
will be lost when the printer is rebooted. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN > Gateway Address 

This item allows you to set the Gateway Address for the TCP/IP protocol 
using a virtual keyboard. Make sure you enter the complete Gateway 
address, including the period symbol between the segments. 

Structure Seg1.Seg2.Seg3.Seg4 

Factory Default 000.000.000.000 

IMPORTANT Disable BootP, ARP or DHCP before trying to 
change the gateway address. 

IMPORTANT If the printer has not rebooted after disabling 
BootP, ARP or DHCP then the value shown is not 
the static value. You MUST save this value or it 
will be lost when the printer is rebooted. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN > MAC Address 

This item is the Manufacturer’s Assigned Number, and is unique for each 
NIC. It is read-only. 

IMPORTANT It is read-only. 
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Network > WLAN> DHCP 

You can enable/disable the DHCP protocol using this option, but consult 
your administrator for the appropriate setting. 

Disable 
DHCP is disabled and you set your own static IP 
address, subnet mask, and gateway address. 

Enable 
DHCP is enabled and IP address, subnet mask, and 
gateway address is assigned dynamically. 

Factory Default Enable 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN> BootP 

You can enable/disable the BootP protocol using this option, but consult 
your administrator for the appropriate setting. 

Disable BootP is disabled. 

Enable BootP is enabled. 

Factory Default Disable 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params 
 

Network > WLAN Params > SSID Name 

A 1-32 character, case-sensitive string that identifies the Extended Service 
Set Identification (ESS_ID) network the unit is part of (ESS_ID is also 
called NET_ID). These characters can be alphanumeric, symbols, or 
spaces. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > Reset SSID Name 

Allows you to reset the SSID name 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN Params > Min Xfer Rate 

Allows you to set the minimum speed at which the Wireless Option will 
accept a connection (in millions of bits per second). The options are Auto-
negotiate, 1Mb/sec, 2Mb/sec, 5.5Mb/sec, 11Mb/sec, 6Mb/sec, 9Mb/sec, 
12Mb/sec, 18Mb/sec, 24Mb/sec, 36Mb/sec, 48Mb/sec, and 54Mb/sec.   

Minimum 1Mb/sec 

Maximum 54Mb/sec 

Factory Default Auto Negotiate 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > Power Mgmt 

This allows you to set the power save mode and sleep time in milliseconds 
(ms). If set to zero, power-save mode will be disabled. 

Minimum 0 ms 

Maximum 1000 ms 

Factory Default 0 ms 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

 

Network > WLAN Params > Internat. Mode 

When enabled, the Wireless option adapts to international frequency 
requirements in Europe. 

Disable International Mode is disabled. 

Enable International Mode is enabled 

Factory Default Disable 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN Params > WEP Key 1 Format 

Allows you to format WEP Key 1 in ASCII or hexadecimal code. 

ASCII Allows you to format WEP Key 1 in ASCII format. 

Hexadecimal 
Allows you to format WEP Key 1 in hexadecimal 
format. 

Factory Default Hexadecimal 

 

Network > WLAN Params > WEP Key 1 Width 

This is the encryption strength. The options are 40 bits and 128 bits: 40 bits 
are weaker and 128 bits are stronger. 

40 bits Allows you to use 40 bit encryption for WEP Key 1. 

128 bits Allows you to use 128 bit encryption for WEP Key 1. 

Factory Default 128 bits 

 

Network > WLAN Params > WEP Key 1 

The individual characters for WEP Key 1. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > WEP Key 2 Format 

Allows you to format WEP Key 2 in ASCII or hexadecimal code. 

ASCII Allows you to format WEP Key 2 in ASCII format. 

Hexadecimal 
Allows you to format WEP Key 2 in hexadecimal 
format. 

Factory Default Hexadecimal 

 

Network > WLAN Params > WEP Key 2 Width 

This is the encryption strength. The options are 40 bits and 128 bits: 40 bits 
are weaker and 128 bits are stronger. 

40 bits Allows you to use 40 bit encryption for WEP Key 2. 

128 bits Allows you to use 128 bit encryption for WEP Key 2. 

Factory Default 128 bits 
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Network > WLAN Params > WEP Key 2 

The individual characters for WEP Key 2. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > WEP Key 3 Format 

Allows you to format WEP Key 3 in ASCII or hexadecimal code. 

ASCII Allows you to format WEP Key 3 in ASCII format. 

Hexadecimal 
Allows you to format WEP Key 3 in hexadecimal 
format. 

Factory Default Hexadecimal 

 

Network > WLAN Params > WEP Key 3 Width 

This is the encryption strength. The options are 40 bits and 128 bits: 40 bits 
are weaker and 128 bits are stronger. 

40 bits Allows you to use 40 bit encryption for WEP Key 3. 

128 bits Allows you to use 128 bit encryption for WEP Key 3. 

Factory Default 128 bits 

 

Network > WLAN Params > WEP Key 3 

The individual characters for WEP Key 3. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > WEP Key 4 Format 

Allows you to format WEP Key 4 in ASCII or hexadecimal code. 

ASCII Allows you to format WEP Key 4 in ASCII format. 

Hexadecimal 
Allows you to format WEP Key 4 in hexadecimal 
format. 

Factory Default Hexadecimal 
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Network > WLAN Params > WEP Key 4 Width 

This is the encryption strength. The options are 40 bits and 128 bits: 40 bits 
are weaker and 128 bits are stronger. 

40 bits Allows you to use 40 bit encryption for WEP Key 4. 

128 bits Allows you to use 128 bit encryption for WEP Key 4. 

Factory Default 128 bits 

 

Network > WLAN Params > WEP Key 4 

The individual characters for WEP Key 4. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > Default WEP Key 

Allows you to set the default WEP key (1-4) or None (0). 

Factory Default 0 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > Reset WEP Keys 

Allows you to reset all four WEP keys (WEP Key 1 through WEP Key 4) at 
one time. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN Params > WPA Mode 

Selects the WPA wireless security mode. 

Disable WPA security is disabled. 

Personal 
Selects personal or pre-shared key (PSK) mode for 
WPA security. 

Enterprise 

802.1x is more secure than WPA2 mode. Enterprise 
mode uses dynamic encryption keys distributed 
securely after a user logs in with their username and 
password, or provides a valid digital certificate. An 
Extensible Authentication Protocol (EAP) is used for 
authentication. 

Factory Default Disable 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > WPA Cipher 

Selects the WPA wireless security cipher setting. 

Disable WPA cipher is disabled. 

TKIP Activates Temporal Key Integrity Protocol (TKIP). 

AES Activates Advanced Encryption Standard (AES). 

TKIP+AES 
Activates both TKIP and AES ciphers. This mode is 
sometimes called PSK2-mixed mode. 

Factory Default TKIP if WPA mode is not disabled 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > WPA Pass-Phrase 

Allows you to set the WPA passphrase.   

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN Params > Reset WPA P-Phs 

Allows you to reset all 32 bytes of the WPA passphrase at once. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN EAP 
 

WARNING  Most of these menu items will not change until configuration of the printer is 

deemed complete by the user and the printer is placed ONLINE. Upon going 
online, the printer will automatically reboot and set these options. 

 

Network > WLAN EAP > EAP Mode 

Selects the Extensible Authentication Protocol (EAP) to be used. 

None  EAP not used. 

LEAP 
Uses Lightweight Extensible Authentication Protocol 
(LEAP). 

     PEAP 
Uses Protected Extensible Authentication Protocol 
(PEAP). 

TTLS Uses Tunneled Transport Layer Security. 

TLS Uses Transport Layer Security. 

Factory Default None 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN EAP > EAP User 

The EAP Username. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN EAP > Reset EAP User 

Allows you to reset the EAP Username. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 

 

Network > WLAN Params > EAP Password 

The EAP Password. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Network > WLAN Params > Reset EAP Pswd 

Allows you to reset the EAP Password. 

IMPORTANT If changed, the printer reboots when it is placed 
ONLINE. 
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Application  
 

LP+, PGL, VGL Character Sets 

The Character Sets for LP+, PGL, and VGL are chosen by Character Group and also a Character Set 
within that group. The active Character Group will determine which collection of Character Sets will be 
shown on the panel and available for selection. The LP+, PGL, and VGL each have their own Character 
Group and Character Set selections. In the case of the LP+, every protocol (P-Series, Serial Matrix, etc.) 
except for P-Series XQ will have its own selections as well.  

The Character Group options and Character Set choices are described in this section. The default 
Character Group “Standard Sets” is the legacy character set group and is unique to each emulation or 
protocol. Therefore, it will be shown only in its respective section. The other groups are common and will 
be described here. Any minor variations among the emulations will be highlighted here. 

Character Group is selected within each emulation or protocol by their respective menu Application > 
XXX Setup > Character Group, where XXX represents the emulation or protocol. 

 

Application > XXX Setup > Character Group 

This option selects the Character Set Group. Based on the group selected, 
then the character set can be chosen with the menu following XXX Sets. 

Standard Sets A set of legacy sets via Standard Sets menu. 

Arabic Sets A set of Arabic sets via Arabic Sets menu. 

Cyrillic Sets A set of Cyrillic sets via Cyrillic Sets menu. 

European Sets A set of European sets via European Sets menu. 

Greek Sets A set of Greek sets via Greek Sets menu. 

Hebrew Sets A set of Hebrew sets via Hebrew Sets menu. 

Turkish Sets A set of Turkish sets via Turkish Sets menu. 

UTF-8 Selects the UTF-8 character set. 

Factory Default Standard Sets 

IMPORTANT VGL does not have the UTF-8 character group. 

 

Application > XXX Setup > Standard Sets 

This is the legacy Character Group and is described in each XXX Setup 
section. 

Standard Sets Unique  Unique 

Factory Default Unique 
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Application > XXX Setup > Arabic Sets 

This option will show when menu Character Group is set to Arabic Sets. 

Arabic Sets 

ASMO 449 

ASMO 449+ 

ASMO 708 

ASMO 708+ 

MSDOS CP710 

MSDOS CP720 

Sakr CP714 

Aptec CP715 

CP 786 

IBM CP864 

IBM CP1046 

Arabic Lam One 

Arabic Lam Two 

Win. CP1256 

Farsi 1 

Farsi 2 

1098 Farsi 1285 

Factory Default ASMO 449 

 

Application > XXX Setup > Cyrillic Sets 

This option will show when menu Character Group is set to Cyrillic Sets. 

Cyrillic Sets 

Code Page 866 

Cyrillic CP 437 

Cyrillic 113 

Cyrillic 8859-5 

ISO 915 

Code Page 855 

Cyrillic 7 bit 

Ukrainian 

Bulgarian 

Win. CP 1251 

Latvian 866 

CP 1048 

Factory Default Code Page 866 

IMPORTANT 
CP 1048 is not available for VGL, P-Series, Serial 
Matrix, or Proprinter XL. 
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Application > XXX Setup > European Sets 

This option will show when menu Character Group is set to European Sets. 

European Sets 

Latin 2 8859-2 

Code Page 852 

Mazovia 

Kamenicky 

Roman 8 

PC-437 Slavic 

Slavic 1250 

Code Page 865 

Code Page 860 

Latin 1 8859-1 

Latin 5 8859-9 

Latin 9 8859-15 

Polish POL1 

Win. CP 1250 

Win. CP 1252 

Win. CP 1257 

CP 858 EURO 

Lith. CP 773 

Serbo Croatic 1 

Serbo Croatic 2 

CP 774 

CP 775 

ISO 8859-4 

Factory Default Latin 2 8859-2 

 

Application > XXX Setup > Greek Sets 

This option will show when menu Character Group is set to Cyrillic Sets. 

Greek Sets 

DEC 256 Greek 

ELOT 928 Greek 

Greek 3 

ABY Greek 

ABG Greek 

ELOT 927 Greek 

Greek 851 

Greek 437 

Greek 8859-7 

Win. CP 1253 

Greek 813 EURO 

Greek 869 EURO 

Factory Default DEC 256 Greek 

 

Application > XXX Setup > Hebrew Sets 

This option will show when menu Character Group is set to Hebrew Sets. 

Hebrew Sets 

Hebrew Old 

Hebrew New 

Hebrew DEC 

Latin-1 Hebrew 

Win. CP 1255 

Factory Default Hebrew Old 
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Application > XXX Setup > Turkish Sets 

This option will show when menu Character Group is set to Turkish Sets. 

Turkish Sets 

Data Gen. Turk.* 

DEC Turkish 

IBM Turkish 

Siemens Turkish 

PTT Turkish 

IBC Turkish 

Bull Turkish 

AS400 Turkish  

Unisys Turkish 

NCR Turkish 

PST Turkish 

UNIS-1 Turkish 

Code Page 853 

INFO Turkish 

Win. CP 1254 

Code Page 857 

Azeri 

Factory Default Data Gen. Turk.* 

IMPORTANT 
Azeri is not available for P-Series, Serial Matrix, or 
Epson-FX. 

 

Application > XXX Setup > UTF-8 

This option will show when menu Character Group is set to UTF-8. 

UTF-8 Sets UTF-8 

Factory Default UTF-8 

IMPORTANT VGL does not support UTF-8. 
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Application > Control 
 

Application > Control > Active IGP Emul 

This function allows you to activate any IGP emulation listed in the menu. 
The IGP emulation can be changed with this menu or by host command if 
the current Active IGP emulation supports it.  

PGL Printronix Graphics Language. 

VGL Emulates the QMS Code-V protocol. 

ZGL  Emulates the Zebra ZPL protocol. 

TGL  Emulates the Toshiba TEC protocol. 

IGL  Emulates the Intermec IPL protocol. 

STGL  Emulates the Sato SPL protocol. 

DGL  Emulates the Datamax DPL protocol. 

IEGL  Emulates the IER IER-520 protocol. 

MGL  Emulates the Monarch MPCL II protocol. 

EGL  Emulates the Eltron Thermal Series protocol. 

CGL  Available upon special request only. 

Factory Default PGL 

NOTE:  The menus for Emulations are described in detail in their respective Programmer’s Reference 

Manual available from our company’s website. 
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Application > Control > PGL Diagnostics 

This menu sets the error reporting capability of PGL when selected as the 
current Active IGP emulation.  

On 
Full error checking reported. Any element that falls off 
the current page is reported as an error. 

Debug Mode 

Puts the printer in debug mode whenever a form is 
defined in CREATE mode. Each line of the CREATE 
form will be printed along with an error if one has 
occurred. 

Fault 

Allows you to halt the printer if a PGL error occurs. If 
you select this option, the PGL error prints on the 
paper, the message “PGL Error” displays on the front 
panel and the printer goes OFFLINE. You must clear 
the error before the printer can resume normal 
operation. 

Host 
Full error checking reported. Error messages are sent 
back to the host through the port based on the menu 
“Ret. Status Port” instead of being printed on paper. 

Off 
There is no error checking. Graphic elements such as 
alpha, line, barcodes, etc., will be clipped if they are 
beyond the page boundaries. 

Factory Default On 

IMPORTANT 
This is only shown when PGL is the Active IGP 
Emulation.  
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Application > Control > VGL Diagnostics 

This menu sets the error reporting capability of VGL when selected as the 
current Active IGP emulation.  

Enable All Full error checking and report. 

Disable No error checking and report. 

Error Msgs 
Command syntax is checked and error messages 
printed when command parameters are incorrect. 

Error Markers 

Prints the following error markers for those elements 
that print beyond the page boundaries: 

>> For elements that begin off the right side of the 
page. 

<< For elements that begin at the indicated position 
but end off the page. 

For elements where the starting position of the 
command contains an error other than an off-page 
error. 

Offpage Errors 
Reports errors for elements that start or end beyond 
the right edge of the page. 

Barcode Errors 
An error message will print when invalid barcode data 
is encountered. 

Factory Default Disable 

IMPORTANT 
This is only shown when VGL is the Active IGP 
Emulation.  

 

Application > Control > XXX Diagnostics 

This menu sets the error reporting capability of the Active IGP Emulation 
(except PGL and VGL). “XXX” is used to denote the Active IGP Emulation 
ZGL, TGL, IGL, STGL, DGL, MGL, EGL or IEGL. 

Disable Disable error checking.. 

Print Print the errors on the label. 

Debug Port Send the information out the debug serial port. 

Factory Default Disable 

IMPORTANT 
For PGL, see PGL Diagnostics and for VGL, see 
VGL Diagnostics instead.  

 

 

 



 

Page | 143 
 

Application > Control > Active LP+ Emul 

This function allows you to select the Active LinePrinter+ protocol. The LP+ 
is used to print text or jobs that are not associated with any IGP emulation. 
Refer to the LinePrinter Plus Programmer's Reference Manual for more 
information. 

P-Series Printronix P-Series language. 

P-Series XQ Printronix P-Series XQ language. 

Serial Matrix Emulates the Serial Matrix protocol. 

Proprinter XL Emulates the Proprinter XL protocol. 

Epson FX Emulates the Epson FX-1050 protocol. 

Factory Default P-Series 

 

Application > Control > PTX Setup SFCC 

Allows you to choose the hex value of the ASCII character you wish to use 
as the SFCC for the PTX SETUP command. 

Minimum hex 01 

Maximum hex FF 

Factory Default hex 21 or the “!” character 

 

Application > Control > PTX Setup Parse 

Determines how PTX_SETUP commands as described in the section The 
PTX_SETUP Commands are handled within the data stream. 

Enable Will parse and execute the PTX_SETUP commands 

Ignore Will parse PTX_SETUP commands but ignore them 

Disable 
Will not parse the PTX_SETUP commands so they 
will be treated as normal text. 

Factory Default Enable 
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Application > Control > PAA: Select Tool 

You can enable a CST (Character Substitution Table) with this menu. The 
CST is loaded in the printer FLASH memory and will be executed by the 
PAA (Printronix Application Adapter). Refer to the PrintNet Enterprise Suite 
User’s Manual to learn more about how to create and use CSTs. 

None No CST will be active. 

CST-1 CST-1 is active. 

CST-2 CST-2 is active. 

Factory Default None 

IMPORTANT 

This menu only appears if a CST is loaded. A CST 
file *.bnd will show in the System > Flash File 
View submenu and is also visible in the 
Configuration Printout header. 

 

Application > Control > Compatibility 

This parameter allows you to make T800 series thermal printers compatible 
with other printers. 

When trying to preserve compatibility with respect to barcodes, you may not 
always be able to make them equal in size. This is due to the various dot-
per-inch differences between printer types. When an exact match cannot be 
made, the barcode is reduced in size so that the form bounds will not be 
compromised and the barcode will be readable. 

Default Use for optimum performance. 

Laser 
Forces the output to correspond with the Printronix 
laser line of printers. 

P5000 
 Forces the output to correspond to the P5000 line of 
line matrix printers. 

T3000 
Forces the ouput to correspond to the T3000 line of 
thermal printers. 

T1006 
Forces the output to correspond to the T1006 line of 
thermal printers. 

Factory Default Default 
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Application > Control > PJL Control 

Allows you to choose how the PJL (Printer Job Language) protocol is 
handled in the printer when sending jobs through the Active IGP Emulation 
or LP+. 

Disable 
PJL commands will be ignored and processed like 
other emulation data. 

Enable PJL commands will be processed. 

Factory Default Disable 

 

Application > PGL Setup 
 

IMPORTANT  The PGL Setup submenu will only be present when the Active IGP Emulation is 

set to PGL. Otherwise, this menu will be replaced with the Active IGP 
Emulation Setup menu. 

 
 

Application > PGL Setup > Character Group 

This option selects the Character Set Group. Based on the group selected, 
the character set can be chosen with the menu following XXX Sets. The 
group Standard Sets is shown below because it is unique to PGL. All other 
groups are similar and described in their respective Programmers 
Reference Manuals. 

 
 

Application > PGL Setup > Standard Sets 

This option will show when menu Character Group is set to Standard Sets. 

Standard Sets 

0) ASCII 

1) German 

2) Swedish 

3) Danish 

4) Norwegian 

5) Finnish 

6) English 

7) Dutch 

8) French 

9) Spanish 

10) Italian 

11) Turkish 

12) CP 437 

13) CP 850 

14-15) Reserved 

16-23 Dwn Overlay 

24-31) User Def. 

Factory Default 0) ASCII 
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Application > PGL Setup > Select LPI 

This is the number of lines to be printed per inch. For example, at 6 lpi 
there is 1/6 inch from the top of one print line to the top of the next print 
line. 

Minimum 1 

Maximum 1000 

Factory Default 6 

 

Application > PGL Setup > Define CR Code 

This option controls the action of the printer when it receives a Carriage 
Return code (0D hex) from the host computer. If this feature is enabled, 
each time the printer receives a Carriage Return, it inserts an additional 
Line Feed code (0A hex) into the data stream. Do not use this feature if the 
host computer sends line feeds to the printer. 

CR = CR 
Does not insert an extra line feed after each carriage 
return. 

CR = CR+LF 
Inserts an extra line feed after each carriage return. 
The next print position will be print position 1 of the 
next line. 

Factory Default CR = CR 

 

Application > PGL Setup > Define LF Code 

This parameter forces the printer to insert an automatic Carriage Return 
into the data stream whenever a Line Feed occurs. This can be used in 
most installations, but it is required if the host computer does not send 
carriage returns to the printer. 

LF = LF 
Does not perform an automatic carriage return. The 
next print position will be at the current print character 
position on the next line. 

LF = CR + LF 
Performs an automatic carriage return. The next print 
position will be print position 1 of the next line. 

Factory Default LF = LF 

 



 

Page | 147 
 

Application > PGL Setup > Autowrap 

This parameter determines if text will wrap to the next line when the line of 
text exceeds the right margin. 

Disable 
Truncates the text beyond the right margin until a CR 
or CR + LF is received. 

Enable Automatically inserts a CR + LF after a full print line. 

Factory Default Disable 

 

Application > PGL Setup > Auto Uppercase 

This parameter enables the printer to print text in all uppercase when using 
the ALPHA command. 

Disable The printer will print text in upper and lowercase. 

Enable The printer will print text in uppercase only. 

Factory Default Disable 

 

Application > PGL Setup > Slash 0 

This parameter allows you to print the numeral “0” with or without the slash.  

Disable Zero is printed without a slash. 

Enable Zero is printed with a slash. 

Factory Default Disable 

IMPORTANT This option does not apply to OCR A or OCR B. 

 

Application > PGL Setup > Select SFCC 

You can specify which decimal code (1-255) will be used as the Special 
Function Control Code (SFCC). The SFCC denotes that the following data 
is a PGL command. 

Minimum 1 

Maximum 255 

Factory Default 126 
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Application > PGL Setup > Host Form Length 

Determines how Media > Image > Label Length is affected upon receiving 
an EXECUTE command.  

Enable 

The physical label length will change to match the 
form length (specified in CREATE command). The 
physical label size remains at the new setting until 
another EXECUTE command is received, or the 
PRINTER CONTROL menu settings are changed. 

Var. Length 

The physical label length is the longest element 
defined in CREATE mode. Works with 
CREATE;NAME;0. This includes all dynamic 
elements whether used in EXECUTE mode or not. 

Var Dynamic 
Len 

The physical label length will change to the longest 
print element used in EXECUTE mode plus the 
setting of “Var Form Adjust.” Works with 
CREATE;NAME;0. If dynamic elements are not used 
in EXECUTE mode, they are not included. 

Disable 

Forms printed in EXECUTE mode do not change the 
physical label size. Therefore, the size of the form 
(defined in CREATE mode) must fit within the current 
label dimensions, or errors may be reported. 

Factory Default Enable 

IMPORTANT 

Changing the form length via the EXECUTE 
command changes the LP+ Emulation logical 
dimensions. 

 

Application > PGL Setup > Var Form Adjust 

This specifies an amount (in tenths of inches) to add to the length of 
variable- length forms. Variable-length forms use a semicolon at the end of 
the CREATE command: ~CREATE;<FORMNAME>;0. 

Typically, variable-length forms are determined by the elements within the 
form. The longest form element becomes the overall form length. This 
option allows an additional space to be added to the form length. 

Minimum 0.0 inches 

Maximum 3.0 inches 

Factory Default 0.0 inches 
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Application > PGL Setup > Var Form Type 

This parameter allows you to manipulate forms created with the CREATE 
command to include variable form length parameters.   

Add Nothing When selected, no action is taken. 

Add ;0 
When selected, the form length ends at the longest 
printed element. (Same as ~CREATE;filename;0). 

Add ;X 
When selected, the form length is set to match the 
value in Media > Image > Label Length. 

Factory Default Add Nothing 

 

Application > PGL Setup > Skip Cmd Prefix 

Stands for Skip Command Prefix. This parameter determines if the printer 
will print any data before a PGL command is received. 

Disable The printer will print all data before a PGL command. 

Enable The printer ignores all data before a PGL command. 

Factory Default Enable 

 

Application > PGL Setup > Ignore Text 

Determines if text in NORMAL mode will be printed or ignored. 

Disable 
When disabled, text in normal mode will be printed. 
Attributes to be printed depend on the PGL Normal 
menu setting. 

Enable 
When enabled, any line of text (non-PGL commands) 
in normal mode will be ignored. 

Factory Default Disable 
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Application > PGL Setup > Ext Execute Copy 

Determines if dynamic text or overlay data is allowed when the Form Count 
parameter (number of forms to print) is used as part of the EXECUTE 
command. 

Disable 
Dynamic data, overlay data, etc. are not allowed if the 
optional Form Count parameter is specified (IGP-100 
compatible). 

Enable 

Dynamic data, overlay data, etc. are allowed within a 
form where the Form Count parameter is specified. In 
this case, the same form is printed for whatever the 
Form Count is.  

Factory Default Disable 

IMPORTANT 

When enabled, incremental data is not 
incremented since the printing page is the same.  

Overlay data is only printed with the first form and 
not on subsequent forms, and each form is 
printed on a separate page. 

 

Application > PGL Setup > AI 00 Spaces 

This option is designated for EAN/UCC-128 barcodes whose application 
identifier (AI) is 00. 

Disable 
The printable data field is printed with the AI enclosed 
in parentheses. This is the standard EAN/UCC-128 
format. 

Enable 
The printable data field is printed with the UCC fields 
separated by spaces. This option is IGP-X00 
compatible. 

Factory Default Disable 

 

Application > PGL Setup > Select SO Char 

Allows you to specify a decimal code from 0 through 255 to be used in 
place of SO (Shift Out) as the control code which allows access for the 
alternate set of control function characters. See the description of the Code 
128 barcodes in the PGL Programmer's Reference Manual for details. 

Minimum 0 

Maximum 255 

Factory Default 14 
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Application > PGL Setup > Ignore Mode 

This parameter instructs the IGP to ignore the character selected under the 
Select Character menu. 

Disable The IGP does not ignore any characters. 

Enable 
The IGP ignores the character specified in the Select 
Char menu. 

Factory Default Disable 

 

Application > PGL Setup > Select Char 

Instructs the IGP which decimal character (0-255) to ignore from the host. 

Minimum 0 

Maximum 255 

Factory Default 0 

 

Application > PGL Setup > Do FF at TOF 

Determines whether the printer, with media already set at the TOF (Top-of- 
Form) position, will advance media to the next TOF position upon receipt of 
an FF command. 

Disable 
The printer will not advance media from the present 
TOF position to the next TOF position upon receipt of 
an FF command. 

Enable 
The printer will advance media from the present TOF 
position to the next TOF position upon receipt of an 
FF command, causing a blank form. 

Factory Default Enable 

 

Application > PGL Setup > IGP100 Compatbl. 

This parameter forces the output to correspond with IGP-100 line matrix 
printer output in cases where there are differences. 

Disable 
In areas of conflict, the printer will be compatible with 
legacy thermal products (best behavior). 

Enable 
The printer will match compatibility in all ways with 
legacy line matrix products. 

Factory Default Disable 
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Application > PGL Setup > Forms Handling 

This submenu allows the user to handle the form in various ways. 

Disable Standard behavior. 

Auto Eject 
Automatically ejects a page at the end of the job to 
spill out the last page. 

Auto TOF 
Automatically does a form feed (FF) at the end of 
each form to the next top of form. 

Factory Default Disable 

 

Application > PGL Setup > PGL Normal 

This option determines whether PGL passes the text data in Normal mode 
according to LP+ or whether PGL will print the text data itself. 

LP+ Menu 
PGL will pass the text data to LP+ only in the default 
setting state (6 LPI, default character set, and font 
attribute). 

PGL Menu PGL will always print the text data itself. 

Factory Default LP+ Menu 

 

Application > PGL Setup > UPC Descenders 

This parameter allows you to print bar code descenders when human 
readable data is not presented in the UPC/EAN bar codes. 

Always 
UPC/EAN bar codes are printed with descenders, 
even if there is no human readable data. 

Never 
UPC/EAN bar codes are printed without descenders if 
the PDF command is present. 

Only with PDF 
UPC/EAN bar codes are printed with descenders only 
when the PDF command is presented. 

Factory Default Always 
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Application > PGL Setup > I-2/5 Selection 

This option is added to be compatible with a special IGP-X00 
customization. Usually, if Interleaved 2/5 bar codes have an odd number of 
digits, a leading zero is inserted in front of the data. However, this special 
IGP-X00 customization gives you the option of adding a space character at 
the end of the bar code instead. 

Leading Zero A leading zero is inserted in front of the data. 

Trailing Space 
A space is inserted at the end of the data instead of a 
leading zero. 

X2 DPD 
When selected, I-2/5 bar code with a magnification X2 
will use the specially configured ratios 3:3:6:5 rather 
than 3:6:9:12 for compatibility issues. 

Modulo 7 CD 
The I-2/5 bar code uses a modulo 7 check digit 
instead of the default modulo 10 check digit. 

Factory Default Leading Zero 

 

Application > PGL Setup > C39 Compatbl. 

This menu makes the old method of decoding C39 alternative character set 
compatible with the new. 

Disable Uses the proper way of decoding. 

Enable Matches the old legacy IGP-100 method of decoding. 

Factory Default Disable 

 

Application > PGL Setup > User-Def Ratio 

This option allows you to ignore the user-defined barcode ratio and replace 
it with the default ratio (X1). 

Disable 
The user-defined barcode ratio will be replaced with 
the default ratio (X1). 

Enable User-defined barcode ratios will be used as supplied. 

Factory Default Enable 
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Application > PGL Setup > Lead PDF Dist 

Adjusts the leading and trailing character spacing distance of the PDF for 
UPC/EAN barcodes. The value can be modified in 0.01 inch increments. 

Minimum 0.01 inches 

Maximum 0.10 inches 

Factory Default 0.10 inches 

 

Application > PGL Setup > Trunc Dyn Data 

This menu allows the user to truncate the dynamic data up to the maximum 
data length specified in Create Mode. 

Disable 
If the dynamic data exceeds the maximum data 
length, an error will report. 

Enable 
If the dynamic data exceeds the maximum data 
length, the data truncates. 

Factory Default Disable 

 

Application > PGL Setup > Boundary Check 

This option turns on or off the page boundary check for all print elements. 

Disable 
No out of bound error is reported. The out of bound 
print element prints over the page boundary. 

Enable 
An out of bound error is reported if the print element is 
out of the page boundary. 

Factory Default Enable 

 

Application > PGL Setup > Preparser 

Allows you to send preparser commands to the printer through any port. 

Disable Not using the Preparser command. 

Enable 
The preparser command can be accepted from any 
port. 

Factory Default Disable 
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Application > PGL Setup > Storage Select 

Allows the user to map the parameter DISK to either SD (SD card) or 
FLASH memory. 

Disk=SD Have the DISK command default to the SD card. 

Disk=PCB 
Flash 

Have the DISK command default to the FLASH 
memory. 

Disk=DRAM 
Have the DISK command default to the DRAM 
memory and will be erased upon power-off. 

Factory Default Disk=SD 
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Application > LP+ SETUP 

 

 

Application > LP+ Setup > Select CPI 

This item selects the characters per inch (CPI) value. 

Selections 10.0, 12.0, 13.3, 15.0, 17.1, and 20.0 CPI 

Factory Default 10.0 CPI 

 

Application > LP+ Setup > Select LPI 

This is the number of lines to be printed per inch. For example, at 6 LPI 
there is 1/6 inch from the top of one print line to the top of the next print 
line. 

Selections 6.0, 8.0, 10.3 LPI 

Factory Default 6.0 LPI 

 

Application > LP+ Setup > Host Command 

This item allows you to select certain host commands to be ignored by the 
printer. 

Enable All host commands accepted by printer. 

Ignore All All commands are ignored. 

Ignore CPI All CPI commands are ignored. 

Ignore LPI All LPI commands are ignored. 

Factory Default Enable 
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Application > LP+ Setup > Typeface 

The font style or typeface to be used when printing text. 

Letter Gothic 
Letter Gothic is a non-proportional font where all of 
the characters take up the same amount of space 
when printed. 

Courier 
Courier is a non-proportional (monospaced) font 
where all characters take up the same amount of 
space when printed. 

OCR-A Optical character recognition font prints only at 10 cpi. 

OCR-B Optical character recognition font prints only at 10 cpi. 

Factory Default Letter Gothic 

 

Application > LP+ Setup > Prop. Spacing 

Each printed character is contained inside a character cell. The width of the 
character cell includes the character and the space around the character. 

Disable 
Each character cell is printed with the same width. 
Each column in the printed text will line up. 

Enable 

The width of each character cell varies with the width 
of the character. For example, ‘i’ takes less space to 
print than ‘m’. Using proportional fonts generally 
increases the readability of printed documents, giving 
text a typeset appearance. 

Factory Default Enable 

 

Application > LP+ Setup > Bold 

To determine if the text printed by the LP+ uses a heavy thickness. 

Disable Text is printed normally. 

Enable Text is printed with a heavy thickness. 

Factory Default Disable 

 



 

Page | 158 
 

Application > LP+ Setup > Italic Print 

To determine if the text printed by the LP+ uses italics. 

Disable Text is printed normally. 

Forward Slant Text is printed with a forward slant. 

Backward Slant Text is printed with a backward slant. 

Factory Default Disable 

 

Application > LP+ Setup > Slashed Zero 

This parameter allows you to print the numeral ‘0’ with or without the slash.  

Disable Zero is printed without a slash. 

Enable Zero is printed with a slash. 

Factory Default Disable 

IMPORTANT This option does not apply to OCR-A or OCR-B. 

 

Application > LP+ Setup > Text Position 

Specifies where the text will be positioned in the line space. 

Top of Line Text is positioned at the top of the line space. 

Bottom of Line 
Text is positioned as if it were at the bottom of a line 
space at 6 LPI. The following example picture below 
shows both Top of Line and Bottom of Line positions. 

Factory Default Bottom of Line 

IMPORTANT This option does not apply to OCR-A or OCR-B. 
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Application > LP+ Setup > Form Length (xx) 

Specifies form length in three different units for all preferences of the user: 
inches, millimeters, and even lines. 

Minimum 0.1 inches 

Maximum 99.0 inches (or maximum Label Length) 

Factory Default 6.0 inches 

 

Application > LP+ Setup > Form Width (xx) 

Specifies form width in three different units for all preferences of the user: 
inches, millimeters, and even characters. The maximum is allowed beyond 
the physical length, but should not be used. 

Minimum 0.1 inches 

Maximum 13.6 inches 

Factory Default 4.1 inches 

WARNING 
The width should not exceed the actual paper 
width to prevent damage to the platen. 

 

Application > LP+ Setup > Left Margin 

Set in characters. Character zero is defined as the far left edge of the 
page, and column numbering increments from left to right. 

Minimum 0 characters 

Maximum 369 characters 

Factory Default 0 characters 

 

Application > LP+ Setup > Right Margin 

Set in characters. Character zero is defined as the far right edge of the 
page, and column numbering increments from right to left. 

Minimum 0 characters 

Maximum 369 characters 

Factory Default 0 characters 
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Application > LP+ Setup > Top Margin 

Defined in linespaces, starting from line zero at the top of the page and 
incrementing from the top down. 

Minimum 0 linespaces 

Maximum 451 linespaces 

Factory Default 0 linespaces 

 

Application > LP+ Setup > Bottom Margin 

Defined in linespaces, starting from line zero at the bottom of the page and 
incrementing from the bottom up. 

Minimum 0 line spaces 

Maximum 451 line spaces 

Factory Default 0 line spaces 

 

Application > LP+ Setup > Print Char. Set 

Selecting this executable menu by pressing the  ENTER key causes the 

printer to print the currently selected character set. 

 

Application > LP+ Setup > Reset Cmd CFG Ld 

When the printer receives a host data stream reset command (ESC @ or 
ESC[K) in addition to resetting printer variables, the selected configuration 
is loaded. 

Disable 
The active emulation parameters are loaded when the 
reset command is executed. 

Power up 
Config 

The power-up configuration is loaded when the reset 
command is executed. 

Current config 
The currently selected configuration is loaded when 
the reset command is executed. 

Factory config 
The factory installed configuration is loaded when the 
reset command is executed. 

Factory Default Disable 
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Application > P-SERIES Setup 

 

IMPORTANT  The P-SERIES Setup submenu will only be present when the LP+ Emulation 

menu is set to P-SERIES. Otherwise, this menu will be replaced with the LP+ 
Emulation menu. 

 

Application > P-Series Setup > Character Group 

This option selects the Character Set Group. Based on the group selected, 
then the character set can be chosen with the menu following XXX Sets. 
The group Standard Sets is shown below because it is unique to P-Series. 
All other groups are similar and described in LP+, PGL, VGL Character 
Sets. 

 
 

Application > P-Series Setup > Character Set  

This option will show when menu Character Group is set to Standard Sets. 
Note that depending on which value is chosen, other menu(s) can be 
unhidden. For example, when IBM PC is selected, a menu Primary Subset 
and Extended Subset is available as shown in this table. 

IBM PC 
When selected, Primary Subset and Extended Subset 
menus will be unhidden. 

Multinational 
When selected, the Multinational menu will be 
unhidden. 

ECMA Latin 1 
When selected, Primary Subset and Extended Subset 
menus will be unhidden. 

DEC Mult When selected, the DEC Mult. menu will be unhidden. 

CP 858 EURO No other menus will be unhidden. 

Factory Default IBM PC 

IMPORTANT 
Upon different choices, menus may be unhidden 
as described. 
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Application > P-Series Setup > Primary Subset 

Application > P-Series Setup > Multinational 

Application > P-Series Setup > DEC Mult. 

One of these menus may be available when the Character Group is 
Standard Sets. The menu bolded in the right column below is unhidden 
and will have options with defaults marked (*). If the Character Set option is 
not shown in the left column, none of these menus is available. 

Character Set = 
IBM PC 

Primary Subset 

ASCII (USA) *, French, German, English, Danish, 
Swedish, Italian, Spanish, Japanese, French 
Canadian, Latin American, Norwegian, Danish II, 
Spanish II, Latin Am II 

Character Set = 
Multinational 

Multinational 

ASCII (USA) *, EBCDIC 

Character Set = 
ECMA Latin 1 

Primary Subset 

ASCII (USA) *, German, Swedish, Danish, 
Norwegian, Finnish, English, Dutch, French, Spanish, 
Italian, Turkish, Japanese 

Character Set = 
DEC Mult 

DEC Mult. 

ASCII (USA) *, French, German, English, 
Norw./Danish, Swedish, Italian, Spanish, Japanese, 
French Canadian, Dutch, Finnish, Swiss 

Factory Default As shown with asterisk (*). 

 

Application > P-Series Setup > Extended Subset 

One of these menus will be available when the Character Group is 
Standard Sets. The menu at the right column is unhidden and will have 
options as shown with defaults marked (*).If the Character Set option is not 
shown in the left column, no menu is unhidden. 

Character Set = 
IBM PC 

Extended Subset 

Code Page 437 *, Code Page 850 

Character Set = 
ECMA Latin 1 

Extended Subset 

Multinational *, Barcode 10 cpi, Mult. DP 10 cpi, Mult. 
DP 12 cpi, Mult. LQ 10 cpi, Greek DP 10 cpi, Greek 
DP 12 cpi, Greek LQ 10 cpi, Grap. DP 10 cpi, Grap. 
LQ 10 cpi, Sci. DP 10 cpi, Sci. DP 12 cpi, Sci. LQ 10 
cpi 

Factory Default As shown with asterisk (*). 
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Application > P-Series Setup > Horizontal DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a horizontal resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi horizontal resolution, depending on the 
print head installed. 

Minimum 60 

Maximum 400 

Factory Default 120 

 

Application > P-Series Setup > Vertical DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a vertical resolution that matches that of the 
printer that the file was originally generated for. 

 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi vertical resolution, depending on the 
print head installed. 

Minimum 72 

Maximum 400 

Factory Default 72 

 

Application > P-Series Setup > Define CR code 

This option controls the action of the printer when it receives a Carriage 
Return code (0D hex) from the host computer. If this feature is enabled, 
each time the printer receives a carriage return, it inserts an additional Line 
Feed code (0A hex) into the data stream. Do not use this feature if the host 
computer sends line feeds to the printer. 

CR = CR 
Does not insert an extra line feed after each carriage 
return. 

CR = CR + LF 
Inserts an extra line feed after each carriage return. 
The next print position will be print position 1 of the 
next line. 

Factory Default CR = CR 

 



 

Page | 164 
 

Application > P-Series Setup > Auto LF 

This option defines the printer action when print data is received past the 
forms width setting. 

Disable Discards any data past the forms width. 

Enable 
Performs an automatic carriage return and line feed 
when data is received past the forms width. 

Factory Default Disable 

 

Application > P-Series Setup > Define LF Code 

This option controls the action of the printer when it receives a Line Feed 
code (0A hex) from the host computer. If this feature is enabled, each time 
the printer receives a line feed, it inserts an additional carriage return code 
(0D hex) into the data stream. Do not use this feature if the host computer 
sends carriage returns to the printer. 

LF = LF 
Does not insert a carriage return before each line 
feed. The next print position will be the current print 
position of the next line. 

LF = CR + LF 
Inserts an extra carriage return before each line feed. 
The next print position will be print position 1 of the 
next line. 

Factory Default LF = CR + LF 

 

Application > P-Series Setup > Control Code 06 

Control Code 06 defines the function of ASCII code 06 hex (ACK). You can 
select an alternate line spacing of 6.0, 8.0, or 10.3 LPI. 

Selections 6.0, 8.0, or 10.3 LPI 

Factory Default 8.0 LPI 

 

Application > P-Series Setup > Control Code 08 

Control Code 08 defines the function of ASCII code 08 hex (BS). You can 
define the code to output an Elongated character or a Backspace.  

Elongated Output and Elongated character 

Backspace Output and Backspace character 

Factory Default Elongated 
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Application > P-Series Setup > Overstrike 

Overstrike determines the action required when a line is printed over a 
previous line because a carriage return was received without a line feed. 

Disable 
Replaces the characters from the first line with the 
second line. 

Enable 
Prints the second line on top of the first line making it 
bolder. 

Factory Default Enable 

 

Application > P-Series Setup > Select SFCC 

This P-Series feature allows you to select an ASCII code which defines the 
Special Function Control Code (SFCC) command code value. The factory 
default value is hex 01, but the P-Series options allow selection of any 
value ranging from hex 00 through hex 7F. This powerful feature permits 
the SFCC code to be assigned a value compatible with the application 
environment where the P-Series jobs originate. The most commonly used 
values include the following: SOH (01 hex), ESC (1B hex), ETX (03 hex), ^ 
(5E hex), and ~ (7E hex). 

Minimum 00 hex 

Maximum 7F hex 

Factory Default 01 hex 

IMPORTANT 

Non-Printable ASCII code values range from hex 
00 through hex 1F and also include hex 7F. 
Printable ASCII code values range from hex 20 
through hex 7E. If a printable code value is 
chosen to define the SFCC code value, you must 
ensure that the printer data stream will not 
contain the same code value in printable text. 
Otherwise text containing the character for the 
SFCC control code value may be incorrectly 
processed as an SFCC command causing print 
errors. 

 

Application > P-Series Setup > EVFU Select 

Controls how the printer handles vertical formatting. 

Disable Disables all EVFU processing. 

Enable 
Selects P-Series compatible Electronic Vertical 
Format Unit (EVFU). 

Factory Default Enable 
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Application > P-Series Setup > Alt. Set 80-9F 

Determines how data in the range 80 hex – 9F hex will be treated. 

Control Code Interprets as a control code. 

Printable Prints data in this range. 

Factory Default Control Code. 

 

Application > P-Series Setup > SFCC d command 

This menu option is for backward compatibility. 

Even dot plot 
This option interprets the SFCC d command as even 
dot plot. 

Double High 
This option interprets the SFCC d command as 
double high. Select this option for backward 
compatibility. 

Factory Default Even dot plot 

 

Application > P-Series Setup > PSeries Dbl High 

This menu option allows printing compatibility between the current and 
older models of Printronix printers. 

Normal 
This is normal Double High printing for current model 
printers. 

P3/4/6/9 
Compat. 

Where older printers printed two dot rows higher, this 
option allows for compatibility by raising the print two 
dot rows to match the current models dot row value 
(two dot rows lower). 

Factory Default Normal 

 

Application > P-Series Setup > FF valid at TOF 

The FF valid at TOF option determines whether the printer will perform a 
Form Feed when the host sends a Form Feed command, if the printer is at 
the top of form. 

Disable 
Will not perform a form feed when the host sends a 
Form Feed and the printer is at the top of form. 

Enable 
Performs a form feed when the host sends a Form 
Feed and the printer is at the top of form. 

Factory Default Enable 
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Application > P-SERIES XQ Setup 
 
IMPORTANT  The P-SERIES XQ Setup submenu will only be present when the LP+ Emulation 

menu is set to P-SERIES XQ. Otherwise, this menu will be replaced with the 
LP+ Emulation menu. 

 
IMPORTANT  This LP+ emulation does not have any specific Character Group or Character 

Set selection. 

 

Application > P-Series XQ Setup > Horizontal DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a horizontal resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi horizontal resolution, depending on the 
print head installed. 

Minimum 60 

Maximum 400 

Factory Default 120 

 

Application > P-Series XQ Setup > Vertical DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a vertical resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi vertical resolution, depending on the 
print head installed. 

Minimum 72 

Maximum 400 

Factory Default 72 
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Application > P-Series XQ Setup > Define CR code 

This option controls the action of the printer when it receives a Carriage 
Return code (0D hex) from the host computer. If this feature is enabled, 
each time the printer receives a carriage return, it inserts an additional Line 
Feed code (0A hex) into the data stream. Do not use this feature if the host 
computer sends line feeds to the printer. 

CR = CR 
Does not insert an extra line feed after each carriage 
return. 

CR = CR + LF 
Inserts an extra line feed after each carriage return. 
The next print position will be print position 1 of the 
next line. 

Factory Default CR = CR 

 

Application > P-Series XQ Setup > Auto LF 

This option defines the printer action when print data is received past the 
forms width setting. 

Disable Discards any data past the forms width. 

Enable 
Performs an automatic carriage return and line feed 
when data is received past the forms width. 

Factory Default Disable 

 

Application > P-Series XQ Setup > Define LF Code 

This option controls the action of the printer when it receives a Line Feed 
code (0A hex) from the host computer. If this feature is enabled, each time 
the printer receives a line feed, it inserts an additional carriage return code 
(0D hex) into the data stream. Do not use this feature if the host computer 
sends carriage returns to the printer. 

LF = LF 
Does not insert a carriage return before each line 
feed. The next print position will be the current print 
position of the next line. 

LF = CR + LF 
Inserts an extra carriage return before each line feed. 
The next print position will be print position 1 of the 
next line. 

Factory Default LF = CR + LF 
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Application > P-Series XQ Setup > Control Code 06 

Control Code 06 defines the function of ASCII code 06 hex (ACK). You can 
select an alternate line spacing of 6.0, 8.0, or 10.3 LPI. 

Selections 6.0, 8.0, or 10.3 LPI 

Factory Default 8.0 LPI 

 

Application > P-Series XQ Setup > Compressed Print 

Controls which host command enables compressed printing. 

Char 01 SOH  

Char 03 ETX  

Char 09 HT  

Factory Default Char 01 SOH 

 

Application > P-Series XQ Setup > Elong/Alt. Font 

Controls which host command sets elongated (double high) fonts and 
extended character set. 

ELNG=BS 
FONT=SO 

Elongated set by BS (08 hex), extended character set 
set by SO (0E hex). 

ELNG=SO 
FONT=BS 

Elongated set by SO (0E hex), extended character set 
set by BS (08 hex). 

Factory Default Elng=BS FONT=SO 

 

Application > P-Series XQ Setup > Gothic Typeface 

Controls which host command sets Gothic printing. 

Char 02 STX  

Char 03 ETX  

Char 09 HT  

Factory Default Char 02 STX 
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Application > P-Series XQ Setup > EVFU Select 

Controls how the printer handles vertical formatting. 

Disable Disables all EVFU processing. 

Enable 
Selects P-Series compatible Electronic Vertical 
Format Unit (EVFU). 

Factory Default Enable 

 

Application > P-Series XQ Setup > Upr. Case Select 

Controls how the printer handles lowercase characters it receives from the 
host computer. When enabled, all characters are printed in uppercase. 

Disable 
Prints lowercase characters received from the host 
computer as lowercase; prints uppercase characters 
received from the computer as uppercase. 

Enable 

Prints lowercase characters received from the host 
computer as their corresponding uppercase 
equivalents; prints uppercase characters received 
from the computer as uppercase. 

Factory Default Disable 

 

Application > P-Series XQ Setup > Slew Relative 

“Slewing” is rapid vertical paper movement. This parameter determines the 
number of lines slewed (either 1-15 lines or 1-16 lines) when an EVFU 
Slew Relative command is received. 

1-15 lines  

1-16 lines  

Factory Default 1-15 lines 
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Application > Serial Matrix Setup 

 

IMPORTANT  The Serial Matrix Setup submenu will only be present when the LP+ Emulation 

menu is set to Serial Matrix. Otherwise, this menu will be replaced with the LP+ 
Emulation menu. 

 

Application > Serial Matrix Setup > Character Group 

This option selects the Character Set Group. Based on the group selected, 
then the character set can be chosen with the menu following XXX Sets. 
The group Standard Sets is shown below because it is unique to Serial 
Matrix. All other groups are similar and described in LP+, PGL, VGL 
Character Sets. 

 

Application > Serial Matrix Setup > Character Set  

This option will show when menu Character Group is set to Standard Sets. 
Note that depending on which value is chosen, other menu(s) can be 
unhidden. For example, when IBM PC is selected, a menu Primary Subset 
and Extended Subset is available as shown in this table. 

IBM PC 
When selected, Primary Subset and Extended Subset 
menus will be unhidden. 

Multinational 
When selected, the Multinational menu will be 
unhidden. 

ECMA Latin 1 
When selected, Primary Subset and Extended Subset 
menus will be unhidden. 

DEC Mult When selected, the DEC Mult. menu will be unhidden. 

CP 858 EURO No other menus will be unhidden. 

Factory Default IBM PC 

IMPORTANT 
Upon different choices, menus may be unhidden 
as described. 
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Application > Serial Matrix Setup > Primary Subset 

Application > Serial Matrix Setup > Multinational 

Application > Serial Matrix Setup > DEC Mult. 

One of these menus may be available when the Character Group is 
Standard Sets. The menu bolded in the right column below is unhidden 
and will have options with defaults marked (*). If the Character Set option is 
not shown in the left column, none of these menus is available. 

Character Set = 
IBM PC 

Primary Subset 

ASCII (USA) *, French, German, English, Danish, 
Swedish, Italian, Spanish, Japanese, French 
Canadian, Latin American, Norwegian, Danish II, 
Spanish II, Latin Am II 

Character Set = 
Multinational 

Multinational 

ASCII (USA) *, EBCDIC 

Character Set = 
ECMA Latin 1 

Primary Subset 

ASCII (USA) *, German, Swedish, Danish, 
Norwegian, Finnish, English, Dutch, French, Spanish, 
Italian, Turkish, Japanese 

Character Set = 
DEC Mult 

DEC Mult. 

ASCII (USA) *, French, German, English, 
Norw./Danish, Swedish, Italian, Spanish, Japanese, 
French Canadian, Dutch, Finnish, Swiss 

Factory Default As shown with asterisk (*). 

 

Application > Serial Matrix Setup > Extended Subset 

One of these menus will be available when the Character Group is 
Standard Sets. The menu at the right column is unhidden and will have 
options as shown with defaults marked (*).If the Character Set option is not 
shown in the left column, no menu is unhidden. 

Character Set = 
IBM PC 

Extended Subset 

Code Page 437 *, Code Page 850 

Character Set = 
ECMA Latin 1 

Extended Subset 

Multinational *, Barcode 10 cpi, Mult. DP 10 cpi, Mult. 
DP 12 cpi, Mult. LQ 10 cpi, Greek DP 10 cpi, Greek 
DP 12 cpi, Greek LQ 10 cpi, Grap. DP 10 cpi, Grap. 
LQ 10 cpi, Sci. DP 10 cpi, Sci. DP 12 cpi, Sci. LQ 10 
cpi 

Factory Default As shown with asterisk (*). 
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Application > Serial Matrix Setup > Horizontal DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a horizontal resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi horizontal resolution, depending on the 
print head installed. 

Minimum 60 

Maximum 400 

Factory Default 120 

 

Application > Serial Matrix Setup > Vertical DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a vertical resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi vertical resolution, depending on the 
print head installed. 

Minimum 72 

Maximum 400 

Factory Default 72 

 

Application > Serial Matrix Setup > Define CR code 

This option controls the action of the printer when it receives a Carriage 
Return code (0D hex) from the host computer. If this feature is enabled, 
each time the printer receives a carriage return, it inserts an additional Line 
Feed code (0A hex) into the data stream. Do not use this feature if the host 
computer sends line feeds to the printer. 

CR = CR 
Does not insert an extra line feed after each carriage 
return. 

CR = CR + LF 
Inserts an extra line feed after each carriage return. 
The next print position will be print position 1 of the 
next line. 

Factory Default CR = CR 
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Application > Serial Matrix Setup > Auto LF 

This option defines the printer action when print data is received past the 
forms width setting. 

Disable Discards any data past the forms width. 

Enable 
Performs an automatic carriage return and line feed 
when data is received past the forms width. 

Factory Default Enable 

 

Application > Serial Matrix Setup > Define LF Code 

This option controls the action of the printer when it receives a Line Feed 
code (0A hex) from the host computer. If this feature is enabled, each time 
the printer receives a line feed, it inserts an additional carriage return code 
(0D hex) into the data stream. Do not use this feature if the host computer 
sends carriage returns to the printer. 

LF = LF 
Does not insert a carriage return before each line 
feed. The next print position will be the current print 
position of the next line. 

LF = CR + LF 
Inserts an extra carriage return before each line feed. 
The next print position will be print position 1 of the 
next line. 

Factory Default LF = LF 

 

Application > Serial Matrix Setup > Control Code 06 

Control Code 06 defines the function of ASCII code 06 hex (ACK). You can 
select an alternate line spacing of 6.0, 8.0, or 10.3 LPI. 

Selections 6.0, 8.0, or 10.3 LPI 

Factory Default 8.0 LPI 

 

Application > Serial Matrix Setup > Overstrike 

Overstrike determines the action required when a line is printed over a 
previous line because a carriage return was received without a line feed. 

Disable 
Replaces the characters from the first line with the 
second line. 

Enable 
Prints the second line on top of the first line making it 
bolder. 

Factory Default Enable 
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Application > Serial Matrix Setup > Printer Select 

Determines if control codes DC1 and DC3 will ignored or used to disable or 
enable the printer, respectively. 

Disable Ignores the ASCII DC1 and DC3 control codes. 

Enable 
Disables the printer when control code DC1 is 
received and enables the printer when DC3 is 
received. 

Factory Default Disable 

 

Application > Serial Matrix Setup > Alt. Set 80-9F 

Determines how data in the range 80 hex – 9F hex will be treated. 

Control Code Interprets as a control code. 

Printable Prints data in this range. 

Factory Default Control Code. 

 

Application > Serial Matrix Setup > ESC d Command 

This item is for backward compatibility. 

Even dot plot 
This option interprets the ESC d command as even 
dot plot. 

Double high 
This option interprets the ESC d command as double 
high. Select this option for backward compatibility. 

Factory Default Even dot plot. 

Application > Proprinter Setup 

 

IMPORTANT  The Proprinter Setup submenu will only be present when the LP+ Emulation 

menu is set to Proprinter XL. Otherwise, this menu will be replaced with the 
LP+ Emulation menu. 

 

Application > Proprinter Setup > Character Group 

This option selects the Character Set Group. Based on the group selected, 
then the character set can be chosen with the menu following XXX Sets. 
The group Standard Sets is shown below because it is unique to 
Proprinter. All other groups are similar and described in LP+, PGL, VGL 
Character Sets 
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Application > Proprinter Setup > Character Set 

This option will show when menu Character Group is set to Standard Sets. 

Code Page 437 * Code Page 437 set 

Code Page 850 Code Page 850 set 

OCR-A OCR-A set 

OCR-B OCR-B set 

Multinational 
ASCII (USA) * 

EBCDIC 

CP 858 EURO CP 858 EURO 

Factory Default Those above with asterisk * 

 

Application > Proprinter Setup > Horizontal DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a horizontal resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi horizontal resolution, depending on the 
print head installed. 

Minimum 60 

Maximum 400 

Factory Default 120 

 

Application > Proprinter Setup > Vertical DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a vertical resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi vertical resolution, depending on the 
print head installed. 

Minimum 72 

Maximum 400 

Factory Default 72 
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Application > Proprinter Setup > Define CR code 

This option controls the action of the printer when it receives a Carriage 
Return code (0D hex) from the host computer. If this feature is enabled, 
each time the printer receives a carriage return, it inserts an additional Line 
Feed code (0A hex) into the data stream. Do not use this feature if the host 
computer sends line feeds to the printer. 

CR = CR 
Does not insert an extra line feed after each carriage 
return. 

CR = CR + LF 
Inserts an extra line feed after each carriage return. 
The next print position will be print position 1 of the 
next line. 

Factory Default CR = CR 

 

Application > Proprinter Setup > Auto LF 

This option defines the printer action when print data is received past the 
forms width setting. 

Disable Discards any data past the forms width. 

Enable 
Performs an automatic carriage return and line feed 
when data is received past the forms width. 

Factory Default Enable 

 

Application > Proprinter Setup > Define LF Code 

This option controls the action of the printer when it receives a Line Feed 
code (0A hex) from the host computer. If this feature is enabled, each time 
the printer receives a line feed, it inserts an additional carriage return code 
(0D hex) into the data stream. Do not use this feature if the host computer 
sends carriage returns to the printer. 

LF = LF 
Does not insert a carriage return before each line 
feed. The next print position will be the current print 
position of the next line. 

LF = CR + LF 
Inserts an extra carriage return before each line feed. 
The next print position will be print position 1 of the 
next line. 

Factory Default LF = LF 
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Application > Proprinter Setup > 20 CPI Condensed 

Compressed print characters are narrower than the normal character set. 
This is helpful for applications where you need to print the maximum 
amount of information on a page. 

Disable 
Does not compress print widths, even if condensed 
print is chosen by the host. 

Enable 
Prints about 60% of the width of normal characters 
when compressed print is chosen by the host 
computer. 

Factory Default Enable 

 

Application > Proprinter Setup > FF valid at TOF 

The FF valid at TOF option determines whether the printer will perform a 
Form Feed when the host sends a Form Feed command, if the printer is at 
the top of form. 

Disable 
Will not perform a form feed when the host sends a 
Form Feed and the printer is at the top of form. 

Enable 
Performs a form feed when the host sends a Form 
Feed and the printer is at the top of form. 

Factory Default Enable 

 

Application > Proprinter Setup > Alt. Char Set 

Determines how control codes hex 80-9F are handled. 

Set 1 
Interprets data in the range of hex 80 through hex 9F 
as a control code. 

Set 2 Prints data in the range of hex 80 through hex 9F. 

Factory Default Set 1 
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Application > Epson FX Setup 

 

IMPORTANT  The Epson FX Setup submenu will only be present when the LP+ Emulation 

menu is set to Epson FX. Otherwise, this menu will be replaced with the LP+ 
Emulation menu. 

 

Application > Epson FX Setup > Character Group 

This option selects the Character Set Group. Based on the group selected, 
then the character set can be chosen with the menu following XXX Sets. 
The group Standard Sets is shown below because it is unique to Epson 
FX. All other groups are similar and described in LP+, PGL, VGL Character 
Sets. 

 
 

Application > Epson FX Setup > Character Set  

This option will show when menu Character Group is set to Standard Sets. 
Note that depending on which value is chosen, other menu(s) can be 
unhidden. For example, when Epson Set is selected, a menu Epson Set is 
available. 

Epson Set When selected, the Epson Set menu will be unhidden. 

OCR-A OCR-A selected. 

OCR-B OCR-B selected. 

Multinational 
When selected, the Multinational menu will be 
unhidden. 

Code Page 850 Code Page 850. No other menus will be unhidden. 

CP 858 EURO CP 858 EURO. No other menus will be unhidden. 

IBM PC IBM PC set. No other menus will be unhidden. 

Factory Default Epson Set 

IMPORTANT 
Upon different choices, menus may be unhidden 
as described. 
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Application > Epson FX Setup > Epson Set 

Application > Epson FX Setup > Multinational 

One of these menus may be available when the Character Group is 
Standard Sets. The menu bolded in the right column below is unhidden 
and will have options with defaults marked (*). If the Character Set option is 
not shown in the left column, none of these menus is available. 

Character Set = 
Epson Set 

Epson Set 

ASCII (USA) *, French, German, English, Danish I, 
Swedish, Italian, Spanish I, Japanese, Norwegian, 
Danish II, Latin Am II, French Canadian, Latin Am I 

Character Set = 
Multinational 

Multinational 

ASCII (USA) *, EBCDIC 

Factory Default As shown with asterisk (*). 

 

Application > Epson FX Setup > Horizontal DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a horizontal resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi horizontal resolution, depending on the 
print head installed. 

Minimum 60 

Maximum 400 

Factory Default 120 

 

Application > Epson FX Setup > Vertical DPI 

This feature enables the thermal printer to print images as close as 
possible to the same size as those originally programmed for a line matrix 
or laser printer by selecting a vertical resolution that matches that of the 
printer that the file was originally generated for. 

Although the range allows a selection of up to 400 dpi, the T800 is capable 
of printing up to 203 dpi or 300 dpi vertical resolution, depending on the 
print head installed. 

Minimum 72 

Maximum 400 

Factory Default 72 
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Application > Epson FX Setup > Define CR code 

This option controls the action of the printer when it receives a Carriage 
Return code (0D hex) from the host computer. If this feature is enabled, 
each time the printer receives a carriage return, it inserts an additional Line 
Feed code (0A hex) into the data stream. Do not use this feature if the host 
computer sends line feeds to the printer. 

CR = CR 
Does not insert an extra line feed after each carriage 
return. 

CR = CR + LF 
Inserts an extra line feed after each carriage return. 
The next print position will be print position 1 of the 
next line. 

Factory Default CR = CR 

 

Application > Epson FX Setup > Auto LF 

This option defines the printer action when print data is received past the 
forms width setting. 

Disable Discards any data past the forms width. 

Enable 
Performs an automatic carriage return and line feed 
when data is received past the forms width. 

Factory Default Enable 

 

Application > Epson FX Setup > Define LF Code 

This option controls the action of the printer when it receives a Line Feed 
code (0A hex) from the host computer. If this feature is enabled, each time 
the printer receives a line feed, it inserts an additional carriage return code 
(0D hex) into the data stream. Do not use this feature if the host computer 
sends carriage returns to the printer. 

LF = LF 
Does not insert a carriage return before each line 
feed. The next print position will be the current print 
position of the next line. 

LF = CR + LF 
Inserts an extra carriage return before each line feed. 
The next print position will be print position 1 of the 
next line. 

Factory Default LF = LF 
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Application > Epson FX Setup > Printer Select 

Determines if control codes DC1 and DC3 will ignored or used to disable or 
enable the printer, respectively. 

Disable Ignores the ASCII DC1 and DC3 control codes. 

Enable 
Disables the printer when control code DC1 is 
received and enables the printer when DC3 is 
received. 

Factory Default Disable 

 

Application > Epson FX Setup > 20 CPI Condensed 

Compressed print characters are narrower than the normal character set. 
This is helpful for applications where you need to print the maximum 
amount of information on a page. 

Disable 
Does not compress print widths, even if condensed 
print is chosen by the host. 

Enable 
Prints about 60% of the width of normal characters 
when compressed print is chosen by the host 
computer. 

Factory Default Enable 

 

Application > Epson FX Setup > Alt. Set 80-9F 

Determines how data in the range 80 hex – 9F hex will be treated. 

Control Code Interprets as a control code. 

Printable Prints data in this range. 

Factory Default Control Code. 
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Application > Fonts 

 

Application > Fonts > Standard Chars. 

This menu entry permits you to adjust the thickness or font weight of 
standard text fonts. 

Minimum 0 

Maximum 512 

Factory Default 340 

 

Application > Fonts > Bold Chars. 

This menu entry permits you to adjust the thickness or font weight of bold 
text fonts. 

Minimum 0 

Maximum 512 

Factory Default 448 

 

Application > Fonts > Extra Bold Chars 

This menu entry permits you to adjust the thickness or font weight of extra 
bold text fonts. 

Minimum 0 

Maximum 512 

Factory Default 504 

 

Application > Fonts > OCR-A Chars. 

Character weight adjustment of resident OCR-A characters. 

Minimum 0 

Maximum 512 

Factory Default 384 
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Application > Fonts > OCR-B Chars. 

Character weight adjustment of resident OCR-B characters. 

Minimum 0 

Maximum 512 

Factory Default 304 

 

Application > Fonts > TT Reg Chars. 

This menu entry permits you to adjust the thickness or font weight of 
standard TrueType fonts. 

Minimum 0 

Maximum 512 

Factory Default 382 

 

Application > Fonts > TT Bold Chars. 

This menu entry permits you to adjust the thickness or font weight of bold 
TrueType fonts. 

Minimum 0 

Maximum 512 

Factory Default 448 

 

Application > Fonts > Tall Characters 

Increases the point height of resident Intellifont characters. 

Disable 
Standard resident font character point height is 
maintained. 

Enable 
Increases the point height of resident Intellifont 
characters approximately 10%. 

Factory Default Disable 
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Configs  
 

Configs > Control 
  

Configs > Control > Save Config 

This option allows you to save up to eight unique configurations to meet 
different print job requirements. This eliminates the need to change the 
parameter settings for each new job. The configurations are stored in 
memory and will not be lost if you turn off the printer. The factory default 
configuration cannot be changed.  

Minimum 1 

Maximum 8 

Factory Default 1 

 

Configs > Control > Load Config 

The printer can store up to eight configurations in memory. This parameter 
allows you to select and load a specific configuration.  

Factory The factory configuration is the default. 

1-8 Different saved configurations. 

Factory Default Factory 

 

Configs > Control > Print Config 

This option is used to print a listing of various stored printer configurations. 
We recommend you store printouts of your configurations in a safe place 
for quick referral.  

Current The current configuration loaded in DRAM. 

Factory The default factory configuration. 

Power-Up The configuration chosen as the power-up config. 

All All saved configurations, including factory. 

1-8 Specific saved configuration selected. 

Factory Default Current 
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Configs > Control > Delete Config 

You can delete one or all of your eight customized configurations. The 
Factory default configuration cannot be deleted.  

All All configurations will be deleted, except Factory. 

1-8 Specific saved configuration will be deleted. 

Factory Default All 

 

Configs > Control > Power-Up Config 

You can specify any one of nine configurations (1-8 saved custom 
configurations or Factory) as the power-up configuration.  

Factory The Factory configuration is the power-up default. 

1-8 Specific saved configuration will be the default config. 

Factory Default Factory 

 

Configs > Control > Auto Save 

You can Enable or Disable the Auto Save feature 

Disable The Auto Save feature is disabled 

Enable The Auto Save feature is enabled 

Factory Default Enable 

IMPORTANT 

The value for this menu is not part of the normal 
saved configuration. Loading another configuration 
will affect this value 

Configs > Custom 
 

Configs > Custom > Name Config 1 … Name Config 8 

Using the virtual keyboard of the UI, you may specify a 15-character name 
which can be used to refer to a configuration. The name you enter for a 
configuration will be used in the Load Config, Save Config, Print Config, 
Delete Config, and Power-Up Config menus. The names can only be 
cleared by using the Reset Cfg Names menu.  

String Any 15-character string using UI keyboard. 

Factory Default Config 1 …  Config 8 
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Configs > Custom > Reset Cfg Names 

You can reset specific configuration names back to the default value of the 
configuration number.  

All Reset all custom configuration names. 

1-8 Reset a specific custom configuration name. 

Factory Default 1 
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Tools  

Tools > Print Tests 
  

Tools > Print Tests > Run Tests 

The printer tests below allow you to check for proper printer operation and 
print quality. Once you have selected the desired test, press the ENTER 
key to start printing. If the Test Count option (below) is set to Continuous, 
press ENTER key again to stop printing. 

Auto Calibrate 
Senses paper out, perforation, gap, or mark, and 
calibrates the printer for the currently installed media. 

Checkerboard 
This pattern helps identify marginal printhead 
elements, quality of edge sharpness, and uneven 
print quality. 

Grey 
This pattern helps identify burned out printhead 
elements and uneven print quality. 

Grid 
This pattern helps identify edge sharpness and 
uneven print quality. 

Current Config 
Prints the current printer configuration and helps 
identify the text print quality. Includes printhead 
statistical data in the header. 

Left Test 

Prints a pattern containing a series of ladder-type bar 
code symbols, starting with four and decrementing by 
one symbol on each print until a single symbol prints 
on the left side. This pattern helps identify ribbon 
wrinkle problems. 

Right Test 

Prints a pattern containing a series of ladder-type bar 
code symbols, starting with four and decrementing by 
one symbol on each print until a single symbol prints 
on the right side. This pattern helps identify ribbon 
wrinkle problems. 

Combo Test Prints a combined left test and right test. 

Ethernet Test Prints the Network Interface statistics. 

Barcode Demo 
1D 

Prints text and picket barcodes with the barcodes 
positioned at the left and right margins of the standard 
label media supplied with the printer. 

NOTE: The printer is automatically put ONLINE 
before printing begins. 
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Tools > Print Tests > Run Tests 

Barcode Demo 
2D 

Prints picket, ladder, and 2-D barcodes with the 
barcodes positioned at the left and right margins of 
the standard label media supplied with the printer. 

NOTE: The printer is automatically put ONLINE 
before printing begins. 

Novram Err Log 

Prints detailed information about the most recent 
Novram related failure. This option is useful when the 
control panel faults with “Bad NVM” or “ILL NVM” type 
errors. Contact the Customer Support Center if 
such an error occurs. 

Print Quality 

Prints various patterns on one page that help in the 
assessment of print quality, including Grey, 
Checkerboard, and text.  Number of patterns 
depends on the current form length. This test should 
be run on at least 6-inch media for the full test print. 

Fine Grid 
This pattern helps identify edge sharpness and 
uneven print quality, but uses a much smaller grid 
than the earlier “Grid” selection above. 

Factory Default Auto Calibrate 

 

Tools > Print Tests > Test Count 

This item selects the number of times the selected test pattern will be 
printed. 

Continuous 
Print continuously until the user stops the test by 
printing the ENTER key. 

Selections 
Choose among 1 Page, 2 Pages, 5 Pages, or 10 
Pages. 

Factory Default Continuous 

Tools > Diagnostics 

 

Tools > Diagnostics > Print Error Log 

This executable menu prints the current log of errors. Most non-routine 
faults (RIBBON FAULT, PRINT HEAD HOT) are stored in the error log. 

 

Tools > Diagnostics > Clear Error Log 

This executable menu clears the error log. 
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Tools > Diagnostics > Hex Dump Mode 

This turns on the hex dump diagnostic. See Troubleshooting Common 
Situations for more information. 

Disable Hex dump mode is turned off. 

Enable 
Hex dump mode is turned on and all incoming data 
will be printed in hexadecimal format. 

Factory Default Disable 

 

Tools > Diagnostics > Job Capture 

Enable a job capture function. The procedure is to enable this menu, send 
the job of interest, then disable the menu. Once this procedure is 
completed, a file Job_XX.cap (e.g., Job_01.cap) will be saved to either the 
USB Drive, SD card, or Flash memory (in that order of priority). More than 
one capture can be made. When enabling this feature again, another 
Job_XX.cap file will be saved (e.g., Job_02.cap).. 

Disable Disable the Job Capture. 

Enable Enable the Job Capture. 

Factory Default Disable 

 

Tools > Diagnostics > Label Capture 

This feature can be used to save a label bitmap to a PNG file on the USB 
drive, SD card, or Flash File system (in that order of priority). The value set 
in the menu provides the number of labels to be saved. As each label is 
printed, the menu value will automatically decrement back to zero and will 
then be disabled. Files will be saved with names in the format of 
Page_XXX.PNG (e.g., Page_001.png, Page_002.png, …). 

Minimum 0 (Feature is disabled) 

Maximum 5 (Number of labels to be captured) 

Factory Default 0 

 

  



 

Page | 191 
 

Tools > Advanced 

This set of tools are advanced types of debugging that need to be coordinated with Printronix Customer 
Support. They capture information that only the Engineering can decipher. This section was designed to 
make it easier for Customer Support to acquire such information from the end user by storing diagnostic 
data/files into the printer flash, SD card, or USB drive. No longer is Customer Support necessarily 
required to install a special debug cable and be on site to capture valuable diagnostics. 

Each different diagnostic in this section will store files in the printer’s file system using different names. 
For example, in the case of auto dump files, a set of files “AUTODP*.LOG” (AUTODP1a.LOG, 
AUTODP1b.LOG, etc) will be stored in the printer’s flash file system. Diagnostics files stored in flash can 
be uploaded on an individual basis using the NIC webpage, PrintNet Enterprise Suite, or collectively and 
easily by using the menu Tools > Advanced > Copy to SD, or menu Tools > Advanced > Copy to 
USB. Once all such diagnostic files are acquired, it can be sent to Printronix Customer Support. 

Note that the printer can store multiple diagnostic results. For example, if the first System Dump menu 
was executed, files “SYS_DP1*.LOG” would be stored. If that same menu was executed at a later time, 
the files “SYS_DP2*.LOG” would then be stored. 

 

Tools > Advanced > Auto Dump 

When enabled, there is an automatic capture of debug information when a 
processor fault occurs. This information is stored in the flash file system as 
a set of files “AUTODP*.LOG” (AUTODP1a.LOG, AUTODP1b.LOG, etc). 
The files can be easily uploaded as described above. 

Disable Auto dump mode is turned off. 

Enable 

A dump file is automatically created and stored in 
FLASH memory as “AUTODP*.LOG” when the 
processor fault occurs. Reboot after the fault and 
retrieve this file using one of the methods mentioned 
above. 

Factory Default Enable 

IMPORTANT 

Once a file is stored in FLASH, it will not be 
replaced with a new file if another problem 
occurs. This is done to prevent FLASH memory 
from filling over time. 

 

Tools > Advanced > System Dump 

When executed, the system temporarily goes into a HALT mode (white 
screen flashes) and stores files “SYS_DP*.LOG” which hold similar 
information saved for the Auto dump case. 

IMPORTANT 

When the processed is finished, the printer 
should come out of HALT mode and operation 
should continue. However, there are situations in 
the printer cannot recover from the HALT 
process. If this happens, reboot the printer and 
then recover the SYS_DP*.LOG files. 
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Tools > Advanced > Debug Setup 

If a file “custflag.dbg” is created by Printronix Customer Support, it can be 
passed onto the end user to be downloaded into the printer. Such a file 
would be used to enable certain embedded diagnostic flags in the 
firmware. If this file is present, then the menu Debug Setup is unhidden.  

Note that if the “custflag.dbg” is not downloaded, the menu Debug Capture 
is still available with some default level of diagnostic capture. 

Typically, the user would execute the Debug Setup menu, then run the 
problem scenario, followed by executing the menu Debug Capture. This 
would capture the debug information in files named “DBG_DP*.LOG”. 

 

Tools > Advanced > Debug Capture 

If a file “custflag.dbg” is created by Printronix Customer Support, it can be 
passed onto the end user to be downloaded into the printer. Such a file 
would be used to enable certain embedded diagnostic flags in the 
firmware. If this file is present, then the menu Debug Setup is unhidden.  

Note that if the “custflag.dbg” is not downloaded, the menu Debug Capture 
is still available with some default level of diagnostic capture. 

Typically, the user would execute the Debug Setup menu, then run the 
problem scenario, followed by executing the menu Debug Capture. This 
would capture the debug information in files named “DBG_DP*.LOG”. 

 

Tools > Advanced > Copy to SD 

If the SD card is present in the printer, users can quickly and easily copy all 
diagnostic files from the flash system to the SD card in one simple step 
instead of having to individually find those files using NIC webpage or 
within the System > Flash File Edit > Copy to SD menu. 

 

Tools > Advanced > Copy to USB 

If the USB drive is present in the printer, users can quickly and easily copy 
all diagnostic files from the flash system to the USB drive in one simple 
step instead of having to individually find those files using NIC webpage or 
within the System > Flash File Edit > Copy to USB menu. 

 

Tools > Advanced > Delete & Optimize 

After the diagnostic files have been uploaded from the flash system or the 
user decides they are no longer needed, they can be easily deleted in one 
simple step by executing this menu. 

Furthermore, after deleting the files, the system will perform a System > 
Flash File Edit > Optimize & Reboot operation automatically so that the 
flash resources are freed. 
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Tools > PTF Debug 

This PTF (Printronix Trace Facility) diagnostics tool is used to trace real-time activities in the printer. Any 
use of this function must be coordinated with Printronix Customer Support. This tool was designed to 
make it easier for Customer Support to acquire such information by storing PTF trace files into the printer 
flash, SD card, or USB drive without requiring the end user install a special debug cable and be on site to 
capture valuable information. 

The PTF diagnostic files saved are named “PTF_DP*.LOG” (PTF_DP1a.LOG, PTF_DP1b.LOG, etc) and 
stored in the printer’s USB drive (if installed), SD card (if installed), or flash memory. If stored in flash 
memory, such files can be uploaded on an individual basis using the NIC webpage, PrintNet Enterprise 
Suite, or collectively and easily by using the menu Tools > Advanced > Copy to SD, or menu Tools > 
Advanced > Copy to USB. Once all such diagnostic files are acquired, they should be sent to Printronix 
Customer Support. 

Note that the printer can store multiple diagnostic results. For example, if the first PTF Debug > Save 
Trace menu was executed, files “PTF_DP1*.LOG” would be stored. If that same menu was executed a 
second time, the files “PTF_DP2*.LOG” would then be stored, and so forth. 

 

Tools > PTF Debug > Buffer Size 

This menu reserves an internal trace buffer (DRAM) needed to capture the 
PTF data. Depending on the type of failure and the length of time needed 
to create it, the buffer might need to increase or decrease. 

Minimum 0 KB (no PTF trace buffer available) 

Maximum 1 MB (largest PTF trace buffer possible) 

Factory Default 4 KB 

IMPORTANT 

The size of the actual PTF_DP*.LOG files saved 
will vary based on how much of the trace buffer is 
actually used. 

 

Tools > PTF Debug > Clear Trace 

Clears the PTF internal trace buffer so that new information can be 
gathered at the beginning. This is useful to reset trace data prior to creating 
a failure event.  

 

Tools > Advanced > Save Trace 

This dumps the PTF trace buffer to files named with the format 
“PTF_DP*.LOG” as described earlier in this section. 

 

Tools > PTF Flags 

This section is used to select certain areas of the PSA system to debug with PTF tracing. These menus 
would only be modified with the direction of Customer Support. The different menus will be listed but do 
not need a detailed explanation. 

All menus below are Enable/Disable. 
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Tools > PTF Flags > Global Enable 

This menu enables the use of the PTF trace facility. 

Factory Default Enable 

 

Tools > PTF Flags > Configuration 

This menu enables information related to menu and printer configuration. 

Factory Default Enable 

 

Tools > PTF Flags > Structures 

This menu is reserved to provide information related to major internal data 
structures. 

Factory Default Disable 

 

Tools > PTF Flags > Messages 

This menu enables information about inter-task messaging. 

Factory Default Enable 

 

Tools > PTF Flags > Host IO 

This menu is reserved for tracing host IO drivers. 

Factory Default Disable 

 

Tools > PTF Flags > Command 

This menu is reserved for tracing emulation command parsing. 

Factory Default Disable 

 

Tools > PTF Flags > Text 

This menu is reserved for tracing emulation text and font selection. 

Factory Default Disable 

 

Tools > Statistics 

All of the menus shown here are read-only. 
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Tools > Statistics > Printer On Time 

Displays the cumulative time in hours the printer has been powered on. 
This value is set to zero at the factory. 

 

Tools > Statistics > Total Media Dist 

Displays the cumulative number of inches the printer has moved media. 
This value is set to zero at the factory. 

 

Tools > Statistics > Total Label Count 

Displays the cumulative number of labels printed, regardless of size. This 
value is set to zero at the factory. 

 

Tools > Statistics > Head On Time 

Displays the time that power has been applied to the printhead since its 
installation. This value is kept with each printhead and updated 
automatically when a different printhead is installed. 

 

Tools > Statistics > Head Print Dist 

Displays the length of media actually printed since the last Reset Head 
Data operation. This value is set to zero at the factory. 

 

Tools > Statistics > Head Life (Standard) 

Displays the percent of life left in the print head.   
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Tools > About 

All of the menus shown here are read-only. 

 

Tools > About > Controller Board Version 

Displays the Controller board version. 

 

Tools > About > Head DPI 

Displays the printhead type installed in dots per inch (203 dpi or 300 dpi). 

 

Tools > About > FLASH Installed 

Displays the total FLASH memory installed (128 MB). 

 

Tools > About > DRAM Installed 

Displays the total DRAM memory installed (128 MB). 

 

Tools > About > CPU Clock 

Displays the current speed of the main processor. 

 

Tools > About > Printer F/W 

Displays the printer firmware version and part number. 

 

Tools > About > RFID Reader F/W 

Displays the RFID reader firmware version (if installed). 

 

Tools > About > RFID Reader Hd/W 

Displays the RFID reader hardware version. (if ThingMagic RFID reader is 
installed) 

 

Tools > About > Wifi F/W 

Displays the Wifi firmware version (if installed).  
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Tools > About > Feature File 

Displays the feature file part number (if present). 
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RFID   
When equipped with the RFID option, the RFID ICON will always appear, but will be in grey when the 
RFID is disabled. When enabled, the icon will appear in color. This section will show how the RFID menu 
is organized. Please see the RFID Labeling Reference Manual available on our website for a detailed 
description of how these menus work and interact. 

RFID > Control 

• RFID Active 

• Error Handling 

• Label Retry 

• Max Retry Error 

• Overstrike Style 

• EPC Write Control 

• AutoID Mgr Rpt 

• Non-RFID Warning 

RFID > Tag Calibration 

• RFID Calibrate 

• Start Position 

• End Position 

• Test EPC Length 

RFID > Calibration Param 

• Operation Order 

• Speed While Encode 

• Tag Position 

• Move to Encode 

• Tag Pos Adjust 

• Write Power 

• Read Power 

RFID > RFID Chip Param 

• USR Size 

• TID Size 

• Tag Length 

• Block Size 

RFID > Diagnostics 

• Read Tag 

• Read Tag & Eject 

• Read USR 
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• Read TID 

• Tag ID 

• Silicon Name 

• Read PC 

• Tag PC 

• Write EPC with 1s 

• Write EPC with 2s 

RFID > Statistics 

• Read Tags Passed 

• Write Tags Fail 

• Read Tags Fail 

• Lock Tags Fail 

• Clear Tag Stats 

• RFID Reader F/W 

• RFID Reader Hd/W 
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4 Downloading Firmware 

There is 128 MB of FLASH memory on the controller board. The printer firmware which includes printer 
control languages (the “emulations”), the engine control, and printer operating system software are loaded 
into FLASH memory at the factory, but there are occasions when you may have to load this software: 

• Firmware upgrade to a newer level 

• Replacing a controller or reloading firmware if FLASH becomes corrupt. 

Once you have the target firmware copied onto your local PC or SD card, you can employ one of the 
various download methods presented in this section. Some methods even allow use of the USB drive. 
Downloading firmware can be accomplished through any host IO installed on the printer, but may not be 
valid for all methods. 

IMPORTANT  The target firmware must be consistent with the options present in the 

controller Security Key. Otherwise, the firmware download will be prevented. 

With exception to the manual two-key and manual three-key power-up sequences, downloading new 
firmware does not require the user to put the printer into any special mode. Now downloading methods 
are employed when the printer is ONLINE and ready to receive data. This makes the download procedure 
easy. 

FLASH is used to store the firmware, but it also contains a file system that holds System and User Flash 
Files. User Flash Files consist of downloaded fonts, logos, forms, setup files, feature files, CST files, and 
files that are specific to the user’s setup or application. These files are either preserved or deleted based 
on the download method used as shown in Table 7. 

IMPORTANT Regardless of download method, any saved configurations will be erased. 

Before starting a download procedure, be sure that you have printed or saved 

configurations on your host computer or using PrintNet Enterprise Suite so 

they can be restored after the download process is complete. 

NOTE:  When the firmware download has completed, the FLASH memory will automatically be 

optimized to maximize the amount of available FLASH memory.  
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Table 7. Firmware Download Methods 

 

Firmware Download Method 
 

File Type(s) 
User FLASH 

Files 

Web Page (Ethernet or WiFi). User needs the network 

configured, a browser, and know the IP address. FILENAME.prg Preserved 

Automatic download (any host IO). Using the 

FILENAME.exe, firmware can be downloaded from a 

Windows Command Prompt without having to manually put 

the printer into download mode. 

FILENAME.exe Preserved 

Manual two-key download (any host IO). This two-key 

(LEFT SOFT KEY + RIGHT SOFT KEY) power-up 

sequence puts the printer into download mode. Firmware 

can be loaded through any host IO port.  FILENAME.exe 

can be downloaded through the USB port using the -pb 

option. Do not use the Manual two-key download for 

FILENAME.exe using the Ethernet or Wifi using the -n 

option. 

FILENAME.prg 

FILENAME.exe 
Preserved 

Manual two-key download (USB Drive or SD Card). This 

two-key (LEFT SOFT KEY + RIGHT SOFT KEY) power-up 

sequence puts the printer into download mode. Firmware 

program file (.prg) must be copied to the USB drive or SD 

card and renamed “UPGRADE”. 

FILENAME.prg 

renamed to 

“UPGRADE” 

Preserved 

Manual three-key download (SD Card). This three-key 

power-up sequence (LEFT SOFT KEY + RIGHT SOFT 

KEY + DOWN ARROW) should be used in situations in 

which a new controller is installed, the program in FLASH is 

corrupt, or a different firmware type will be installed. 

Firmware program file (.prg) must be copied to the SD card 
and renamed “UPGRADE”. 

FILENAME.prg 

renamed to 

“UPGRADE” 

Deleted 

PrintNet Enterprise (Ethernet only). Users may install the 

PrintNet Enterprise application from the company’s 

website This is the most versatile and powerful method to 

upgrade printers but requires your computer to run Java™ 

programs. 

For a detailed description, refer 

to the PrintNet Ethernet User's 

Manual. 

 

Firmware File Types (.prg) and (.exe) 
Using firmware with an .exe extension FILENAME.exe is convenient. However, firmware with the .exe 
extension may not be available in all situations. The FILENAME.prg file can be extracted from the 
FILENAME.exe file by running the .exe file like an application. This will extract the FILENAME.prg file in 
the same directory where FILENAME.exe was executed.  

For example, executing 123456.exe in directory C:\download will generate a file C:\download\123456.prg. 

Running the FILENAME.exe on a command line with the -h option will display help information. 
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Web Page Download 
NOTE:  This download method requires firmware with the .prg extension FILENAME.prg. 

1. Make sure the printer is powered up, in ONLINE mode, and that the Ethernet cable is connected or 
Wifi is active. 

2. Get the IP address from the front panel ONLINE screen (or under Network  in Settings ). 

3. Enter the printer’s IP address in your browser (e.g., http://10.224.5.21). 

4. When prompted for a user name and password, enter “root” for user name and click OK. 

5. Click “System” in the Configuration box. 
 
 

 
 

Figure 2 System Configuration Upgrade 

6. Click the “Upgrade” button. 
 

7. Browse to the directory or enter FILENAME.prg in the “File to upload” field and click 

“Upgrade”. A Warning message opens. 

 

 
Figure 3 Uploading Firmware File for Upgrade 

8. Click “Ok” to continue. After a few minutes, you are prompted to reboot. 

9. Click “Yes”. 
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Figure 4 Confirm Reboot 

10. Wait until the printer is finished upgrading firmware. 
 
 

 
Figure 5 Waiting for Firmware Upgrade Completion 

11. When the Web Page is redirected, the download process in complete. 
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Automatic Download (.exe) 
The firmware can be downloaded without requiring the user to manually put the printer into download 
mode. 
 

 

NOTE:  This download method requires firmware in the form FILENAME.exe, which should be a six 

digit number with the .exe extension (e.g., 123456.exe). 

1. Make sure the printer is powered up, in ONLINE mode, and that the applicable host IO cables are 
connected. 

2. Navigate to the directory where the target firmware resides.  

IMPORTANT For USB connections, the Windows Driver must be installed. 

3. Install the Windows Driver provided on our company’s website. During the installation, make sure to 
share the printer when prompted and record the “Share name”. 

 

 

 

Figure 6 Selecting to Share the Printer 

IMPORTANT For USB connections, the printer must have a “Share name” established. 

4. The “Share name” will be needed when executing the FILENAME.exe command. This should be 
accomplished during installation, but can be verified at any time. Select the driver, right-click the 
mouse button and select “Printer Properties”. Click the “Sharing” tab, make sure the “Share this 
printer” box is check marked, and enter the “Share name”. 
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Figure 7 Setting Printer Properties Sharing Options 

 

5. Start a Windows Command Prompt session. 

6. Navigate to the directory with the target firmware (e.g., c:\download). 

7. Execute FILENAME.exe  as follows: 
 
 

Connection Type Enter Command 

USB FILENAME –a –pbSharedName <Enter> 

where SharedName of the printer is the ‘Share 

name’ entered during installation. 

Ethernet FILENAME -n xxx.xxx.xxx.xxx <Enter> 

where xxx.xxx.xxx.xxx represents the IP address. 

 

WARNING DO NOT interrupt the downloading process once it has started. Interrupting a 

download will leave the flash memory incompletely loaded, and the printer may 

not boot up. 

8. When the new software has successfully loaded into flash memory and the printer has reset 

itself, the process is complete. 
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Manual Two-Key Download Sequence 
NOTE:  This download method can be completed with firmware in the form of FILENAME.prg  or 

FILENAME.exe (USB Only). 

The following steps prepare the printer for download. When the printer is in the download mode, any host 
IO can be used to download the firmware. Serial IO is not recommended due to the size of the firmware 
and the time it takes to complete. Therefore, it is not discussed in this document. 

1. Set the printer power switch to O (Off). 

2. Connect the Ethernet cable or USB cable to the printer interface. 

3. Press and hold down the LEFT SOFT KEY + RIGHT SOFT KEY on the printer’s control panel. 

4. Set the printer power switch to I (On). 

5. After five seconds, release the front panel keys. 

6. Wait for the printer to power-up and displays “PROGRAM DOWNLOAD” on the front panel. 

7. Start a Windows Command Prompt session. 

8. Navigate to the directory with the target firmware (e.g., c:\download). 

9. Send the firmware to the printer as described for various host IO options: 

• Sending Firmware via Ethernet or Wifi (LPR)  

• Sending Firmware via USB  

Manual Three-Key Download Sequence 
If the flash memory contains only boot code (e.g., if it is new), or if flash memory is corrupt, or you want to 
delete all Flash User Files, you must download software using the manual three-key download method. 
The SD card is the only method to do this: 

1. Rename the FILENAME.prg to “UPGRADE” in the SD card root directory. 

2. Set the printer power switch to O (Off). 

3. Insert the SD card into the printer. 

4. Press and hold down the LEFT SOFT KEY, RIGHT SOFT KEY, and DOWN ARROW panel keys. 

5. Set the printer power switch to I (On). 

6. After five seconds, release the control panel keys. 

7. The downloading process will begin automatically and shown on the front panel. Wait until it completes 
and the printer is fully rebooted with the new firmware.  

8. Set the printer power switch to O (Off). 

9. Remove the SD card – this completes the process. 
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Sending Firmware in Download Mode 
This section describes how to send the firmware data to the printer using the desired host IO. Serial IO is 
not recommended due to the size of the firmware and the time it takes to complete. Therefore, it is not 
discussed in this document.  

NOTE:  The three-key download sequence only allows download through the SD card. 

Although the program file FILENAME.prg is used in the examples, any file with a Printronix header can be 
substituted in this process to download flash files. 

Sending Firmware via Ethernet or Wifi (LPR) 
 

 

NOTE:  You will need the IP Address of the printer.  This method can not be used for 

FILENAME.exe.  For FILENAME.exe over Ethernet or Wifi see Automatic Download section. 

 

1. Enter the following to start the LPR program: 

lpr -S xxx.xxx.xxx.xxx -P d1prn FILENAME.prg 

 

where xxx.xxx.xxx.xxx is the IP Address of the printer. 

WARNING DO NOT interrupt the downloading process once it has started. Interrupting a 

download will leave the FLASH memory incompletely loaded, and the printer 

may not boot up. 

2. The process is complete when the new software has successfully loaded into flash memory and the 
printer has reset itself. 

Sending Firmware via USB 
 

This section explains how to download firmware through the USB port. This can be completed with 
firmware in the form FILENAME.prg. 

IMPORTANT For USB connections, the Windows Driver must be installed. 

1. Install the Windows Driver from our company’s website. During the installation, make sure to share the 
printer when prompted and record the “Share name”. 

 

 

 

Figure 8 Selecting to Share the Printer 
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IMPORTANT For USB connections, the printer must have a “Share name” established. 

2. The “Share name” will be needed when sending the data through the USB port. This should be 
accomplished during installation, but can be verified at any time. Select the driver, right-click the 
mouse button and select “Printer Properties”. Click the “Sharing” tab, make sure the “Share this 
printer” box is check marked, and enter the “Share name”. 

 

 

Figure 9 Setting Printer Properties Sharing Options 

 

3. Start a Windows Command Prompt session. 

4. Navigate to the directory with the target firmware (e.g., c:\download). 

5. Send the file except the .exe file using the following command:  

“COPY /b <File Name> \\COMP_NAME\Printers_Shared_Name” where COMP NAME is the name of 
the laptop or PC and can be found in the Computer Properties screen and Printers_Shared_Name is 
the shared name created above.   

For FILENAME.exe use the following command:  

“FILENAME –pb\\COMP_NAME\Printers_Shared_Name” where COMP NAME is the name of the 
laptop or PC and can be found in the Computer Properties screen and Printers_Shared_Name is the 
shared name created above.  . 

6. The process is complete when the new software has successfully loaded into flash memory and the 
printer has reset itself. 

IMPORTANT DO NOT interrupt the downloading process once it has started. Interrupting a 

download will leave the flash memory on the controller PCBA and NIC 

incompletely loaded, and the printer may not boot up. 

  

file://///COMP_NAME/Printers_Shared_Name
file://///COMP_NAME/Printers_Shared_Name
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Downloading Files to the Main File System 
User Files can be downloaded into the Main File System (onboard PCB Flash) in various ways as 
discussed in this section. This section does not cover specific methods used by the emulations but rather 
general ways of downloading files as shown in Table 8. Font download is discussed in a later section. 
 
 

Table 8. File Download Methods 

File Download Method File Preparation 

Web Page (Ethernet or Wifi only). User needs to know the IP address 

and have a browser. 

None required. 

PTX_SETUP (any host IO). User can employ PTX_SETUP commands 

around the file data to store the file into the Main File System. 

Binary (raw) data of the 

file is embedded within 

PTX_SETUP commands. 

Manual two-key download (any host IO). This two-key (LEFT SOFT KEY + 
RIGHT SOFT KEY) power-up sequence puts the printer into download mode. 
Files can then be downloaded. 

Use the PSA File Utility 

to create files that can 

be loaded in download 

mode. 

PrintNet Enterprise (Ethernet only). User may install the PrintNet 

Enterprise application available from our company’s website. This is the 

most versatile and powerful method to download files but requires your 

computer to run Java™ programs. 

For a detailed description, 

refer to the PrintNet 

Ethernet User's Manual. 

 

NOTE:  Depending on the file download method, the file itself may need to be modified so that when it 

is downloaded to the printer, the printer stores the file with the correct Main File System name 

and file type. 

Filename Extensions Not Shown in Menus 
 

 

Files with the one of the filename extensions below (upper or lower case) are considered system files and 
are not shown in System > Flash File View or within the System > Flash File Edit > Delete Files menu. 

NOTE:  DO NOT download any user files with the extensions shown in Table 9. 

 
 

Table 9. Filename Extensions Not Shown In Menus 

Extensions 

*.bin *.inf *.ras 

*.cpg *.lfi *.rfv 

*.eng *.map *.sec 

*.fon *.pat  

*.gz *.qsm  
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File Properties Not Shown in Menus 
 

Files with one of the properties listed below (case sensitive) are considered system files and are not 
shown in System > Flash File View or within the System > Flash File Edit > Delete Files menu. 

NOTE:  DO NOT download any user files with the one of the properties shown in Table 10. 
 
 

Table 10. File Properties Not Shown In Menus 

Properties 

Prot NetC NGif 

Rmap Rfnt Rmnu 

Rprg Eprg VERS 

ASIC FPGA UMCA 

Rval XHEX RULE 

CRft Rver Rsec 

SORT   

 

Web Page Download 
 

1. Make sure the printer is powered up, in ONLINE mode, and the Ethernet cable is connected or Wifi is 
active. 

2. Obtain the IP address from the front panel ONLINE screen (or under Network  in Settings ). 

3. Enter the IP address of the printer in your browser (e.g., http://10.224.5.21). 

4. Enter “root” for the user name when prompted, and click OK. 

5. Click “Printer” in the Configuration box. The following webpage will display. Click “File Management” 
to download the file. 
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Figure 10 Downloading Files using the File Management Webpage 

6. Click “Browse” to navigate the directory and find the download file, then click “Download File”. 
 

 

Figure 11 Navigating to Download a File 

 

A notification displays indicating that the web page will refresh upon download completion. 
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Figure 12 File Download Notification 

PTX_SETUP Download 
 

 

Use PTX_SETUP to load files into the Main File System. Refer to the Appendix section entitled “Command 
Format” 

Example loading a font named ARIAL.TTF: 

!PTX_SETUP 

FILE_IO-CAPTURE;“ARIAL.TTF”  

PTX_END 

Arial TrueType font binary data. 

NOTE: DO NOT add LF/FF to the end of the binary data. 

!PTX_SETUP 

FILE_IO-CAPTURE;””  

PTX_END 

Manual Two-Key Download 
 

1. Download the PSA File Utility from our company’s website.  

2. Use the utility to open the file to be downloaded and follow the instructions as provided in the Help 
Section to create the target download file with the appropriate header that will be sent to the printer. 

 

 

For example, opening the file “Arial.ttf” and creating a Download Header with type Font (as shown 
above) might create a file “Arial.dwn” that will be sent to the printer in download mode. 

3. Place the printer in download mode as described in   
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4. Manual Two-Key Download Sequence. 

5. Send the file as described in Sending Firmware in Download Mode. Substitute Arial.dwn in place of the 
firmware FILENAME.prg. 

6. The process is complete when the file successfully loads into flash and the printer resets. 

7. To verify that the file is recognized and downloaded, go to the System > Flash File View submenu. 
One of the files displayed should (in our example) include Arial.ttf. 

Downloading Files to the SD Card 
 

SD files can be utilized by the printer and certain emulations such as PGL. Since the SD file format is an 
industry standard, downloading files and fonts to the SD card does not require special facilities within the 
printer. This allows the user to copy files from their PC or laptop to the SD card as well as copy printer 
files on the SD card to their PC or laptop. 

IMPORTANT  The printer will only locate files stored on the root directory of the SD card. The 

name of the file within the SD card root directory is the name shown in the SD 

File System submenu. 

Alternatively, users can copy files from the Main File System to the SD card by using the System > Flash 
File Edit > Copy to SD menu. Users can also copy files from the SD card to the Main File System by using 
the System > SD File Edit > Copy from SD menu. 

PGL forms, fonts, and logos can all be read from and stored onto SD cards as described in the PGL 
Programmer’s Reference Manual. 

IMPORTANT The SD card must be installed at the time of power-up and cannot be removed 

until the printer is powered off. 

Using TrueType Fonts 
 

 

TrueType fonts allow you to customize the look of your forms and labels. You can download TrueType 
fonts purchased from various sources into your printer. The fonts are available for purchase on websites 
such as www.fonts.com and www.myfonts.com. 

The following sections discuss how to: 

• Download TrueType fonts 

• Select and print downloaded TrueType fonts 

Uuse TrueType fonts to print DBCS using UTF-8  

Downloading TrueType Fonts 
 

 

You can download TrueType fonts to your printer by using any of the following methods: 

• PTX_SETUP Download  

• Web Page Download 

• PGL Emulation other Emulations 

• Manual Two-Key Download 

• Labeling Applications  

Once a TrueType font is downloaded, it is stored in the Main File System or SD File System as a resident 
font. Regardless of printer power cycles, the downloaded font will stay in the printer until the user deletes 
it. The user can find a list of all printer resident fonts within the submenus System > Flash File View or 
System > SD File View. User downloaded fonts can be deleted from these same submenus. If within the 

http://www.fonts.com/
http://www.myfonts.com/
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Main File System, the user is recommended to perform a System > Flash File Edit > Optimize & Reboot 
function. 

PGL Emulation 

A TrueType font can be loaded by creating a file that appends a PGL command to the font and then 
sending that file to the printer. Use the PGL FONTLOAD command: 

~FONTLOAD;FontName;FontSize;Location 

where 

FontName TrueType font name, e.g. arial.ttf 

FontSize TrueType font size, e.g. file size for arial.ttf 

Location  The download location. By default, “DISK” represents the Main File System (Flash), while 
“EMC” designates the SD card. The PGL menu “Storage Select” can be changed to force 
“DISK” to store fonts and other PGL elements to the SD card. 

Example: 

~FONTLOAD;arial.ttf;60548;DISK  

(Insert binary data of arial.ttf here.) 

END 

After the file is created, it can be copied to the appropriate printer I/O port 

while the printer is ONLINE, similar to other print files. 

Example: 

copy/b filename.ext lpt1 or LPT1 

Manual Two-Key Download 

This is described in Section “Manual Two-Key Download” on page 212. 

Labeling Applications 

A TrueType font can be downloaded through several labeling applications, such as Codesoft, Loftware, 
and Bartender. Contact the appropriate company for more details. 

Select and Print Downloaded TrueType Fonts 
 

 

After downloading the TrueType font using any of the following methods, you can access the downloaded 
TrueType font by using the command as described in the PGL Programmer’s Reference Manual. 

To Print ASCII Characters 

You can print characters from your font using the currently selected character set. You can also select a 
new character set using the ISET command. 

Example: 

~CREATE;FORM 

FONT;NAME ARIAL.TTF 

ALPHA 

10;10;3;3;$01234$ 

STOP 

END 

~EXECUTE;FORM;1 
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To Print All Characters 

You can print all of the characters in your font using UTF-8. You must have a UTF-8 datastream to print. 

Example: 

~CREATE;FORM 

ISET;’UTF8’ 

FONT;NAME ARIAL.TTF 

ALPHA 

10;10;3;3;$UTF-8 

data$ STOP 

END 

~EXECUTE;FORM;1 

Demo Facility 
To exercise the function of a Printronix printer in an environment where there is no host computer system 
available, you may need to execute a demo test file from the menu system. When executed, the demo test 
file will run through the emulations as if the host computer sent the file. Once completed, it will run the file 
again until terminated. 

This section describes how to download, configure, execute, and terminate the demo. Demo files are 
treated as other User Flash Files and therefore are preserved across downloads by default. 

Downloading a Demo File 

1. Download the PSA File Utility from our company’s website.  

2. Use the utility to open the demo file to be downloaded and follow the instructions as provided in 
the Help Section to create the target demo file with the appropriate header that will be sent to the 
printer. 

 

 

For example, opening the file “ean8.pgl” and creating a Download Header with type Demo (as shown 
above) might create a file “ean8.dmo” that will be sent to the printer in download mode. 

3. Place the printer in download mode as described in   



 

Page | 216 
 

4. Manual Two-Key Download Sequence. 

5. Send the file as described in Sending Firmware in Download Mode. Substitute ean8.dmo in place 
of the firmware FILENAME.prg. 

6. The process is complete when the file successfully loads into flash and the printer resets. 

7. Verify that the file is recognized and downloaded under the Tools > Print Tests > Run Tests 
menu. One of the printer tests shown should include ean8.pgl. 

Configuring the Printer to Run a Demo File 

This facility does not attempt to identify which emulation a particular demo file is designed for. The user 
must configure the printer for the appropriate emulation before invoking the demo. The demo will inherit all 
menu configuration parameters when executed. The user is responsible to properly configure the forms 
size, typeface, orientation, etc. This facility will not restore any configuration settings when the demo file is 
finished printing. 

Starting a Demo File 

The demo file is initiated by selecting its Flash File name and pressing ENTER within the Tools > Print 
Tests > Run Tests menu. This causes the printer to go ONLINE and print the demo file. Once the demo 
file starts, it will repeat automatically until the demo file sequence is stopped. 

WARNING DO NOT run a demo file if the printer is in the middle of another test or host job. 

This will cause unexpected results. Similarly, do not send host jobs when 

running demo tests. 

Pausing a Demo File 

Pause the demo by placing the printer OFFLINE (press the PAUSE key). To resume printing, go back 
ONLINE. 

Stopping a Demo File 

Stop the demo by executing a soft reset on the printer (press the LEFT and RIGHT arrow keys 
simultaneously). This will resume normal operation. 

Deleting a Demo File 

Delete demo files similar to any other file in the Main File System. Once deleted, the file will no longer 
appear as a selection in the Tools > Print Tests > Run Tests menu. 
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WLAN Radio Firmware Upgrade 
There is a radio chip on the WLAN Option Board that contains firmware. This firmware is loaded into 
radio chip at the factory, but there are occasions when you may have to upgrade this firmware to a newer 
level. 

Firmware Download Methods 

The radio firmware can only be downloaded by having the radio firmware copied onto a SD card or USB 
Drive renamed to UPGRADE using the Manual Two-Key Download Sequence. 

IMPORTANT  To upgrade the Radio firmware, the WLAN interface must be active. This means 

the Ethernet cable must not be attached. 

 

Table 11. Firmware Download Methods 

 

 

 

The method shown above is the same procedure as downloading firmware shown earlier in this chapter. 
Simply substitute FILENAME.fls for FILENAME.prg. 

  

 

Firmware Download Method 
 

File Type(s) 

Manual two-key download (USB or SD Card). This two-

key (LEFT SOFT KEY + RIGHT SOFT KEY) power-up 

sequence puts the printer into download mode.  Radio 

firmware file must be copied to the USB drive or SD card 

and renamed “UPGRADE”. 

FILENAME.fls 

renamed to 

“UPGRADE” 
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5 Diagnostics and 
Troubleshooting 

Printer Tests 
A sequence of automatic tests is performed during printer power-up. If any faults are detected at that time, 
a fault message will display. 

Before placing the printer in its operating environment, run test patterns to ensure proper operation and 
print quality. The printer has a number of tests which allow you to check for proper printer operation and 
print quality. 

You can invoke the various test patterns from the Tools > Print Tests menu. For more information, see

Tools section. 

 

Troubleshooting Common Situations 
Occasionally, situations occur that require some troubleshooting skill. Possible problem situations and 
potential solutions are listed in this section. While not every conceivable situation is addressed here, you 
may find some of these tips helpful. Contact a qualified service technician for problems that persist or are 
not covered in this section. 

Interfacing 

The printer will not function properly with an incorrectly wired cable or the wrong interface cable installed. 
If the cable is suspect, contact Printronix or your authorized service representative. 

When the printer is first powered up, it will reset itself to the communication default parameters. The 
parameters are listed in the following table: 

 

PARAMETER DEFAULT 

Baud 9600 

Data Bits 8 

Parity NONE 

Stop Bits 1 

 
The printer interface configuration settings may be entered from the control panel. 

Hex Dump Mode 

Hex dump mode allows you to place the printer into a diagnostic mode in which the printer outputs a 
hexadecimal data stream on the label for examination. The purpose of hex dump mode is to see exactly 
what data is received by the printer, in order to debug forms. 
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When enabled, the hex dump mode translates all host interface data to its hexadecimal equivalent, then 
prints the hex code and its printable symbol, if one exists. Figure 13 shows a partial example of a hex 
dump. 

After the printer enters hex dump mode, all characters it prints (including any in the printer’s input buffer) 
are printed in two forms: as a two-symbol hexadecimal code and as the character’s printable symbol (if it 
has one). A non-printable code is printed as a period [.] symbol. Up to 16 characters can be printed per 
line of hex dump printout. While the printer is in hex dump mode, it does not act upon any control codes, 
other than to print their hexadecimal equivalents. 

The 16 characters printed per line on the hex dump are formatted so that the 16 printable symbols are 
printed in columns 1 through 16. The 17th column is blank. Column 18 contains either a p (PI line active) or 
a blank (PI not active). Columns 19 and 20 contain the hexadecimal code for the first character, followed 
by a blank. The PI line condition and hexadecimal code for the second character are printed in columns 
22, 23, and 24, followed by a blank. The third through 16th characters are printed in a similar manner. The 
hexadecimal code for the 16th character is printed in columns 78, 79, and 80. 

NOTE:  Values will vary based on printhead width. 

Subsequent printing observes the current setting for skip-over perforation, form length, and top-of-form 
position parameters. 

IMPORTANT You must have a minimum of 4.1 inches of media installed and have Media 

> Image > Label Width set to 4.1 inches. If not, the hex dump data will be 
truncated and lost. 

If a fault occurs while printing a hex dump, the printer reverts to the normal fault state. When the fault is 
cleared, the printer resumes printing the hex dump (either a partial line with a form feed or nothing at all). 
Top-of-Form remains unaffected. 

 

Figure 13 Sample Hex Dump 

To begin a hex dump, first place the printer OFFLINE and enable the Hex Dump Mode option from the 
control panel: enable the Tools > Diagnostics > Hex Dump Mode menu. 

Next, place the printer back ONLINE and send data to the printer from the host computer. Any data 
received from the host is “dumped” to the printout. 

To cancel a hex dump, first place the printer OFFLINE and disable the menu(s) affected. The paper may 
then be advanced to the next Top-of-Form. 

Controlling Print Quality 

Three factors have the greatest effect on print quality: 

• The amount of heat applied by the printhead (print intensity) 

• The speed at which media is moving under the printhead (print speed) 

• The position of printhead burn line (printhead pressure) 

The life of the printhead can be adversely affected if an excessive amount of heat is needed to create the 
image. For example, low-cost direct thermal media often has very high reaction temperatures, which 
means that it takes a great deal of heat to make a clear image. This will shorten the life of the printhead. 
Resin ribbons and film media may require higher print intensity or greater head pressure to create a high 
contrast image, which may also shorten the life of the printhead. 
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The printer provides different ways to increase the heat: 

• Running the printer slower by changing the print speed via the host commands or the Media > 
Speed menu, allows more heat to transfer at lower print intensity settings. 

• Setting the print intensity to a higher value with the Print Intensity function, accessed via host 
commands or through the Media > Image menu. This causes the printhead to generate more heat 
to be transferred into the media. 

• The print intensity can be adjusted even higher with the Intensity Shift function, accessed through 
the Media > Image menu allowing the actual setting to reach a maximum of 20. This option 
should only be used if a slower speed or a higher heat setting was not successful. Using the 
Intensity Shift function will shorten the available printhead life expectancy. 

The position of printhead burn line will affect print quality. Please refer to section Printhead Burn Line 
Adjustment to adjust printhead burn line. 

Also, the printhead should be cleaned frequently to ensure that foreign material does not accumulate on 
the printhead and interfere with heat transfer. If smears, voids, or white lines appear in the printed form, 
the printhead should be cleaned with a printhead cleaning pen. 

The cleaning should be done as a matter of routine whenever you install a new ribbon (thermal transfer 
mode) or when you install new media (direct thermal mode). 

 

 
 

The most common signs of a worn printhead are fixed vertical streaks that are always the same size and in 
the same place on the printout. To determine if vertical streaks are caused by a worn printhead, follow 
these methods: 

1. Clean the printhead thoroughly with the printhead cleaning pen. Test again for vertical streaks. 

2. Remove the printhead (see Replacing the Printhead) and examine it for contamination or damage 

such as scratches, dents, or other marks on the light brown area containing the heating elements. 

Clean and install it, then test again for vertical streaks. 

3. Load an alternate roll of media. Test again for vertical streaks. 

4. Load an alternate roll of ribbon. Test again for vertical streaks. 

If after performing all these tests you still see fixed vertical streaks, you must replace the printhead. 

 

 

 

Printhead 
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Replacing the Printhead assembly 

1. Set the printer power switch to O (Off). 

WARNING Always unplug the printer power cord from the printer or power outlet before 

doing any installation procedure. Failure to remove power could result in injury 

to you and damage the equipment. When applicable, you will be instructed to 

apply power. 

 

2. Unplug the printer power cord from the printer or the AC power source. 

3. Open the printer top cover by pulling the blue levers , located on each side, toward the front of the 
printer, then lift the top cover. 

4. Remove the ribbon and media (e.g., paper, label, or tag stock material). 

CAUTION  Oils from your hands can damage the light brown area (heating elements) of 

the printhead. Do not touch the light brown area when you handle the printhead 
assembly. 
 

5. Touch an unpainted part of the printer frame before touching the printhead. 

6. Push the one side of print head assembly then lift up to disengage it from inner cover. 

   

 

 

 

 

 

 

 

CAUTION  To prevent electrostatic damage to electronic components, ground yourself by 

touching an unpainted part of the printer frame before handling and installing 

he printhead. 

 

  

 
Let latch to release from 

top inner cover. 
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7. Disconnect the printhead cable to replace the new printhead assembly. 

 

 

8. Install the right side latch of new printhead assembly first for making sure the printhead cable 
assemblies into the slot as shown below. 

    

9. Then install the left side latch of new printhead assembly to finish the printhead replacing. 

   

 

Latch 
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Restore the Printer to Operation 

1. Inspect the light brown area of the printhead for smudges or fingerprints. If necessary, gently 

clean the light brown area with a soft, lint-free cloth (or a cotton swab) moistened with isopropyl 

alcohol, or use a Cleaning Pen (P/N 203502-001). 

2. Install the ribbon and media (e.g., paper, label, or tag stock material). 

3. Close the pivoting deck and rotate the deck lock lever fully counterclockwise. 

4. Close the media cover. 

5. Plug the AC power cord into the printer and the power source. 

6. Verify the Printhead statistics from the ONLINE menu screen (the Printhead Gauge should show 
100%). 

7. Test printer operation and check print quality by selecting the Tools > Print Tests section and 
printing one of the test patterns. 
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Solving Other Printer Problems 

 
 

Table 12. Printer Problems and Solutions 

 
Symptom Solution/Explanation 

Communications Failures. 1. Check the interface cable. 
2. Check the configuration to ensure the correct interface is 

enabled. 

3. Verify the printer is receiving data by watching for 

“Receiving Data” messages in the ONLINE screen of 

the control panel. 

CONTROL PANEL 

LCD shows ONLINE and the 

printer appears to be 

working, but nothing is 

printing. 

1. Verify that the Active IGP Emulation shown on the 

control panel matches the emulation data sent to the 

printer. 

2. Verify that the SFCC selection(s) in the APPLICATION 

section of the menu match the SFCC utilized within the 

emulation data that is sent to the printer. 

3. Verify that the labels are the correct type (direct or thermal 

transfer). 

4. If using direct thermal media, check that the media is 

loaded with the direct thermal side facing up. 

5. Check that the transfer ribbon is correctly routed. Route 

transfer ribbon with ink side down as it passes under the 

printhead. 

6. Check that the printhead assembly is properly closed by 

making sure the printhead latch is fully engaged. 

7. Verify that the ribbon and media are compatible; 

incompatibility can cause extremely light printing. Match 

the ribbon to the type of media being used. 

8. Check the used sections of ribbon for a printed image. 

Often times when ribbon and media are incompatible, the 

image can be seen on the ribbon but it will not transfer to 

the media. 

9. Check that the Print Intensity is correct. Set the Print 

Intensity in the Media > Image section or via the host 

software. 

10. Check that the Label Width parameter value does not 

exceed the width of the media installed. Set the Label 

Width in Media > Image > Label Width. 

11. Run the Checkerboard test print pattern from the Tools > 

Print Tests menu. NOTE: Any imbalance of the print on 

the page could indicated that the printhead pressure may 

need adjustment. 

12. Remove the printhead completely and re-install it ensuring 

the cables are correctly seated. 
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Table 12. Printer Problems and Solutions 

 
Symptom Solution/Explanation 

LCD shows ONLINE and the 

printer appears to be 

working, but nothing prints 

and “Invalid Data” displays in 

the message area. 

This message informs the user that the printer has received 

data, but no valid commands were found. This typically occurs 

when an incorrect Active IGP Emulation or SFCC was 

selected. This message will continue to display until new data 

is received or when the printer is put OFFLINE. 

1. If the emulation and SFCC are correct, additional 

diagnostic information can be obtained by selecting the 

desired option under the “xxx Diagnostics” menu, found 

in the Application > Control section. 

2. After selecting the desired option, run the job again to 

obtain the additional diagnostic information. 

ONLINE status indicator is 

flashing. 

1. Check the LCD for a specific fault message. Press the 

PAUSE key, and if a fault message displays, refer to the 

LCD Message Troubleshooting table on page 233. 

2. Check for an Out-of-Media condition or missing labels in 

the middle of a roll. Load the correct media. 

3. Check that the ribbon and label stock are correctly routed. 

Load ribbon and label stock correctly. 

POWER FAILURES 

Printer fails to turn on, and 

the display is not backlit. 

1. Check that the printer AC power cord is correctly attached 

to the printer and to the AC power outlet. 

2. Have a qualified electrician test the AC wall outlet for the 

correct power range. Locate the printer in an area that has 

the correct power range. 

3. Check the AC power cord. Replace a damaged AC power 

cord or one that you suspect may be bad. 

4. Call your authorized service representative. 

PRINT QUALITY 

• Label(s) did not get 

printed within a multi label 

print job. 

• A portion of the printed 

image was clipped off 

and the beginning of the 

next label was printed on 

the same physical label. 

1. If the serial interface is being used, verify that the correct 

serial data protocol is selected to match the host 

interface protocol. 

2. If Media > Image > Clip Page = Enable, the printer may 

have falsely detected a gap, hole, or black mark and then 

clipped (discarded) the remaining printable data for the 

label. To fix this: 

a. Perform Auto Calibrate. See Running Auto Calibrate. 

b. Decrease Sensors > Control > Gap/Mark Threshold 

value by 2 or 3 increments. See Gap/Mark 

Threshold. 

c. Set Media > Image > Clip Page to Disable and Media 

> Image > Label Length to correct physical length 

value. See Intro: Clip Page. 
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Table 12. Printer Problems and Solutions 

 
Symptom Solution/Explanation 

Media moves, but no image 

prints in ONLINE mode. 

1. Make sure the J402 power supply cable has a good 

connection to the right side of the printhead. 

2. Place the printer OFFLINE and print the Checkerboard 

diagnostic test pattern in Tools > Print Tests section. If the 

pattern prints, there is a communication problem between 

the host computer and the printer. 

Media moves, but no image 

prints in Direct Thermal 

mode. 

1. Media is not the type for direct thermal printing. Install 

direct thermal media. 

2. Direct thermal media is installed wrong side up. Reinstall 

the media with the correct side facing the printhead. 

Media and ribbon move, but 

no image prints in Thermal 

Transfer mode. 

1. Print the Checkerboard diagnostic test pattern and check 

that the image appears on the used portion of ribbon. If the 

image is on the ribbon, the ribbon may be installed with the 

transfer side against the printhead, instead of against the 

media. 

2. The ribbon may be designed for another model printer. 
3. The ribbon may not be compatible with the media. 

When narrow media is 

installed, the media moves 

but no image prints. 

Verify the Media > Image > Label Width value agrees with the 

width of the installed media. Too large a value will start the 

image too far to the right and off the media. 

Printing is faded or of poor 

quality. 

1. Clean the printhead. 
2. Check that both latches on the pivoting deck are closed 

and latched. Close the printhead by pressing down on 

both sides of the pivoting deck and rotating the deck lock 

lever fully counterclockwise. 

3. Verify that the head pressure adjustment dial is properly 

set. Try increasing the pressure. 

4. Verify that the Print Speed and Print Intensity values are 

correct. Adjust Print Speed and Print Intensity in the 

Media > Speed and Media > Image sections, 

respectively, or via host software. 

Print is light on the left or right 

side of the label. 

Check if the pressure is set for the width of the media being 

used. Even the pressure near the edge of the media. 

Prints strange characters 

instead of the correct label 

format. 

1. If the printer serial interface is being used, check that the 

printer serial baud rate setting matches the baud rate of 

the host computer. Reset the printer via software, or turn 

the printer off and then on. 

2. Check if the printer serial host interface is set for 8 data 

bits but the transmitting device is set for 7 data bits (or 

vice-versa). Check the current setting by viewing it on the 

LCD, and use the Host IO > Serial section to adjust the 

settings, if necessary. 
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Table 12. Printer Problems and Solutions 

 
Symptom Solution/Explanation 

• Start of image is printed 

an erroneous distance 

from the top-of-form. 

• The printer starts to print 

one label and then 

another, all within the 

same physical label. 

1. Make sure the Media > Image > Label Length value 

matches the actual physical length of the label installed 

and the run on Auto Calibrate (see Running Auto 

Calibrate on page 40). 

 

These symptoms could be caused by: 

• Severely curled labels near the end of a media roll 

• Media sensor triggering off of a dark, preprinted image 
on the label 

• Multiple gaps within the physical label. 
2. Set Media Image > Clip Page to Disable. 
3. Run a Media Profile (see Running Media Profile page 41). 
4. If the Media Profile printout shows that preprinted images 

has an amplitude approaching the Gap/Mark Threshold 

level, position the lower media sensor to avoid the image 

or increase the Threshold Range percent value in the 

Sensors > Calibrate section. Run Auto Calibrate again and 

Media Profile to verify there is an improvement. 

• Loss of one or more 

serialized labels within a 

print job. 

• Start of image is printed 
in the middle of the gap. 

• The top part of the image 

is lost when printing with 

Head First orientation 

selected. 

1. Go to the Sensors > Calibrate section. 
2. Set Gap Windowing to Enable. 
3. Set Gap Length to equal the physical gap length of the 

media installed. The range is 0.05 to 1.00 inches. 

 
The likely cause of these symptoms is that Media Image >Clip 

Page = Enable and a cross-perforation, radical fold or flaw in 

the liner has caused the media sensor to detect this as the 

leading edge (TOF) of the new label or end of label (EOF), or 

both. 
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Table 12. Printer Problems and Solutions 

 
Symptom Solution/Explanation 

Smears or voids in printed 

image. 

1. Clean the printhead. 
2. Make sure the printhead temperature (Print Intensity) is 

not too high. Change the Print Intensity value in the 

Media > Image section. 

3. Verify that the printhead burn line is setup correctly to 

match the media width installed. 

4. Skin oils can adhere to the surface of label stock, causing 

fingerprints which inhibit thermal transfer. Wipe label stock 

with a cloth, or remove a few feet of labels to expose a 

clean area. Handle labels by the edges. 

5. Check that the media has not been mishandled before or 

during installation in the printer. Soiled media or media 

with fingerprints will prevent proper ribbon transfer. 

6. Check that media has not been installed inside out. 

Surfaces on both sides may look identical but can produce 

big differences in print quality. 

7. Make sure the correct ribbon and media combination are 

being used. Use the correct ribbon type. 

8. Check the ribbon for creases or folds across its surface. 

Smooth out the ribbon to remove any creases. 

9. Reduce the Print Speed value through the Media > Speed 

section, or via host software. 

10. If using ribbon (Transfer Print mode), do not use direct 

thermal media. 
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Table 11. Printer Problems and Solutions 

Symptom Solution/Explanation 

Advances several labels 

when FEED key is pressed. 

1. Check that labels are loaded correctly. 

2. Check that the Media > Image > Label Length (or sent by 

the host computer) agrees with the length of the media 

installed. Although gaps, holes, notches, or black marks 

are used to establish the Top-of-Form position, a larger 

page length will override the gap and skip a page or more 

if Media > Image > Clip Page is set to Disable. Set Label 

Length to match the media being used. 

3. Check that the printer is optimized to detect the type of 

media installed. Perform Auto Calibrate for gapped and 

black mark media. (See Running Auto Calibrate on 

page 40) 

4. Adjust the media sensor horizontally to detect gaps, holes, 

notches, or narrow width black marks. (See Positioning 

the Media Sensors on page 37.) 

5. If the problem persists, run the Media Profile printout to 

see if the label length indicators are being sensed. 

6. Run Manual Calibrate. (See Running Manual Calibrate 

on page 43.) 
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Table 11. Printer Problems and Solutions 

Symptom Solution/Explanation 

Label wraps around the 

platen roller. 

1. Open the pivoting deck by rotating the blue deck lock lever 

clockwise and then open the front door and loosen the two 

thumbscrews for better platen access. 

2. Remove the wrapped label by slowly pulling and 

unwrapping it from the platen. 

NOTE: Even though power is removed from the platen 

motor, some drag will be felt as the platen rotates. 

CAUTION 

Never use a sharp object against the platen as cuts and 

gouges in the platen may cause voids in the printed image 

and require platen replacement. 

3. When the entire label is removed from the platen, then use 

an isopropyl alcohol wipe, Printronix PN 254945-901, to 

remove all the adhesive from the platen to help prevent 

any future label wraps. Tighten the printer front door 

thumbscrews. 

4. A label wrap occurs when a die cut label is incorrectly torn 

at the tear bar by the user and adhesive is exposed under 

the leading edge of the next label. When the printer pulls 

this next label back to TOF, the adhesive contacts the 

platen and when the label advances forward during 

printing or a Form Feed, it wraps around the platen. 

5. Label wraps can be avoided by having the user practice 

careful tear off techniques and ensuring that the label 

across perforations are ideally positioned at the tear bar 

edge by using the correct Media > Image > Paper Feed 

Shift value. 

Pivoting deck is difficult to 

close and lock when heavy 

tag stock media is installed. 

1. Set the printhead pressure adjustment dial to the MIN 

position. 

2. Close the pivoting deck and lock the deck lock lever. 
3. Position the printhead pressure adjustment dial to the 

desired head pressure setting. 

Print is too small or too large. Ensure the proper printhead is installed (203 or 300 dpi). 
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Table 11. Printer Problems and Solutions 

Symptom Solution/Explanation 

Print quality is good, but the 

printer skips every other 

label. 

An occasional blank label 

occurs within a print job, but 

no labels are lost. 

1. Make sure that the label is not formatted too close to the 

top edge of the form. Leave white space equal to eight dot 

rows at the top of the label. 300 dpi = .0264 inches. 

203 dpi = .04 inches. 

2. Check that Media > Image > Clip Page = Enable. Clip 

Page = Enable causes any printable data to be clipped off 

and lost once the next TOF position (transmissive gap, 

notch, hole, or reflective mark) is detected. Clip Page = 

Disable allows the printer to ignore a gap or mark. The 

printer looks for the gap or mark after the specified Label 

Length is first reached. 

RIBBON 

Printer advances media, but 

the ribbon does not advance. 

1. Make sure the ribbon is installed correctly. 
2. A poor ribbon/media combination can cause insufficient 

friction between the media and ribbon. Verify that the 

correct ribbon and media are being used. 

3. The printhead pressure may not be set high enough. Set 

the pressure higher. 

4. There may be adhesive on the printhead. Clean the 

printhead. 

5. Verify that Media > Handling > Print Mode menu is set 

for Transfer and not Direct Thermal. 

Printer cuts (melts) through 

the transfer ribbon. 

1. Verify that Print Intensity is set to the proper level in the 

Media > Image section. 

2. Verify that Media > Handling > Print Mode menu is set 

for Transfer and not Direct Thermal. 

Printing stops and the 

ONLINE status indicator 

flashes. 

1. Check that the media sensor is clean and undamaged. 
2. Check that the gap between the bottom of a label and the 

top of the next label is at least 0.100 inch. Use only labels 

and tag stock approved for this printer. 

3. Inspect for a jammed label. Remove the jammed label. 
4. Check that the transfer ribbon and label stock are routed 

correctly. 
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Printer Alarms 

The printer has built-in alarms that monitor printer status and media stock conditions. Alarm messages 
display indicating the present status of the printer and media stock levels. The alarms also indicate if the 
printer electronics detect an error condition. 
 

Fault Messages 

If a fault condition occurs in the printer, the status indicator on the control panel flashes on and off and the 
message display indicates the specific fault. Fault messages are summarized in Table 14. 

Displayed faults fall into one of two categories: 

• Operator correctable 

• Field service required 

Operator-Correctable Fault Messages 

For the operator-correctable faults, follow the suggested corrective action under the solution section of 
the table. After correcting the displayed fault, press the PAUSE key to clear the error message and status 
indicator and resume printing. Some faults require the user to go ONLINE to clear. If the fault message 
reappears, power off the printer and wait 15 seconds before powering on the printer again. If the error 
condition persists, contact your authorized service representative. 

Fault Messages Requiring Field Service Attention 

If a fault is not correctable by the operator, the fault message is followed by an asterisk (*). This usually 
indicates that an authorized service representative is needed. You should try two steps to clear the fault 
before calling your authorized service representative: 

1. Set the printer power switch to O (off), wait 15 seconds, then turn the printer on again. Run your 

print job again. If the message does not appear, it was a false indication and no further attention 

is required. 

2. If the message reappears, press the PAUSE key. If the message goes away, it was a false 

indication and no further attention is required. If the message reappears, call your authorized 

service representative. 

Fatal Messages Requiring Firmware Upgrade or Diagnostics 

Some faults are generated by the software when a fatal error occurs that is not recoverable. These faults 
are prefixed with “Fatal Error:” and are the result of a software algorithm failure. When these faults occur, 
the following steps are recommended: 

1. Cycle Power. Run the print job again. If the message appears, load the latest firmware. 

2. Cycle power. Run the print job again. If the message appears, record the display message and follow 
the instructions for Error! Reference source not found.. 

3. Contact your authorized customer service representative. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

BAD VFU CHANNEL The application tried to use an undefined VFU channel. 

 

1. Change the application to use defined channels. 

BUFFER OVERFLOW Host sent data after the printer buffer was full (serial interface). 

 

1. Verify that the printer matches the host serial interface 

configuration settings for Data Protocol, Baud Rate, Data Bits, 

Stop Bits, Parity, Data Terminal Ready, and Request to 

Send. 

2. Set printer serial interface parameters to match those of the 

host. 

BUFFER OVERRUN Receive overrun (serial interface). 

 

1. Verify that the printer matches the host serial interface 

configuration settings for Data Protocol, Baud Rate, Data Bits, 

Stop Bits, Parity, Data Terminal Ready, and Request to 

Send. 

2. Set printer serial interface parameters to match those of the 

host. 

CALIBRATION FAIL Calibration values derived from Manual Calibrate were not 

acceptable. 

 

1. Run Manual Calibrate again. 

CANNOT CALIBRATE 

Disable Peel-Off 

Calibrate was attempted with Peel-Off Media Handling selected. 

NOTE: You can perform Auto Calibrate in Peel-Off mode if 

Cal in Peel Mode = Enable. Be prepared to catch labels during 

Auto Calibrate. 

 

1. Select another option in the Media > Handling > Media 

Handling menu. 

2. Enable Sensors > Calibrate > Cal in Peel Mode. 

CHECKSUM ERROR 

FLUSHING QUEUES 

The printer received the complete program but the checksum did 

not match. The data may have been corrupted during download.  

1. Power off the printer for 15 seconds, then power back on. 

2. If the problem persists, contact your authorized customer 

service representative. 



 

Page | 234 
 

Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

CUTTER FAULT 

Jam or Cut Fail 

• Cutter assembly is not in the closed position. 

• Cutter option was not able to complete a full cut cycle due to a 

jam. 

• Cutter PCBA detected current overload and opened circuit 

breaker on cutter PCBA. 

1. Place the cutter assembly in the closed (up) position. 

2. Clear obstruction from the cutter assembly. 

3. Ensure media thickness is within specification. 

4. Wait a few minutes for the cutter circuit breaker to 

automatically reset. 

5. Press PAUSE to clear the fault message and resume 

printing. 
Diagnostic Entry: 

Power-up Key Request 

Debugger CD Command 

Debugger HALT Command 

Diagnostic mode was entered from a special key sequence or 

the debugger.  

No action required. 

DIRECT THERMAL 

Remove Ribbon 

This is the normal reminder message when you change the 

Media > Handling > Print Mode setting from Transfer to Direct.  

1. Remove ribbon from the ribbon supply and ribbon take-up 

spindles in the printer. 

2. If ribbon is required for printing, change the Print Mode back 

to Transfer. 

ERROR: DC PROGRAM 

NOT VALID 
The printer cannot find the data controller program or the 

validation checksum is corrupt.  

1. Power off the printer for 15 seconds, then power back on. 

2. Download the emulation software again. 

3. If the problem persists, contact your authorized customer 

service representative. 

ERROR: PROGRAM NOT 

COMPATIBLE 
The printer is not compatible with the downloaded program.  

1. Power off the printer for 15 seconds, then power back on. 

2. If the problem persists, contact your authorized customer 

service representative. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

ERROR: PROGRAM NOT 

VALID 
The printer does not see a program in flash memory.  

1. Power off the printer for 15 seconds, then power back on. 

2. If the problem persists, contact your authorized customer 

service representative. 

ERROR OCCURRED 

FLUSHING QUEUES 
An interim message displays while the printer discards host data 

it cannot use because a fault condition exists. While this 

message displays, the asterisk (*) rotates.  

Wait. When the asterisk (*) stops rotating, a different fault 

message will appear; troubleshoot the final message. Contact 

your authorized customer service representative 

FATAL ERROR 

xxxx 

A fatal software error has occurred. 

1. Cycle Power. Run the print job again. If the message appears, 

load the latest firmware. 

2. Run the print job again. If the message appears, record the 

display message and follow the instructions for Error! R

eference source not found.. 

3. Contact your authorized customer service representative. 

FILE EXISTS 

Enable Overwrite 

The printer operator tried to save a file using the name of an 

existing stored file. 

1. Enter the System > Flash File Edit menu and enable the 

Overwrite Files feature to overwrite the existing file. 

 
FILE SYS FULL 

Delete Files 

Insufficient flash memory available to store file. Given there is 

128MB of Flash Memory, this error is still possible but unlikely. 

1. Go to the System > Flash File Edit section of the menu. 

2. Check the amount of flash memory that can be optimized 

from the “Flash Reclaimable” menu. 

3. If this value is small, then use “Delete Files” to delete 

unwanted files. 

4. If this value is large, then run “Optimize & Reboot”.  

 
FILE SYS FULL 

Optimize&Reboot 

File system not detected or flash was corrupted. 

1. Run the System > Flash File Edit >  Optimize & Reboot 

feature. 

 FILE SYS INVALID 

Optimize&Reboot 

The file system was given an invalid request. 

1. Run the System > Flash File Edit >  Optimize & Reboot 

feature. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

FILE SYS WRITE 

Check Flash 

Problem writing to flash memory. 

1. Power off the printer for 15 seconds, then power back on. If 

the problem persists, contact your authorized customer 

service representative. 

 FILE UPLOADING 

Please Wait 

File is uploading to PNE. 

1. Wait for upload completion before accessing printer front 

panel. 

 FRAMING ERROR Serial framing error over a serial interface. 

1. Match the serial interface settings of the printer to those of the 

host computer. 

GAP NOT DETECTED • The printer is set for Gap or Mark sensing, but a gap, notch, or 

black mark is not being detected. 

• The lower media sensor is not positioned correctly. 

• Gap/Mark Threshold is set too high or Paper Out Threshold is 

set too low. 

1. Check that the setting of the Gap/Mark Sensor in the 

SESNOR > Control section matches the installed media. 

2. Check the position of the lower and upper media sensors. 

(See Positioning the Media Sensors on page 37.) 

3. Clean the sensor assembly and paper path. 

4. Run Auto Calibrate to improve the sensor’s ability to detect the 

media in use. 

5. Run the Sensors > Diagnostic > Media Profile. 

6. Run Manual Calibrate. (See Running Manual Calibrate 

page 43.) 

7. Manually change the Gap/ Mark Threshold and/or Paper 

Out Threshold values. 

Half Speed Mode The printhead or power supply is approaching a hot state. Half 

Speed Mode helps the cooling process and should permit 

completion of print jobs. Half Speed Mode helps prevent a PRINT 

HEAD HOT or PWR SUPPLY HOT fault, which will stop the 

printer. 

1. Allow printer to continue printing. Full speed will resume 

automatically when a lower printhead or power supply 

temperature is achieved. 

2. Let the printer cool down. Full speed will be restored when 

printing is resumed. 

3. Lower Media > Image > Print Intensity and Media > Speed > 

Print Speed to reduce frequency of Half Speed Mode. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

HEAD POWER FAIL Printhead lost power. 

1. Replace the printhead. 

2. Power off the printer for 15 seconds, then power back on 

again.  

3. If the problem persists, contact your authorized customer 

service representative. 

 IGP/PGL ERROR Appears when the “Fault” option is selected from Error Report in 

the front panel and there is an application programming error with 

the IGP emulation PGL. 

1. Correct the application programming error as described in the 

PGL Programmer’s Reference Manual. 

2. The other option is to modify Application > PGL Setup > 

Error Report menu. 

 INCOMPATIBLE WITH 

CUTTER 

Peel-Off Media Handling selection was attempted with the cutter 

option still installed. These modes require that the Peel option be 

installed to use the Label Taken Sensor. 

1. Select a different Media Handling Mode. 

2. Power off the printer and remove the cutter option, install 

the Peel option, power on the printer and select Peel-Off 

Mode.  

LABEL MISSING 

Check Paper Path 

The Label Taken Sensor did not detect the label present over the 

tear bar with Peel-Off Media Handling mode enabled. 

• The label was removed before the printer stopped printing or 

before the LCD “Remove Label” message displayed. 

• The label slipped behind the platen roller. 

• The label wrapped around the platen roller. 

• Peel-Off Media Handling mode was mistakenly selected. 

 

1. Press the PAUSE key to continue printing and then wait for 

the LCD “Remove Label” message before removing the label. 

2. Open the pivoting deck, reinstall the label, close the deck, 

press the PAUSE key, and continue printing. 

3. Open the pivoting deck and remove wrapped labels from the 

platen. Clean all adhesive from the platen. Reinstall labels, 

close the deck, press the PAUSE key, and continue printing. 

4. Select the correct Media Handling mode in the Media > 

Handling section. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

OPTION NOT INSTALLED If the printer is powered on with the cutter enabled in Media > 

Handling > Media Handling, but the cutter itself is open (in the 

down position, or the cutter upper enclosure is removed) the 

printer cannot detect the cutter. When using the cutter, the printer 

must be powered on with the cutter in the up position and the 

cutter upper enclosure installed. 

 

1. Check that the cutter option is installed, connected in the up 

position, and the upper enclosure installed before powering 

on the printer. 

2. Install the cutter option or change to the correct option in the 

Media > Handling > Media Handling menu. 

3. If the error persists, contact your authorized customer service 

representative. 

 … OR … 

If the printer is powered on in Peel-Off in Media > Handling > 

Media Handling, but the Peel option cannot be detected by the 

printer. When using Peel-Off handling, the printer must be 

powered on with the Peel option installed. 

 

1. Check that the Peel option is installed and connected before 

powering on the printer. 

2. Install the Peel option or change to the correct option in the 

Media > Handling > Media Handling menu. 

If the error persists, contact your authorized customer service 

representative. 



 

Page | 239 
 

Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

PAPER OUT 

Load Paper 

The printer does not sense media: 

• Media was not installed or has run out. 

• A break in media has occurred. 

• Media was not routed or installed correctly. 

• The media sensor is not positioned correctly. 

• Media is installed correctly, but the sensor is not detecting it. 

• Sensors > Control > Gap/Mark Thresh value may be set too 

high and/or Sensors > Control > Paper Out Thresh may be set 

too low. 

• The printer detected a false PAPER OUT when changing to 

Gap or Mark sensing or vice-versa. 

 

1. Install media. If a break occurred, reinstall the media. Press 

the PAUSE key to clear the fault message. 

2. Verify the lower media sensor is properly positioned under the 

media. Run Auto Calibrate to improve the ability of the sensor 

to detect the installed media. 

3. Check if the Gap/Mark Threshold is too high or the Paper Out 

Threshold is too low. Lower the Gap/Mark Threshold or raise 

the Paper Out Threshold value. 

4. If using media with no gaps or black marks, perform Auto 

Calibrate to establish a valid Paper Out Threshold. 

5. If the printer detected a false PAPER OUT when changing to 

Gap or Mark sensing or vice-versa, press the PAUSE key and 

run Auto Calibrate. 

PARITY ERROR Parity error (serial interface). 

1. Check your serial host interface parameter settings. If 

necessary, change them so they match the settings of the 

attached host. 

 
POWER SAVER MODE This is a status message. The printer is in low-energy idle state, 

the higher voltages are off, and only +5Vdc logic circuits are 

active. 

No action required. 

PRINT HEAD COLD Printer is in a cold environment or the printhead data cable has 

become dislodged from the back of the printhead or the controller. 

1. Reseat the cables on printhead. 

2. Change the printhead. 

3. Place printer in a warmer location. 

4. If problem persists, contact your authorized service 

representative. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

PRINT HEAD HOT The printhead has become overheated. 

1. Allow the printhead to cool down for 5 minutes, then press 

PAUSE. Resume printing. 

2. If possible, reduce print intensity. 

3. If problem persists, contact your authorized service 

representative. 

PRINT HEAD UP 

Close Print Head 

Printhead is not closed and completely latched. 

1. Close and latch the printhead pivoting deck. 

PRINTER HOT The printer has detected higher than usual temperatures on the 

controller PCBA. 

 

1. Power off the printer for 15 seconds, then power the printer 

back on. 

2. Move the printer to a cooler location. 

3. If the problem persists after moving the printer to a 

cooler location, contact your authorized customer 

service representative. 

PRINTER UNDER 

REMOTE CONTROL 

Indicates that PNE has control of the printer. 

1. Press any key on the printer. 

Remove Label • A label was detected at the front of the printer by the Label 

Taken Sensor. This is the normal reminder message when 

Peel-Off Media Handling has been selected. 

• A label was removed, but the “Remove Label” message 
remained. 

• The incorrect Media Handling mode was selected. 

 

1. Remove the label from the front of the printer to allow the next 

label to print. 

2. Verify that a front door assembly is installed on the printer and 

that it is properly closed. Ensure that no debris is obstructing 

the door mirror or the Label Taken Sensor. 

3. Change Media > Handling > Media Handling to the correct 

selection. 

Replace printhead for 

optimal print quality 

The printhead has reached the end of the warranty life. 
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Table 13. LCD Message Troubleshooting 

 
Displayed Message Solution/Explanation 

Ribbon Low • The supply spool is getting low. 

• If there is a large amount of ribbon still on the supply spool, 

then the Ribbon Low message is being displayed falsely. 

1. Replace ribbon. 

2. Disable Media > Ribbon > Ribbon Low. 

RIBBON OUT 

Load Ribbon 

The ribbon supply spool is empty or the ribbon has broken. 

1. Replace ribbon. 

2. Reinstall ribbon. 

SECURITY VIOLATION # The software being used is not correct for the printer. 

1. Load the correct software. 

2. If the problem persists, contact your authorized customer 

service representative. 

NOTE: 

# represents source of the error where: 

  1 = Failure during 3 button download 

  2 = Failure during 2 button download 

  3 = Failure during power up 

 

Hex Dump Mode 

As an aid to troubleshooting, the Hex dump mode allows you to place the printer into a diagnostic mode in 
which the printer outputs a hexadecimal data stream on the label for examination. The purpose of hex 
dump mode is to see exactly what data is received by the printer, in order to debug forms. 

When enabled, the hex dump mode translates all host interface data to its hexadecimal equivalent, then 
prints the hex code and its printable symbol, if one exists. Figure 13 shows a partial example of a hex 
dump. 

 

Figure 14 Sample Hex Dump 

After the printer enters hex dump mode, all characters it prints (including any in the printer’s input buffer) 
are printed in two forms: as a two-symbol hexadecimal code and as the character’s printable symbol (if it 
has one). A non-printable code is printed as a period [.] symbol. Up to 16 characters can be printed per 
line of hex dump printout. While the printer is in hex dump mode, it does not act upon any control codes, 
other than to print their hexadecimal equivalents. 
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The 16 characters printed per line on the hex dump are formatted so that the 16 printable symbols are 
printed in columns 1 through 16. The 17th column is blank. Column 18 contains either a p (PI line active) or 
a blank (PI not active). Columns 19 and 20 contain the hexadecimal code for the first character, followed 
by a blank. The PI line condition and hexadecimal code for the second character are printed in columns 
22, 23, and 24, followed by a blank. The third through 16th characters are printed in a similar manner. The 
hexadecimal code for the 16th character is printed in columns 78, 79, and 80. 

NOTE:  Values will vary based on printhead width. 

Subsequent printing observes the current setting for skip-over perforation, form length, and top-of-form 
position parameters. 

IMPORTANT You must have a minimum of 4.1 inches of media installed and have Media 

> Image > Label Width set to 4.1 inches. If not, the hex dump data will be 
truncated and lost. 

If a fault occurs while printing a hex dump, the printer reverts to the normal fault state. When the fault is 
cleared, the printer resumes printing the hex dump (either a partial line with a form feed or nothing at all). 
Top-of-Form remains unaffected. 

 

To begin a hex dump, first place the printer OFFLINE and enable the Hex Dump Mode option from the 
control panel: enable the Tools > Diagnostics > Hex Dump Mode menu. 

Next, place the printer back ONLINE and send data to the printer from the host computer. Any data 
received from the host is “dumped” to the printout. 

To cancel a hex dump, first place the printer OFFLINE and disable the menu(s) affected. The paper may 
then be advanced to the next Top-of-Form. 

Diagnostics for Fatal Error 

If the printer stalls with an LCD message that starts with “Fatal Error:”, reboot the printer and continue. If 
this situation persists, invoke the diagnostic Auto Dump that will capture the failure dump in a flash file 
that can be later uploaded from PrintNet Enterprise Suite or SD memory card and sent to Printronix 
Customer Support Center (see Printronix Customer Support Center) for further analysis. 

This diagnostic option must be enabled for the printer to capture the information. To perform this 
diagnostic do the following the procedure: 

1. Enable the Tools > Advanced > Auto Dump option. 

2. When the failure happens, reboot the printer and wait for it to power up again. 

3. Under System > Flash File View, check to see if files ‘AUTODP*.LOG ‘ are present. 

4. If present, use PrintNet Enterprise Suite to upload these files to your host computer. Alternatively, use 
the function System > Flash File Edit > Copy to SD to copy the file onto an SD memory card. Or use 
System > USB File Edit > Copy to USB to copy the file onto a USB drive. 

5. Contact Printronix Customer Support Center and send them the files and the printer’s configuration 

printout. Refer to the PrintNet Enterprise Suite User’s Manual for instructions to accomplish these 

tasks. 
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A Specifications 

Print Method 
 
 

Table 14. Printing Specifications 

 
T820 T830 

Print Resolution (dpi) 203 300 

Min. Dot Size (sq. in) 
.005 

(.127 mm) 

.0033 

(.083 mm) 

Bar Code Modulus (mils) 

 

 

 
 

5 - 127 

 
 

3.3 - 110    Picket Fence 

   Ladder 10 -127 10 - 110 

Max. Print Speed (ips) 8 

Max. Slew Speed (ips) 8 

Max. Print Width 
4.1 

104.1 mm 

Print Length 
0.25 ~ 50” 

6.3 ~ 1270 mm 
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Media Handling 

 
Maximum 

Width 
Label 

Max Print 
Speed  

Limitations 

Tear-off 4.4 in 8 ips - 

Peel 4.4 in 3 ips nom 
Not compatible with 

RFID 

Cutter 4.4 in 4 ips nom 
Not compatible with 

RFID 

 
 

Media 

 
 

Table 15. Media - General Information 

Type Roll-fed, die-cut continuous or fanfold labels, tags or tickets; 

most direct thermal or thermal transfer materials. 

Supply Roll 5 inch (127 mm) maximum diameter on 1 inch (25.4 mm) to 1-

1/2 inch (38 mm) diameter cores. 

Label Material Thermal transfer plain-coated papers, vinyl, Mylar, metallized 

paper, non-woven fabric, fine woven fabric, thermal-visible light 

scannable paper, infrared scannable paper, thermal ticket/tag 

stock, thermally-sensitive plastic stock. 

Media Sensing Mark sensor horizontally moveable sensor. Gap sensor fixed 

position centerline of printer. When set to Mark, it senses a black 

mark on the underside of tag or label stock, or notch on side. 

Gap sensor recognizes the inter-label gap by shining light through 

the linter. When set to Disable, it senses no label indicators or 

ignores all existing label length indicators on the installed 

media. 
Label Peel-Off Peels and presents label to the operator, one at a time.  

Label Taken Sensor (part 
of the Peel Option) 

Detects when a printed label is at the printer exit throat. Used 

only for Peel-Off Media Handling mode. 
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Direction of Media Motion Direction of Media Motion Direction of Media Motion 

I. Tag Specification 

(Mark Sensing) 

II. Tag Specification 

(Gap Sensing) 

III. Label Specification 

(Gap Sensing) 

 

 

 

 

 

  
  

 
 
 
 
 
 
 
 
 
 
 
 

Figure 15 Media Dimensions 

Table 16. Media Specifications 

 
 

  T820  T830  

A Label Width Range 0.79 -4.4 in. 

20mm to 112mm 

B Backing Width Range 0.79 -4.4 in. 

20mm to 112mm 

C Min. Gap/Hole/Notch Height 0.10 in. 

2.54 mm 

K Min. Refl. Mark Height 0.10 in. 

2.54 mm 

I Min Refl. Mark Width 0.5 in. 

12.7 mm 

E Media Thickness Range 0.00236 -0.00748 in. 

0.06 -0.19 mm 

G Width of Inter-label gap/hole 0.25-0.50 in.  

6.35-12.7 mm 

Black Mark (on underside) 
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Table 16. Media Specifications 

 
 

  T820  T830  

D Media Length Range 

Continuous/Batch Mode1 

Tear-Off Strip Mode1 

Peel-Off Mode 

Cut Mode 

 

0.25 in. (6.35mm) – 50 in. (1270mm) 

0.25 in. (6.35mm) – 50 in. (1270mm) 

1 in. minimum (25.4 mm) – 50 in. (1270 mm) 2 

1 in. minimum (25.4 mm) – 50 in. (1270 mm) 

 These figures are approximate and depend upon the active emulation and application. 
(1) Media length must be greater than 1.96” (49.8mm) for tear function. 
(2) 1.5 inch with Validator support. 

 

 

Ribbon 
 

Table 17. Ribbon Specifications 

 
 
 

T820 T830 

Ribbon Width Range 
1.0 -4.4 in. 

25.4 -112 mm 

1.0 -4.4 in. 

25.4 -112 mm 

Max. Ribbon Length 300m 300m 

Max Ribbon Roll 

Diameter 

2.68 in 

68mm 

 

2.68 in 

68mm 
 

Indicators and Switches 

 

Table 18. Indicators and Switches 

Indicator Lights: ONLINE 

Switches: POWER 

Keys: PAUSE, FEED, LEFT SOFT KEY, RIGHT 

SOFT KEY, UP / DOWN / LEFT / RIGHT 

ARROW KEYS,  (ENTER) 

Message Display: 320 x 240 Color QVGA display 
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Memory 
 

Table 19. Memory Specifications 

Flash Memory (standard) 128 MB soldered onto Controller PCBA 

DRAM (standard) 128 MB soldered onto Controller PCBA 

 

Media Cutter Option 

Cutters are designed to cut tags and label liner. Avoid cutting through the adhesive backed portion of any 
media. 

Cutting through perforate liner is not recommended. In addition, although the cutter may operate with 
synthetic, foil, and woven materials, application testing is encouraged to ensure reliable operation and to 
assess cutter life. 

 

Table 20. Cutter Specification 

Typical Life > 1,000,000 cuts 

Warranty** 12 months or 500,000 cuts  

(whichever comes first) 

 Environment Same specifications as printer 

Cutting Method Slide type 

Media Thickness Range 0.06~0.28mm (0.00236~0.0011in) 

Media Width Range 15~110mm (0.6~4.33in) 

Media Length Range 25.4~1270mm (1.00~50 in.) 

Allowable Cutting Frequency Max. 25 cuts per minute  

(cutting 0.06mm media) 

 

 

** Warranty is based on cutting label liner and paper based tag stock only. All other materials (including 
synthetic, foil, and woven materials) may reduce cutter life to an indeterminate amount, even when they 
are within the rated media thickness specification. Qualification and life-testing is recommended for these 
cutter applications. 
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Host Interfaces 
Table 21. Host Interface Characteristics 

1.  RS-232 at 600,1200,2400,4800,9600,19200,38400,57600, or 115200 baud. 
2. USB 2.0 
3. Ethernet 10/100 
4. Wireless 802.11 a/b/g/n 

The RS-232 host interfaces shall have the following characteristics: 

Word Length: Selectable 7-bit or 8-bit data format 

Handshaking: XON/XOFF (in receive mode only) and 

CTS/RTS 

Input Buffer: Selectable from 1k through 16 kbytes. XOFF 

is transmitted and RTS goes low when 

buffer is equal to or less than 25% of full. 

XON is transmitted and RTS goes high 

when buffer is 25% above empty. 

Characters are transmitted with no parity 

from the printer 

 

Power 
Table 22. Power Source and Grounding 

Power Source: 115 or 230 VAC 50/60Hz switching 

power supply. 

Grounding: Unit must be connected to a properly 

grounded receptacle. 

 

Table 23. Power Consumption 

 203 dpi, 14 ips 300 dpi, 12 ips 

Energy Power Saver Mode 1.9 Watts 1.9 Watts 

Standby 5.4 Watts 5.4 Watts 

25% Print Density 90 Watts 90 Watts 

T800 in Thermal Transfer Print Mode, +15 Intensity, 22degC @ 40% RH 
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Environmental 
 

Table 24. Environmental Information 

Operating Temperature: 41° F to 104° F (5° C to 40° C) 

Storage Temperature: -40° F to 150° F (-40° C to 60° C) 

Operating Humidity: 

Storage Humidity: 

20% to 85%, non-condensing 

5% to 85% non-condensing 

Ventilation: Free air movement 

Dust: Non-conducting, non-corrosive 

Noise <66dB(a) 

 

Physical 

 

Table 25. Physical Dimensions 

 T820, T830 

Outside Dimensions 1.5 in H x 8.6 in W x 11.2 in D 

119mm H x 219mm W x 285mm D 

Weight 6lbs 

2.75kg 

NOTE: 

Media Cutter: Add 1.4 in Depth 

 

Acoustic Specifications 
 

Table 26. Acoustic Noise Levels per ISO 9296 

 T820, T830 

Printing @ 6 IPS 66 dBA 

Standby Same as Ambient 
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B Printer Options 

Media Handling Accessories and Options are offered with the printer to enhance its capabilities and to 
provide a large degree of application flexibility. A description of the option complement is given below. 
Field-installable options include installation instructions. 

Media Handling Accessories 

Media Cutter 

The printer may be ordered with a cutter mechanism installed (for cutting tags and label liner), or the option 
can be installed by an authorized service representative at a later date. Once installed, the printer can be 
configured to automatically cut media after each or a specified number of labels is printed. 

Peel Dispenser 

Peels off labels one at a time before printing the next label. Peel-off is available as a factory option or field 
installable kit. 

Hardware Options 

RFID 

This option provides the capability of programming EPC Global Gen2 RFID tags during the printing 
process. 

The printer may be ordered with the RFID reader installed. 

Interface Options 

Wireless NIC (802.11 a/b/g/n/ac/b/g/n wireless) 

The Wireless NIC provides 802.11 a/b/g/n/ac/b/g/n connectivity. The card provides wireless connectivity 
without expensive cabling and reconfigurations required from a wired network. PNE (standard with the 
wireless NIC), is a printer management tool.  

The printer may be ordered with the wireless option installed. 

Bluetooth 4.2 

The BT 4.2 adapter provides wireless communications protocol designed for low power usage, within a 
short range.  

The printer may be ordered with the Bluetooth option installed. 
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Software Options 

Premium Asian Fonts 

A selection of three different purchasable Asian fonts can be provided (one font per SD card). These Asian 
fonts include Hanzi GB, Kanji SJIS, and Hangul, are available for use when the SD card is installed. 

Quick Change Memory Cartridge 

The QCMC provides the ability to duplicate an entire printer’s firmware, saved configurations, and custom 
files quickly through the printer’s control panel with a user friendly interface. 

Supplies 
The best printing solution is achieved when the printer, ribbon, and media are matched to the application 
requirements. The use of Genuine Printronix Thermal Media and Ribbons will ensure optimum image 
quality, consistent bar code performance, and extended life of the printhead. 

For any other questions concerning Genuine Printronix Thermal Supplies, please visit our company’s 
website or email to the following entities: 

 

Americas: Service@PrintronixAutoID.com  

Europe, Middle East, Africa: EMEA_support@PrintronixAutoID.com  

Asia: APAC_support@PrintronixAutoID.com  

China: CHINA_support@PrintronixAutoID.com  

 

Manuals 
The most recent edition of our manuals are available from our company’s website. 

• Maintenance Manual 

• LP+ Programmer’s Reference Manual 

• PGL Programmer’s Reference Manual 

• VGL Programmer’s Reference Manual 

• TGL Programmer’s Reference Manual 

• IGL Programmer’s Reference Manual 

• STGL Programmer’s Reference Manual 

• DGL Programmer’s Reference Manual 

• IEGL Programmer’s Reference Manual 

• MGL Programmer’s Reference Manual 

• EGL Programmer’s Reference Manual 

• RFID Labeling Reference Manual  

• Network Interface Card User’s Manual 

• PrintNet Enterprise Suite User’s Manual 

 

mailto:Service@PrintronixAutoID.com
mailto:EMEA_support@PrintronixAutoID.com
mailto:APAC_support@PrintronixAutoID.com
mailto:CHINA_support@PrintronixAutoID.com
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C Media Cutter Installation 

Printer Media Cutter Installation 

Preparing the Printer 
1. Set the printer power switch to O (Off). 

2. Open the printer to remove the front cover as shown. 

 

       
 

Installing the Media Cutter 
WARNING The cutter blades are sharp. Keep your fingers away from the cutter blades. 

 

3. Put the cutter cable connector through the opening of the lower inner cover front side. 
 

 

Cutter Cable 

Connector Cutter Assembly 
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4. Gently place the cutter assembly into niches on both sides of the lower inner cover, then push the 
cutter to lock into the lower inner cover. Make sure the cutter cable is fed into the opening. 

 

 

5. Turn the printer upside down. Unscrew one screw on the printer bottom cover. 
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6. Open the cover to plug the cutter assembly connector into the printer main board receptacle. 

 

Note: There is the RTC battery cable on the bottom cover, please open the cover carefully. 
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D Peel-off Module Installation 

Printer Peel-off Module Installation 

Preparing the Printer 
1. Set the printer power switch to O (Off). 

2. Open the printer to remove the front cover as shown. 

 

       
 

Installing the Peel-off Module 
 

3. Put the peel-off module cable connector through the opening of the lower inner cover front side. 

 

Peel-off Module 

Cable Connector 

Peel-off Module 
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4. Gently place the peel-off module into the niches on both sides of the lower inner cover, then push it to 
lock into the lower inner cover. Make sure the cable is fed into the opening. 
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5. Turn the printer upside down. Unscrew one screw on the printer bottom cover. 

 

6. Open the cover to plug the peel-off module connector into the printer main board receptacle. 

 

Note: There is the RTC battery cable on the bottom cover, please open the cover carefully. 
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E Loading WLAN Certificates 

Overview 
This section describes how to load the certificate(s) for both the WLAN Extensible Authentication Protocol 

(EAP) and SOTI Connect https://www.soti.net/products/soti-connect/ using the PSA File Utility. The 

PSA File Utility will take certificate files (generated by the System Administrator) and combine them with 

the PTX_SETUP commands such that a single output file can be sent to the printer and effectively load 

the certificates. 

IMPORTANT For the certificates to work correctly, the Real Time Clock (RTC) must be set 

properly. This can be done using the menus in System > Date. 

WiFi Certificates 

There are two options that can be selected for EAP mode that determines whether one or three files is 

needed. For EAP-TLS, the printer requires three files: 

• Certificate Authority (CA) File 

• Privacy Enhanced Mail (PEM) Certificate File 

• Key File 

 

For EAP-PEAP, only the Certificate Authority File is required. These files should originate from your 

System Administrator.   

NOTE:  WLAN Certificates can only be loaded if the WLAN Option is installed in the printer.  

SOTI Certificates 

There are 4 different certificate files that can be downloaded to the printer to support SOTI connection: 

• MQTT Certification File 

• File Store File 

• Printer Certification File 

• Private Key File 

One or more of these files can be provided to create a single file that loads them into the printer. 

802.1x Certificates 

There are 3 different certificate files that can be downloaded to the printer to support the 802.1x 

connection: 

• Certificate Authority (CA) File 

• Printer Certification File 

• Private Key File 

One or more of these files can be provided to create a single file that loads them into the printer. 

 

https://www.soti.net/products/soti-connect/
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WiFi Certificates 

Windows Procedure 

Download the PSA File Utility available from our company’s website. Run the application then execute the 
WiFi Certificate Load section as follows, choosing either EAP-PEAP or EAP-TLS. 

 

 

This will bring up a Dialog with either one or three files needed as input: 

      

    

You can either double-click in the file boxes  or click on the  button to enter the file 
names for each type of security file. 

Once every required file has been entered, the Create button can be pushed and the user will be prompted 
to choose an output file.  

Once the output file is created, this output file can then be sent to the printer like any other host application 
job while the printer is online. No need to put the printer in download mode. 

Linux Procedure 

1. Download the WLAN Certificate Utility from our company’s website.   
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2. Unzip the file and you will find a Linux version (bdcert.lnx), Windows version (bdcert.bat), and 
README.TXT file. 

3. The bdcert.lnx must be run from a Linux command line. 

4. Usage of the bdcert.lnx is as follows: 

When all three certificate files are required:  

 bdcert.lnx (ca file) (pem file) (key file)  >  (ptx file) 

When only the certificate authority file is required: 

    bdcert.lnx (ca file)  >  (ptx file)    

5. Run bdcert.lnx with the certificate authority filename, the certificate filename, and the private key 
filename redirecting the output to an output file or Run bdcert.lnx with the certificate authority 
filename redirecting the output to an output file. 

6. Once the output file has been generated it can be sent to the printer through any host interface while 
the Printer is Online. 

Webpage Procedure 

NOTE:  Certificates can be loaded using the Ethernet or WLAN interface. 

1. Make sure the printer is powered up, in ONLINE mode, and that the Ethernet cable is connected or 
the printer is connected through the WLAN. 

2. Get the IP address from the front panel ONLINE screen (or under Network  in Settings ). 

3. Enter the printer’s IP address in your browser (e.g., http://10.224.5.21). 

4. When prompted for a user name and password, enter “root” for user name and click OK. 

5. Click “Network” in the Configuration box. 

 

6. In the Certificates and Security Key box browse for the certificate files.   

 

7. Enter the Certificate file in the PEM slot. 

8. Enter the Certificate Authority file in the CA slot. 

9. Enter the Private Key file in the Key Slot. 
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10. Click on the Upload button for each of the files 

 

11. After each file is uploaded a Notification message is displayed. 

 

12. Click on OK to continue to the next file. 

13. After all the files have been uploaded a notification message is displayed. 

 

After the Web Page redisplays the Certificates are loaded and ready to use. 
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SOTI Certificates: Create the Download File 
Download the PSA File Utility available from our company’s website. Run the application then execute the 
SOTI Certificate Load section as follows. 

 

 

This will bring up a Dialog with four optional files that can be chosen as input: 

 

 

You can either double-click in the file boxes   or click on the  button to enter the 
file names for each type of security file. 

Once at least one file has been entered, the Create button can be pushed and the user will be prompted 
to choose an output file. Ideally, all four files would be entered before doing the Create action. 

Once the output file has been generated, it can be sent to the printer as any other application or host job 
while the printer is online. 
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802.1x Certificates: Create the Download File 
Run the PSA File Utility and then execute the 802.1x Certificate Load section as follows. 

 

 

 

This will bring up a Dialog with three optional files that can be chosen as input: 

 

       

    

You can either double-click in the file boxes   or click on the  button to enter the 
file names for each type of security file. 

Once at least one file has been entered, the Create button can be pushed and the user will be prompted 
to choose an output file. Ideally, all four files would be entered before doing the Create action. 
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F PTX_SETUP Commands 

Overview 
The PTX_SETUP commands are a superset of commands which allow the printer to perform several 
tasks by parsing commands either stored in flash or sent to the printer by the host. Commands range from 
re-routing debug statements to downloading complete printer configurations. 

This appendix describes the PTX_SETUP commands specific to thermal printers, as well as the 
commands which are not platform specific. 

Command Format 
Some concepts to keep in mind are as follows: 

1. PTX_SETUP commands are not emulation specific. In a system with IGP emulations, the IGP level 
emulation will process the PTX_SETUP commands. In a system without an IGP, the PTX_SETUP 
commands will be processed by the base emulation (e.g., LP+). 

2. Since there is no disk on a flash-based printer, DISK_IO commands are now called FILE_IO. 
However, for backwards compatibility DISK_IO and FILE_IO are synonymous. 

3. The PTX_SETUP command set is case sensitive; all PTX_SETUP commands are in upper case 
characters only. 

4. The white space separating commands may be any number of spaces and tabs. This allows a 
PTX_SETUP file to be formatted for easier readability. 

5. The PTX_SETUP and PTX_END command should be followed by a new line character. 

6. Any unknown command will terminate the PTX_SETUP processing. The offending command will be 
the first line of printed text. 

7. Although the original implementation of PTX_SETUP allowed for only a single parameter, separated 
from the sub-command by a single semicolon (;) character, the new PTX_SETUP command set 
allows for multiple parameters separated by commas, semicolons, spaces or tabs. 

Each emulation has modes in which the PTX_SETUP commands could get missed. For example, when a 
PGL label is being defined using the ~CREATE … END sequence, PTX_SETUP commands will not be 
processed during label format definition.  

Therefore, it is highly recommended that all PTX_SETUP commands be placed between print jobs, rather 
than attempting to embed them within jobs. 
 
PTX_SETUP commands have the following format: 

(SFCC)PTX_SETUP 

Command–Action;Parameter 

PTX_END 

For example, if the SFCC assigned to PTX_SETUP is the default value of the exclamation mark (!, hex 
21), and you wanted to load configuration number 4, you would use the following command: 

!PTX_SETUP 
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CONFIG–LOAD;4 

PTX_END 

This Appendix Section will be divided into different PTX_SETUP groups based on the Command. Each 
section will show different Actions and Parameters with a brief description of each. Some Commands may not be 
available for every product as they are often related to a particular option or capability. This will be noted in the 
Section. 

NOTE:  When a file system error occurs, a message will be displayed on the front panel indicating the 

error, and the action needed to take to correct the error. 
 

SECURITY Commands 

!PTX_SETUP 

SECURITY-PASS;<password> 

SECURITY-SET;<ENABLE/DISABLE> 

PTX_END 

 

The SECURITY commands add an extra layer of protection to prevent the printer NIC from being 
configured without authorization. Security is disabled by default and must be enabled with a user-defined 
password. It is up to the user to create a strong password and store it in a secure location. 

 

If the user forgets the Security password, it can be reset by executing the ENet-To-Default menu through 
the front panel or the webpage. If security is enabled, all PTX_SETUP scripts using NIC_SETUP 
commands will be required to prepend the SECURITY-PASS command with the correct password for the 
printer. If no SECURITY command is included in the PTX script file, the NIC_SETUP commands will be 
ignored by the printer. If the SECURITY feature is disabled, then the SECURITY-PASS parameter is not 
needed and will be ignored if present. 

 

SECURITY Usage example: 

'!PTX_SETUP 

SECURITY-PASS;Yklmn@1o7vnb 

NIC_SETUP 

enable telnet 

END_NIC_SETUP 

PTX_END 

 

HOST_IO Commands 

!PTX_SETUP 

SECURITY-PASS;<password> 

HOST_IO–Action;Parameter 

PTX_END 

 

Note: The SECURITY-PASS command is only required if SECURITY is enabled on the printer. 
Otherwise, the SECURITY sub-command can be omitted. 
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Table 28. PTX_SETUP FILE_IO Commands 

Action Parameter Description 

USB enable,disable Enables or disables the printer host USB interface. 

PNE enable.disable Enables or disables the PNE port. The default number is 

3001. 

MGMT enable,disable Enables or disables the printer management port. The 

default number is 3001 and is typically used for PXML. 

 
 

CONFIG Commands 
!PTX_SETUP 

CONFIG–Action;Parameter 

PTX_END 
 

Table 27. PTX_SETUP CONFIG Commands 

Action Parameter Description 

CLEAR_NAMES  
This command resets all of the configuration names to their 

default values. 

DELETE Cfg Deletes Configuration number Cfg 1-8. 

DOWNLOAD Cfg 
This command saves the configuration data that follows as 

configuration Cfg. Cfg must be 1-8 or END. 

GET_NAMES 

Port 

or 

FILE;NAME 

This command uploads the names of the configurations to 

the port specified by Port. Port must either be “1284”, 

“SERIAL”, “USB”, or “ETHERNET”. 

Alternatively, “FILE” followed by a filename NAME can be 

used to store the info into a file. 

INFO Port 

This command uploads general information about the printer 

to the port specified by Port. Port must either be “1284”, 

“SERIAL”, “USB”, or “ETHERNET”. 

The format of the return information is discussed later in this 

section. 

 

LOAD Cfg 

Cfg can be 0-8 (0=Factory). This loads configuration Cfg. If 

configuration Cfg was not previously saved, the operator panel 

will display an error message and the current configuration 

will not be changed. 
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Action Parameter Description 

MPI_SELECT MPI 

This command selects the active Management Protocol 

Interface (MPI). Currently there are two selections “UCP” and 

“PXML”. The default is PXML. 

NETCFG 0 or 1 
Loads the NIC configuration:  

0 = OEM Configuration, 1 = MFG Configuration 

OVERLAY Cfg 

This command overlays the configuration data that follows on 

existing configuration Cfg. Cfg must be 1-8 (or END). If Cfg 

does not exist then command is treated the same as 

DOWNLOAD. 

PANEL 

LOCK 
 

 
or 
 

UNLOCK 

Parameter “LOCK” locks the operator configuration menu. 

 
Parameter “UNLOCK” unlocks the menu and allows the 

operator access to the menus. By default, the menu is 

unlocked. 

PNE_PORT Port 

This command selects the port that the PNE will use to 

communicate to the printer. 

The valid ports are “DISABLE”, “ETHERNET”, or “USB”. 

NOTE: If ETHERNET is selected but not enabled, the 

selection will revert to DISABLE. 

PNE_PORT_NUM Port Number 

This command sets the Ethernet Port the PNE uses to 

communicate if the PNE Port was set to Ethernet.  

NOTE: This causes the printer to automatically reboot. 

POWERUP Cfg 

Sets the power-up configuration to Cfg and loads 

Configuration Cfg. Cfg can be any value from 0-8, where 

0=Factory. 

PRINT Cfg 

Print Configuration Cfg. Cfg can be a number 1-8, or one of 

four pre-defined configurations. The four non-numeric 

configurations are requested using the first character for the 

CURRENT, FACTORY, POWERUP, or ALL configuration(s). 

PXML_PORT_NUM Port Number 

This command sets the Ethernet Port the PXML and UCP will 

use to communicate if the PXML Port is set to Ethernet.  

NOTE: This causes the printer to automatically reboot. 

RESET  Reboots the printer. 

SAVE Cfg 

Cfg must be 1-8. This command will save the current 

configuration as configuration Cfg. If Cfg is not in the range of 

1-8, the command is ignored. 
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Action Parameter Description 

SETMENU Value;Tag 

Tag is the name of the menu as defined in the menu file. Value 

is the value to which the menu is to be set. This function should 

be used with great caution as setting an invalid Value could 

make the printer non-functional. 

GETMENU 

Port 

Tag1 

… 

TagN 

This command uploads a set of menu values to the location 

Port. Port must either be “1284”, “SERIAL”, “USB”, or 

“ETHERNET”. Following a line terminator (e.g., CR+LF), a 

series of Tags can be listed (each separated by a line 

terminator) with CONFIG-GETMENU;END marking the end. 

See the example later in this Section. 

SET_NAME Cfg 
This command downloads a name for the configuration 

specified by Cfg. Cfg must be 1-8. 

UPLOAD 

Port;Cfg 

or 

FILE;Name;Cfg 

This command uploads the configuration stored in location 

Cfg to the port specified by Port. Port must either be “1284”, 

“SERIAL”, “USB”, or “ETHERNET”. Cfg may be 1-8 or ALL. 

Alternatively, “FILE” followed by a filename NAME can be 

used to store the configuration into a file. 

NETINFO ETHERNET 

This command will get network information from the printer 

regarding TCP services. The output will show a list of network 

protocols and whether the given protocol is enabled or 

disabled. 

PORTINFO ETHERNET This command returns the TCP/UDP port numbers assigned 

to TCP services supported by the printer. 

HOSTINFO ETHERNET 
This command provides information on Host I/O. Mainly 

whether USB, PNE, and printer management are 

enabled/disabled. 

 

Configuration Upload / Download 

The UPLOAD and DOWNLOAD command can be used for uploading and downloading complete printer 
configurations. If a customer needs to configure 50 printers identically, the customer needs only configure 
one printer and UPLOAD the configurations. The configurations uploaded may then be sent to other 
printers as jobs eliminating the necessity for the operator to configure each printer manually. 

The UPLOAD command will always place a header and footer into the uploaded data. This header will be 
the DOWNLOAD command followed by the configuration number. The footer will be the DOWNLOAD END 
command. The operator should be aware that the UPLOAD and DOWNLOAD commands use a 
secondary copy of the menu structure which does not affect the printer's active configuration. This allows 
the UPLOAD and DOWNLOAD commands to operate without affecting the printer's current configuration.  

If the operator intends to use one of the configurations after downloading, the operator should reboot the 
printer to ensure proper operation. This can be accomplished by adding the RESET command as the last 
command in your setup file. This is necessary because the printer caches the active configuration. 
Rebooting the printer ensures that the desired configuration is correctly read from FLASH. 
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NOTE:  While an upload or download is in progress, the Front Panel will be unavailable. 

INFO Return Status 

The INFO command returns a collective set of the information about the printer state in the following 
format: 

 

!PTX_SETUP 

CONFIG-INFO 

RTC;<HOUR:MIN:SEC DAY-MONTH-YEAR> 

MODEL;<Model Name> 

PROGRAM VERSION;<Program File Version> 

PROGRAM FILE; <Program File Number> 

SERIAL NUMBER;<Serial Number of Printer> 

DPI;<203, 300, or 600> 

RFID;<1=Present, 0=Not Installed> 

ODV;<1=Present, 0=Not Installed> 

GPIO;<1=Present, 0=Not Installed> 

PTX_END 

 

GETMENU Command and Return Data 

The GETMENU command is formed to allow the user to name a set of menus to be returned back to the 
host system per the following format example, sending the results back through the host network: 

 

!PTX_SETUP 

CONFIG-GETMENU;ETHERNET 

igpswitch 

serbaud 

CONFIG-GETMENU;END 

PTX_END 

 

The results coming back through the network host would look something like this: 
 

!PTX_SETUP 

CONFIG-GETMENU 

igpswitch;2 

serbaud;3 

CONFIG-GETMENU;END 

PTX_END 

FILE_IO Commands 
!PTX_SETUP 

FILE_IO–Action;Parameter 

PTX_END 
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Table 28. PTX_SETUP FILE_IO Commands 

Action Parameter Description 

CAPTURE Filename 

When Filename is provided, this begins capturing all incoming 

data into given Filename. This file will be targeted for the 

DRIVE (see below) supplied. 

When all data to be captured has been received, this same 

command should be sent without the Filename parameter to 

terminate the capture process and commit the data to a 

specified drive. 

CERTTYPE Filename;Type 

When a Network Certificate file is downloaded using the 

FILE_IO CAPTURE. The certificate type will be set. The 

types available are: 

 MQTT 
 MC - CA Certificate 
 PC - Printer Certificate 
 PK - Private Key 
 FS - File Store 
 
 802.1x  
 SP - Printer Certificate 
 SK - Private Key 
 SC - CA Certificate 

 
DEL Filename The DEL action will mark Filename as deleted. 

DRIVE Letter 

The drive letter chooses between the Flash File System, SD 

Card, or USB drive (if available). No drive letter or the drive 

letter A selects the Flash File System. The drive letter B 

selects the SD card, letter D selects the USB drive if available. 

DUMPFILE 
File;Prop; 

Size 

When File is provided, space is reserved based on the Size 

parameter. The parameter PROPS is the four-byte value that 

specifies the file properties. 

When all data to be captured has been received, this same 

command should be sent without the parameters to terminate 

the capture process and commit the data to the original File. 

OPTIMIZE  
Causes the printer to optimize the Flash File System. The 

printer automatically reboots during this process. 

PROPS File;Prop 

The PROPS action will set the file properties of a given file. 

The file properties are a four letter, case sensitive file 

descriptor. The properties field can be used to ensure that a 

file is used for its intended purpose. Once properties have 

been associated with a file, they cannot be changed. 
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Action Parameter Description 

RUNFILE File;Prop 

The RUNFILE action will open the file named File for printing. 

After the PTX_END command is processed, the contents of 

File will get printed before any more data is read from the 

host. If the Prop field is present, RUNFILE will verify that Prop 

matches the saved file properties. Any mismatch will cause 

the command to be ignored. 

UPLOAD File;Port 

Reads the file named File out of the flash file system and 

sends it to a host computer via the Port I/O port. Port is either 

“1284”, “SERIAL”, “USB”, or “ETHERNET”. 

 

When a file is opened for writing with the FILE_IO–CAPTURE;Filename command, the system will allocate 
RAM for file control blocks as needed. If the file already exists on the Flash File System and the System > 
Flash File Edit > Overwrite Files menu is set to disable, a warning will be displayed on the front panel. After 
clearing the warning, the file data will be printed. To overwrite the existing file, set the Overwrite Files option 
to enable. 

Due to the nature of writing files, the data is first stored into RAM. As a result, the printer must have 
sufficient available RAM. If the printer is not able to allocate enough RAM, a warning will be displayed on the 
front panel.  

None of the captured file data will be committed to flash until the entire file is loaded and the terminating 
command “FILE_IO–CAPTURE” is received. Receipt of the command will cause all file data to be written 
to the drive targeted with the “FILE_IO-DRIVE” command. Any errors with this process will result in a front 
panel warning message. 

Example to store file “Test.bmp” to Flash: 
 

!PTX_SETUP 

FILE_IO–DRIVE;A 

FILE_IO–CAPTURE;Test.bmp 

PTX_END 

<data> 

<data> 

<data> 

!PTX_SETUP 

FILE_IO–CAPTURE 

PTX_END 

 

NOTE:  Lack of available flash memory might be due to files that have been deleted but the flash 

space has not been reclaimed. Such flash can be reclaimed by using the System > Flash File 

Edit > Optimize & Reboot function. 

NOTE:  After selecting the Optimize & Reboot function, do not shut off the printer's power until after 

the printer returns to the power-on state. Loss of power during the optimize process may 

corrupt the printer's program. If this occurs, first attempt to repeat the downloading process. If 

that fails, contact an authorized service representative. 



 

Page | 272 
 

ENGINE Commands 
!PTX_SETUP 

ENGINE–Action;Parameter 

PTX_END 
 

Table 29. PTX_SETUP ENGINE Commands 

Action Parameter Description 

ALM_WIDE wide width 

Set the Auto Label Mapping wide width (units of 

1/1000”; e.g., a wide width value of 1000 = 1”), which 

represents the width of the image in the file sent from 

the host which is to be auto label mapped into several 

labels, each of which will have a width of narrow width. 

 

#labels = wide width/narrow width (rounded down) 

ALM_NARROW narrow width 

Set the Auto Label Mapping narrow width, which 

represents the width of one auto mapped label (in units 

of 1/1000”; e.g., a narrow width value of 1000 = 1”).  

This width should be set prior to the wide width. In 

addition, it can never exceed the physical width of the 

printer. If it does, the narrow width will be automatically 

reduced to the Media > Image > Label Width value set 

in the configuration menu. 

ALM_ENABLE 

N 

W 

* 

Set Auto Label Mapping to Narrow, Wide, or Off. Enter 

“N” for Narrow, “W” for Wide, or any other letter to 

disable ALM. By default, only the Narrow option is 

implemented. 

EJECT  Performs a Form Feed. 

IMAGE_SHFT_H Value 

Shifts the image Value horizontally in 1/1000” units. If 

Value is out of range with the panel menu Media > 

Image > Horizontal Shift , the command will be 

ignored. 

IMAGE_SHFT_V Value 

Shifts the image Value vertically in 1/1000” units. If 

Value is out of range with the panel menu Media > 

Image > Vertical Shift , the command will be ignored. 

LENGTH Value 
Sets the Media > Image > Label Length using 1/1000” 

units. 

MEDIA_HANDLING Value 

Sets the type of media handling:  

0 - Continuous 

1 - Tear-Off Strip  

2 - Tear-Off (Not Available on T800/T4000) 

3 - Peel-Off 
4 - Cut 

MIRROR Value 
Value of 0 turns mirroring off, non-zero turns mirroring 

on. 
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Action Parameter Description 

MODE 
X 

D 

Parameter “X” sets the print mode to Thermal Transfer, 

parameter “D” sets to Direct Thermal. 

ODV 1 
Enables the ODV unit so that ODV begins verifying 

printed barcodes. 

OVERSTRIKE 0 

Requests the printer to back up one form (as defined 

by the Form Length) and then print out an overstrike 

pattern.  

This command should only be used if the Validator > 

Control > Validator Action is set to Retry Form. 

WIDTH Value 
Sets the Media > Image > Label Width using 1/1000” 

units. 

 

RFID Commands 
!PTX_SETUP 

RFID–Action;Parameter 

PTX_END 

 

NOTE on Action EPC_LENGTH: 

Extreme caution should be used when utilizing this command. In normal circumstances, calibrating tags 
requires only using the “Run Calibration” menu. When tags are calibrated, the maximum sizes of the various 
RFID banks (including the EPC bank) are automatically set based on the silicon type detected. The values 
determined by the calibration should not be changed. Emulation commands can read or write any EPC 
length that is less than or equal to the maximum EPC length without changing this value.  

There is only one circumstance where a user might want to set this value: if during calibration a warning 
message is displayed on the control panel that the silicon type was not recognized, the maximum EPC length 
can be manually set with this command if known. If the silicon type in the tags being used does not support 
a length as long as the maximum length set by this command, all subsequent read and write tag operations 
will fail. 

Table 30. PTX_SETUP RFID Commands 

Action Parameter Description 

EPC_LENGTH Bit Length 
Sets the maximum length of the EPC bank in 

bits. 

OVERSTRIKE_REPORT ON or OFF 
Enables/disables reporting of RFID overstrikes 

to the host. The default is OFF (disabled). 

STATISTICS_REPORT ON or OFF 
Enables/disables reporting of RFID statistics to 

the host. The default is OFF (disabled). 

STATISTICS_CLEAR  Clears the RFID statistics. 
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Action Parameter Description 

GET_STATISTICS  
Returns the RFID statistics values as shown in 

a following example later in this section. 

RFID_CAL  

Executes the RFID calibration procedure. This 

will take a few minutes. After the calibration 

completes, information is returned in the same 

format as with RFID_LASTCAL. 

RFID_LASTCAL  

Return information about the last RFID 

calibration in the form shown in the section 

below. 

GET_CALINFO  

Return expanded information about the last 

RFID calibration in the form shown in the 

section below. This command returns all of the 

same information as returned by 

RFID_LASTCAL in addition to some extra 

pieces of information about the calibration 

results, including the currently chosen 

operation order. 

SET_OPORDER 
RFID_DURING_PRINT, 
RFID_BEFORE_PRINT, 
or RFID_AFTER_PRINT 

Sets the Operation Order in the RFID 

Calibration Params menu to Encode Before 

Print, Encode During Print, or Encode After 

Print. No all operation orders are legal for all 

tag types. If an operation order is not legal for 

the currently calibrated tag type, the setting will 

be ignored. Success in changing the setting 

can be confirmed with the GET_CALINFO 

command. 

SET_LABELRETRY Number of Retries 

Sets the number of retries in the “Label Retry” 

menu. This number represents the number of 

successive tags that will be overstruck due to 

failed RFID operations before a fault is 

declared on the control panel 

SET_ERRHANDLE 
RFID_ERR_NONE, 

RFID_ERR_STOP, or 
RFID_OVERSTRIKE 

Changes the value of the “Error Handling” 

RFID menu to None, Stop, or Overstrike mode. 

GET_RFIDCONTROL  

Returns information about items in the RFID 

control menu including the number of retries 

and the RFID error handling mode. It returns 

information in the form shown in the section 

below. 

 
The GET_STATISTICS information that is returned to the host is with this format: 
 

!PTX_SETUP 
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RFID-GET_STATISTICS 

TID;<TID> 

RFID TAGS PASSED;<Number of Tags with all RFID Passed> 

WRITE TAGS FAIL;<Number of Tags Failed Due To Write Operation> 

READ TAGS FAIL;<Number of Tags Failed Due To Read Operation> 

LOCK TAGS FAIL;< Number of Tags Failed Due To Lock Operation> 

PTX_END 

 
The RFID_LASTCAL information that is returned to the host is with this format: 

 

!PTX_SETUP 

RFID_LASTCAL-INFO 

TID;<TID> 

FORM LENGTH;<xx.yy inches> 

POSITION;<xx.yy inches> 

WRITE POWER;<Power Setting> 

READ POWER;<Power Setting> 

PTX_END 

 

The GET_CALINFO information that is returned to the host is with this format: 

 

!PTX_SETUP 

RFID-GET_CALINFO 

TID;<TID> 

POSITION;<xx.yy inches> 

BASE POS;<xx.yy inches> 

READ POWER;<Power Setting> 

WRITE POWER;<Power Setting> 

ANTENNA;<0 for external antenna and 1 for internal antenna> 

TID;<TID that identifies silicon in calibrated tags> 

USR SIZE;<Size of USR Bank on calibrated tags> 

EPC SIZE;<Size of EPC Bank on calibrated tags> 

OPERATION ORDER;<Operation Order> 

PTX_END 

 
The GET_STATISTICS information that is returned to the host is with this format: 
 

!PTX_SETUP 

RFID-GET_RFIDCONTROL 

ERROR HANDLING;<RFID Error Handling Mode> 

LABEL RETRY;<Number of Label Retries> 

PTX_END 
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ODV-2D Commands 
!PTX_SETUP 

ODV–Action;Parameter 

PTX_END 

Table 31 PTX_SETUP Commands for ODV-2D 

Action Parameter Description 

GRAPHICS 
ON or 1 

OFF or 0 

When enabled, search graphics within the job for 
barcodes. Otherwise, ignore the graphics and only 
process the barcode command from the emulations. 

ORIENT 

ALL 

PICKET 

LADDER 

Choose the orientations of the barcodes to process. 

SKIP 

0 = OFF 

1-9999 = # 

> 9999 = ON 

Skip a certain number of labels from ODV2D 

processing. If zero, no labels will be skipped (ignored). 

If 1-9999, this number of labels will be skipped. 

Numbers > 9999 will result in indefinite skipping of 

labels. 

CODE39 
ON or 1 

OFF or 0 

When enabled, Code 39 barcodes will be processed. 

Otherwise, they will be ignored on the label. 

CODE128 
ON or 1 

OFF or 0 

When enabled, Code 128 barcodes will be processed. 

Otherwise, they will be ignored on the label. 

INT2/5 
ON or 1 

OFF or 0 

When enabled, Interleaved 2/5 barcodes will be 

processed. Otherwise, they will be ignored on the label. 

CODE93 
ON or 1 

OFF or 0 

When enabled, Code 93 barcodes will be processed. 

Otherwise, they will be ignored on the label. 

CODABAR 
ON or 1 

OFF or 0 

When enabled, Codabar barcodes will be processed. 

Otherwise, they will be ignored on the label. 

UPC/EAN 
ON or 1 

OFF or 0 

When enabled, UPC and EAN barcodes will be 

processed. Otherwise, they will be ignored on the label. 

PDF417 
ON or 1 

OFF or 0 

When enabled, PDF417 barcodes will be processed. 

Otherwise, they will be ignored on the label. 

MICRO417 (FUTURE) 
ON or 1 

OFF or 0 

When enabled, Micro PDF417 barcodes will be 

processed. Otherwise, they will be ignored on the label.  

DATAMATRIX 
ON or 1 

OFF or 0 

When enabled, Data Matrix barcodes will be 

processed. Otherwise, they will be ignored on the label. 

QR 
ON or 1 

OFF or 0 

When enabled, QR barcodes will be processed. 

Otherwise, they will be ignored on the label. 
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Action Parameter Description 

AZTEC (FUTURE) 
ON or 1 

OFF or 0 

When enabled, Aztec barcodes will be processed. 

Otherwise, they will be ignored on the label. 

ZONE 

SYMB; 

X1;Y1 

X2;Y2 

ROT;MIN 

ROW;COL 

Allows a barcode that is pre-printed on the label to be 

included for the ODV-2D to validate. The parameters 

are as follows: 

SYMB = Symbology (same strings as used in the 

Action list above) 

X1;Y1 = Upper left-hand corner in 1/1000 inches. 

X2;Y2 = Lower right-hand corner in 1/1000 inches. 

ROT = “NOR”, “CCW”, “CW”, or “INV” 

MIN = Minimum bar size in 1/1000” inches 

ROW = Data Matrix rows 

COL = Data Matrix columns 

 

Miscellaneous Commands 

LP MODE Commands 

!PTX_SETUP 

LPMODE;Parameter 

PTX_END 

 

Action Parameter Description 

n/a Protocol 

Protocol must be 0-4. This command resets the 

software protocol, and is selected as follows:  

0 - P-Series 

1 - P-Series XQ  

2 - Serial Matrix 

3 - Proprinter III XL 

4 - Epson FX-1050 

 

NIC_SETUP Commands 

!PTX_SETUP 

NIC_SETUP 

<NIC setup command> 

<NIC setup command> 

<NIC setup command> 

END_NIC_SETUP 

PTX_END 
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NIC setup is for advanced users only and requires using commands as described in the Ethernet User’s 
Manual. Here is an example below: 

 
!PTX_SETUP 

NIC_SETUP 

store net tcp opts -zeroiparp 

store ifc from default 

store ifc 2 wlan ssid ap1231_vl1_open 

store pping opts enable 

store pping packet 2 

store pping period 2 

END_NIC_SETUP 

PTX_END 

 

GPIO Commands 

!PTX_SETUP 

GPIO–Action;Parameter 

PTX_END 

 

Action Parameter Description 

EVENT Value 
Triggers a GPIO event by the Value given. Valid 

event numbers range from 0-65535. 

 

PRINTJOB Commands 

!PTX_SETUP 

PRINTJOB–Action;Parameter 

PTX_END 

 

Action Parameter Description 

START jobID 

Start of job marker. Results in a “start of job” message 

sent back to host through the PPM port when a job 

starts printing. 

END jobID 

End of job marker. Results in a “end of job” message 

sent back to host through the PPM port when the job 

finishes printing. 
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G Quick Change Memory Card 

(QCMC) 

Overview 
The QCMC provides the ability to duplicate an entire printer’s firmware, saved configurations, and 

custom files quickly through the printer’s control panel with a user friendly interface. No external host or 

files are needed to transfer this information to the QCMC. A “snapshot image” is saved of the printer’s 

firmware, configuration settings, and custom files. The saved image can be copied to any number of 

printers using the same QCMC so that the printers will be identically configured (assumes same printer 

hardware and options are present). 

The QCMC has its own resident network MAC address that will be used in place of the printer’s 

LAN/WLAN MAC address when the card is left installed in a printer. This allows a mission critical printer 

to be exchanged quickly with a spare printer that will be identically configured, including the network 

MAC address. 

The following are examples of how the QCMC may make printer management more convenient: 

• A site has 10 printers to install that should all be configured identically. Rather than inputting the 
information through the control panel individually to each printer, insert the QCMC into the first 
printer, capture the changes, and then easily share the image with the other nine printers. 

• A site is adding additional printers and wants them configured the same as the printers already 
installed, but is unsure what changes were originally made. By using the QCMC to capture the 
exact image of the older printers, no custom settings will be missed. 

• A printer is set up on a network that is configured to only allow recognized MAC addresses to 
access the network. If the printer with the QCMC installed needs repair and must be removed 
from the network, the MAC that resides on the QCMC can be easily transferred to the 
replacement printer, along with all the configuration information and any other files stored as the 
“snapshot image” on the QCMC, making the replacement printer an exact duplicate for the 
downed printer. By using the MAC address that resides on the QCMC, the replacement printer 
can be installed without notifying the network administrator, thereby simplifying the exchange. 
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Installing the QCMC 
CAUTION You must power off the printer before you install or remove the QCMC, or you 

may damage the QCMC and the printer. If you remove the QCMC after powering 

on the printer with the QCMC installed, the fault message “SD REMOVED 

Reboot Printer” will display. You cannot clear this message by reinserting the 

QCMC. You must cycle power. 

1. Set the printer power switch to O (Off). 

2. Insert the QCMC SD card into the QCMC slot on the back of the printer. 
 
 

 
 
 
 
 
 

Figure 16 QCMC Slot on Back of Printer 

Saving the Printer’s Configuration to the QCMC 
 

 

NOTE:  The MAC address residing on the QCMC will be used in place of the MAC assigned to the 

printer’s own network card whenever the QCMC is installed. If you do not want to identify the 

printer with this MAC address, make sure the QCMC is removed from the printer before 

attaching the printer to the network. 

When the printer software detects the presence of a QCMC at power-up, a check of the QCMC will be 
performed to determine if there is already a saved flash image available. If no printer flash image exists on 
the QCMC, the software will then check to see if there are any saved configurations in the printer. If the 
QCMC is blank (no flash image) and saved configurations are detected in the printer, then the user will be 
prompted with a message on the front panel to save the printer’s configuration to the QCMC as shown 
below. 
 

QCMC Slot 
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NOTE:  This screen will appear every time at power-up until the printer’s flash is saved to the QCMC. 

If the RIGHT ARROW key is pressed, the printer will reboot into normal operation and not save any 
information to the QCMC. On subsequent power-ups the Save message, shown above, will display again. 

When the ENTER key is pressed, the printer will not go ONLINE, but instead will copy the printer’s entire 
flash image to the QCMC, creating a snapshot of the printer’s memory. 

Below is a list of items that will be saved to the QCMC: 

• Printer Program File (software) 

• Custom configurations (1–8) 

• Feature files or CST’s that have been downloaded on the printer. 

• All variable settings from the printer’s NVRAM 

• Network settings including IP Address 

• Other user files, such as fonts, bitmaps, or graphics files downloaded to the printer. 

While the printer is saving its QCMC settings to the SD card, the following message will display. This could 
take a few minutes to complete.  
 

 
 

WARNING During this process, do not turn off the power. The time it takes to complete 

the process depends on the amount of information in flash and may take 

longer when large user files are included. 

Upon successful completion of saving a flash image to the QCMC, the printer will display a message 
indicating the operation is complete as shown in the following figure. The printer will then reboot into 
normal operation. 
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In the unlikely case there is not enough space on the SD to save the entire flash image, you will be 
prompted with a message “NOT ENOUGH SPACE ON SD / Delete SD File”. This is a fatal error and 
requires user intervention: 

• Cycle power on the printer.  

• When prompted to save the QCMC select the RIGHT ARROW key to skip. The printer will then 
boot normally and go ONLINE. 

• Go OFFLINE and find the System > SD File Edit > Delete SD Files menu.  

• Delete unnecessary SD files then try the QCMC Save operation again. 

Copying the QCMC “Snapshot” Image to a Second Printer 
Always power off the printer before removing or inserting the QCMC. Place the QCMC into the second 
printer’s memory slot. Upon power up, the printer software detects the presence of a QCMC and a check 
of the QCMC will be performed to determine if there is already a saved flash image from this QCMC on 
the printer. If no, the following screen will display: 
 

 

 

NOTE:  This message will appear every time at power-up until the QCMC settings are copied to the 

printer. 

If the RIGHT ARROW key is pressed, the printer will reboot into normal operation and not copy any 
information to the printer. On subsequent power-ups the Copy message above will display again if the 
QCMC remains installed in the printer. 

IMPORTANT: If the QCMC remains installed in the printer, the MAC address onboard will be 

used in place of the resident MAC address to the printer’s LAN/WAN interface 

card. 

When the ENTER key is pressed, the printer will not go ONLINE immediately, but will copy the contents of 
the QCMC to the flash memory, creating a clone of the original printer. Before the copy process is allowed 
to continue, the printer hardware will be checked. If the printer hardware is incompatible with the QCMC 
contents, the screen shown below will be displayed, and the printer will not copy any settings. 
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This means that the QCMC is not compatible with the printer’s software or hardware. A software upgrade 
is required, or a different configured QCMC will be needed. 

A QCMC validation check will also be performed to ensure the data stored on the SD is not corrupted. If 
the test fails the following fault message will display.  
 

 

This means that the data on the QCMC was not saved properly, and must be deleted then resaved. 
Follow the instructions for deleting files, and then repeat the copying process. 

If all the checks pass, then the printer will copy the files from the QCMC to the target printer. While this 
copy is in progress, the following message will be displayed. 
 

 

Upon successful completion, the printer will display the following message on the front panel and reboot 
into normal operation. 
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IMPORTANT: When the copy is completed and the printer reboots, the user should run auto-

calibration to make sure the configuration changes are used in the calibration 

process. 

Updating the QCMC Image 
This option should only be used when a QCMC image has previously been stored from the target printer. 
If some configuration settings have been altered from that point, the menu System > SD File Edit > 
QCMC Update can be used to update the configuration settings in the image stored on the QCMC. 

Below is a list of items that will be updated on the QCMC by the QCMC Update operation: 

• Custom configurations (1–8) 

• All variable settings from the printer’s NVRAM 

• Network settings including IP Address 

Below is a list of items that will NOT be updated on the QCMC by the QCMC Update operation: 

• Printer Program File (software) 

• Feature files or CST’s that have been downloaded on the printer. 

• Other user files, such as fonts, bitmaps, or graphics files downloaded to the printer. 

While the printer is updating the QCMC configuration, the following message will display. 
 

 
 

WARNING During this process, do not turn off the power.  

Upon successful completion of saving a flash image to the QCMC, the printer will display a message 
indicating the operation is complete. The printer will then reboot into normal operation. 
 

Erasing the QCMC Image 
This option should only be used when a QCMC has already been stored and when the user desires to 
start fresh with a new image. 

To utilize this option, navigate to the menu System > SD File Edit > QCMC Erase and press the ENTER 
key. When this option is activated, all QCMC files and configurations will be deleted from the SD card. 

While the printer is erasing the QCMC configuration, the following message will display. This could take 
several minutes. 
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WARNING During this process, do not turn off the power.  

Upon successful completion of saving a flash image to the QCMC, the printer will display a message 
indicating the operation is complete. The printer will then reboot into normal operation. 



 

Page | 286 
 

H Custom Configuration 

Module (CCM) 

Overview 
You can make a standard SD card or USB drive into a Custom Configuration Module (CCM) that can 

be used to configure an unlimited number of printers one at a time. The programmed CCM can contain 

any combination of printer firmware (program file), a feature file, a CST, downloadable fonts and forms, 

NIC configurations, customer files, and PTX_SETUP config files. 

The CCM is made using the PSA File Utility to create a set of configuration files (CCMLOAD.xxx, 

CCMHOST.000) that are copied onto an SD card or USB drive. Once the CCM Package of files is copied, 

the SD card or USB drive can be used to identically configure an unlimited number of printers (one by 

one). The list of files that can be loaded onto a CCM are shown in the table below: 

 

 Content Max Files Headers File Origin 

Program File * 1 Y Printronix Firmware (e.g., P300768.exe) 

Feature File 1 Y Printronix Feature File (e.g., P300774.exe) 

CST File 1 Y PNE Suite CST Manager 

GPIO File 1 Y PNE Suite GPIO Manager 

Fonts 25 Y TrueTypes or Intellifonts 

File System 25 Y Custom Files, Logos, Forms 

Network Config 1 N Telnet Commands to setup Network 

Emulation Setup 25 N Emulation Commands for Initialization 

Printer Config 1 N PTX_SETUP config file via PNE Suite 

* A program file is always required for a valid CCM. See CCM Content Description for complete details. 

Creating a CCM Package 
Creating a CCM Package is easy using the PSA File Utility which is available on our company’s website. 

Run the PSA File Utility and then execute the Custom Config Module section as follows: 

 

This will bring up a Create CCM dialog window. From there, highlight items in the list with the left mouse 
button and use the right mouse button to choose an option: 
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Some customizations will only allow one selection, while others will allow multiple selections. In the case 
that an (.exe) is selected for the Program or Feature File, the user will be prompted to have the files 
executed (unzipped) prior to adding them to the customization file. 

For Fonts and File System selections, the customization file requires a download header. If the selected 
file does not contain a download header and it is required, the user will be prompted to add one. For other 
cases like the CST and GPIO files, those headers are create ONLY by the PNE Suite and any attempt to 
include files that do not contain proper headers will be rejected. See CCM Content Description below for 
complete details. 

Once the CCM content tree is complete, the Create button asks the user to choose a directory to store the 
configuration package. This directory can be the target SD card or USB drive or another directory. The 
configuration files created (CCMHOST.000 and CCMLOAD.000-CCMLOAD.xxx) must all be copied onto 
the target SD card or USB drive before use.  

IMPORTANT When creating the new CCM Package, any existing CCM files (CCMHOST.000 and 
CCMLOAD.000-CCMLOAD.xxx) in that directory will be deleted. 

Configuring Printers 
CAUTION You must power off the printer before you install or remove the SD card or USB drive.  

Do not remove the SD card or USB drive until prompted by the printer when the CCM 

update has been completed. 

1. Set the printer power switch to O (Off). 

2. Insert the SD card or USB drive with the CCM file package into the printer. 

3. Hold down the UP arrow key. 

4. Turn the printer power on and release the UP arrow key when you hear a beep or see the LEDs flash. 

5. After the printer powers-up, the following message will be displayed on the front panel: 
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NOTE:  If the printer reports the CCM is empty, then it could not find the CCMLOAD.xxx files on the SD 

card or USB drive. Turn off the printer and check the contents of the SD card or USB drive. 

Also make sure the SD card or USB drive are properly inserted. 

6. When the ENTER key is pressed, the printer will start the configuration process.  

IMPORTANT  Do NOT power off the printer until the process is complete. This may require an additional 
1-2 reboots depending on the content.  

7. When the process completes the printer will display one of the following messages on the front panel: 

      

NOTE:  The printer may reboot during the configuration process, this is normal. Do NOT interrupt the 

printer until it displays one of the messages above. 

 

8. Turn off the printer and remove the CCM.  This process can be repeated on any number of printers. 

 

Printer Firmware Compatibility 
A CCM can be created for use on Printronix Auto ID T800 printer. If you are using older printer code (see 
list below), you can create a CCM using only an SD card. Newer printer code supports either an SD card 
or USB CCM. 
 
Firmware revisions below this level only support SD card – newer revisions support both 
FILE,PRGM,PTX,T800,CMB-MGL V1.20D  P301002 
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CCM Content Description 

Program File and Feature File 
Program Files and Feature Files are created by Printronix and have part numbers starting with P3 (e.g., 

P300998). These files are provided as a zipped (.exe) file that can be executed on a Windows Command 

shell or linux shell (unzip XXXXX.exe). This will extract either a program file (.prg) or a feature file (.fls, 

.dwn) which contains the headers necessary to store the information into the printer when in download 

mode.  

The PSA File Utility will accept either the extracted file or the (.exe) directly as input. If the (.exe) is 

provided, the CCM feature will perform the extraction for the user. 

The most recent printer firmware releases can be found on our company’s website. 

CST and GPIO Files 
CST and GPIO files are created within the PrintNet Enterprise Suite available at no cost from our 

company’s website. The PNE Suite has two utilities called the CST Manager and GPIO Manager, 

respectively that can save the files with all the necessary headers. The CST Manager saves files as 

(.bnd) and the GPIO Manager as (.gpf). 

 

Fonts and File System 
As the table shows, some files require headers. The headers are a 256-byte prefix with information on 

how/where to store the data within the printer file system. For Font and Template selections the 256-byte 

header (if not already present) can be added separately with the PSA File Utility or at the time when the 

raw files are included within the CCM. Users will be prompted to create the headers automatically if the 

files supplied do not have headers. Up to 25 (each) files can be added. 

PGL Forms and Logos 

Storing PGL forms or logos using this method can be tricky because the data stored in the File System 

for a PGL logo or form is not the same content as when these items were originally sent to the printer 

using the ;DISK parameter. Forms and Logos loaded using this method must have 256-byte headers 

that apply *.frm (forms) or *.lgo (logos). Furthermore, the content cannot include the ;DISK parameter. 

The recommended method of loading PGL forms and logos are using the Emulation Setup section. 

Network Config File 
The Network Config is a series of PrintNet internal command shell (npsh) commands explained in the 

PrintNet Ethernet User’s Manual available from our company’s website. The internal commands must be 

wrapped within a PTX_SETUP construct as shown below: 
 

!PTX_SETUP 

NIC_SETUP 

store net tcp opts -zeroiparp 

store ifc from default 

store ifc 2 wlan ssid ap1231_vl1_open 

store pping opts enable 

store pping packet 2 

store pping period 2 

END_NIC_SETUP 

PTX_END 

 

This file is created manually by the user and typically stored with an extension (.ncg) to easily identify its 

purpose. It is the responsibility of the user to verify the content is correct. 
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WARNING: Be sure the NIC Config File does not contain a “reset” command. This would prematurely 

force a reboot and the CCM functionality may not work properly. 

Emulation Setup 
Emulation Setup files do not require headers. They are optional and interpreted by the emulations when 

the CCM Package is installed. The order of these files added determines the order by which the 

emulations will receive and interpret them. This type of file might be useful in order to run a job that stores 

emulation forms and logos into the flash file system, so they are available at power-up.  

For example, a PCX or TIFF logo could be converted to a PGL logo to be stored in Flash using the 

Actions > PGL Logo Header function in the PSA File Utility. That resulting file could then be added to 

this section to download the logo to Flash memory. Similarly, a PGL form with the CREATE command 

and ;DISK parameter could be added to store that PGL form into Flash memory.  

This emulation commands should not include anything that prints data because this is specifically for 

setup purposes. Furthermore, because the printer configuration has not yet been configured, the 

emulation commands MUST be consistent with the Factory default configuration (e.g., PGL as the Active 

IGP Emulation). 

PTX_SETUP Printer Config 
The Printer Config is an optional part of the CCM Package to be used to store configuration and setup the 
power-up configuration setting. The configuration is in the form of a PTX_SETUP file that is best generated 
by PNE Suite to accurately represent the entire configuration, using internal menu identifiers.  

If the configuration setup is consistent with the Factory, then this content can be omitted. The steps to 
create a Printer Config are the following: 

1. Load a target printer with the Program File firmware to be used with the CCM. 

2. Start PNE Suite. 

3. Use the Configuration Editor to upload the configuration from the printer. 

4. Modify the Configuration as needed with the Configuration Editor. 

5. Save the Configuration as a PTX_SETUP file (.ptx). 
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I Customer Support 

Printronix Customer Support Center 
 

IMPORTANT Please have the following information available prior to calling the Printronix 

Customer Support Center: 

• Model number 

• Serial number (located on the back of the printer) 

• Installed options (i.e., interface and host type if applicable to the problem) 

• Configuration printout. 

• Is the problem with a new install or an existing printer? 

• Description of the problem (be specific) 

• Good and bad pictures that clearly show the problem (faxing or emailing of 

these samples may be required) 

 

 

Americas (844) 307-7120 
Service@PrintronixAutoID.com 

Europe, Middle East, and Africa +31 24 3030340 

EMEA_support@PrintronixAutoID.com 

Asia Pacific +886 3 990 6155 
APAC_support@PrintronixAutoID.com 

China +86 755 2398 0479 
CHINA_support@PrintronixAutoID.com 

 

 

Printronix Auto ID Support: https://usca.tscprinters.com/en/technical-support    

 
 
  

https://usca.tscprinters.com/en/technical-support
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Corporate Offices 

Printronix Auto ID 

3040 Saturn Street, Suite 200 

Brea, CA 92821  

U.S.A. 

 
Phone:  (844) 307-7120 

Fax:  (657) 258-0817 

 

Printronix Auto ID, EMEA Head Office  

Georg-Wimmer-Ring 8b D-85604    

Zorneding, Germany 

 

Phone:  +49 (0) 8106 37979-000 

E-Mail: EMEA_Sales@PrintronixAutoID.com 

 

Printronix Auto ID, Asia Pacific Head Office 

Taiwan  

9F, No. 95, Minquan Rd. 
Xindian Dist.,  New Taipei City  
231 Taiwan (R.O.C) 

 
Phone: +886 3 990 6155 

Fax:  +886 3 990 6215 

 

Printronix Auto ID, China Head Office 

Shenzhen  

New World Center 2510 room  

No. 6009,  Yitian road 

Futian District,  Shenzhen 

518000  

China 

Phone:  +86 755 2398 0479 

Fax:  +86 755 2398 0773 
 

Visit the Printronix Auto ID website at https://usca.tscprinters.com/en/printronix-auto-id-
enterprise-printers 

  

mailto:EMEA_Sales@PrintronixAutoID.com
https://usca.tscprinters.com/en/printronix-auto-id-enterprise-printers
https://usca.tscprinters.com/en/printronix-auto-id-enterprise-printers
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J Glossary 

 

Baud (rate) Baud Rate is the number of information bits that can be 
transmitted between the printer and the computer in one 
second. For example, one baud equals one bit per 
second in a series of binary signals. Both the printer and 
the computer must be configured to the same baud rate. 

 
BIT Binary digIT. A digit in the binary number system, 

represented by a 0 or a 1. A bit is the smallest unit of 

storage in a digital computer. 
 
Boot-up The start-up procedure which causes a computer 

operating system to be loaded into main memory. 
 
Buffer An area of storage into which data is read or written 

temporarily during data transfers. 
 
Configuration Refers to the operating properties that define how the 

printer responds to signals and commands received from 
the host computer at the printer interface. These 
properties are called configuration parameters and are 
set to match the operating characteristics of the host 
computer system. 

 
Continuous Media Media comprised of one continuous length without a gap, 

notch, hole, or black mark to establish a predetermined 
label or tag length. With this media type, the Host Form 
Length or user-selected Label Length sets the desired 
length of each label. 

 
Handling Mode  A media handling mode that advances media in the 

forward direction only. 
 
Controller An independent functional logic unit in a data processing 

system that controls data paths between one or more 
units of peripheral equipment. 

 

Data Bits Binary information sent to the printer; a character set 
grouping containing letters, digits, and punctuation marks 
to be printed. 
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Default A value, parameter, attribute, or option that is 

assigned by a program or system when another 

has not been specified by the user. 
 
Diagnostic Pertaining to the detection and isolation of a printer 

malfunction or mistake. 
 
Direct Thermal Media Media coated with special chemicals that act as an 

accelerator, acceptor dye, and binder. In Direct 

Thermal mode, the heat from the selected 

rectangular elements in the thermal printhead makes 

direct contact with the media (no ribbon is used) 

and causes a chemical reaction that creates the 

image on the media. 
 
Direct Thermal Printing A printing method in which no ribbon is used to 

transfer data from the printhead to the media to 

create an image. The thermal printhead selectively 

heats small rectangular elements which make 

direct contact with the coated media. 
 
DRAM  Dynamic Random Access Memory. Can be read 

from or written to at any time. DRAM is volatile: 

whatever is in DRAM is lost when power is turned 

off. 
 
Fanfold Media Media supplied in a fanfold stack instead of a roll format. 
 
Flash Memory Printer configurations, programs, downloaded files, and 

fonts are stored in Flash Memory. Data in Flash are not 
lost when power is turned off (Resident fonts are fonts 
permanently stored in Flash and availalbe at any time, 
via software commands.) 

 
Font           A collection of printing characteristics for printing 

alphanumeric characters, all of which combine to 

produce a distinctive style of print. 
 
Host Computer The computer that stores, processes, and sends data to 

be printed, which communicates directly with the printer. 
The term “host” is used to indicate the controlling 
computer, since modern printers are themselves 
microprocessor-controlled computer systems. 

 
Interface The hardware component used to link two devices by 

common physical interconnection, signal, and functional 
characteristics. 

 

IPS The speed at which the media is printed based on a 

rate of Inches-Per-Second. 
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Label Liner (backing)   The material labels are attached to during their 
manufacturing process. Attachment is usually 
accomplished with an adhesive. After printing, labels can 
be easily removed from the liner and the liner discarded 
or recycled. 

 
Label Taken Sensor A sensor located at the front of the printer to detect the 

presence of a label extended out the front of the printer. 
The sensor is used only during Peel-Off Media Handling 
to sense a label and then detect its removal prior to 
printing the next label. 

 
Media Material onto which data is printed by the printer. The 

types of media supported by the printer are die-cut 

labels or tag stock, supplied in roll or fanfold format. 

Media is further described by the type of sensing used 

to detect the Top-of-Form position based on the label 

length indicators used. Transmissive (Gap) media 

uses a liner gap, notch, or hole between labels, and 

Reflective (Mark) media uses a horizontal black mark 

located on the underside of the tag stock or label liner. 

Continuous media (with no label length indicators) 

uses no sensing method, and the operator determines 

which label length is desired. 
 
Media Sensor The sensor used to detect the presence of media in the 

paper path as well as the gap, notch, or hole position of 
Transmissive media or the horizontal black mark on 
Reflective media. 

 
Memory See RAM, Nonvolatile Memory, DRAM, and Flash 

Memory. 
 
Nonvolatile Memory Nonvolatile memory stores variables that must be 

preserved when the printer is turned off, such as 
configuration parameters and printer usage statistics. 

 
NVRAM Acronym of Nonvolatile Random-Access Memory. See 

Nonvolatile Memory. 
 
Parity (check) Parity checking is the addition of a non-data bit to data, 

resulting in the number of “1 bits” being either always 
even or always odd. Parity is used to detect transmission 
errors. Parity represents value in the check digit of the 
received or transmitted data. 

 
PCBA Printed Circuit Board Assembly. A PCB with 

components (ICs, resistors, capacitors, etc.) 

installed. 
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PGL Intelligent Graphics Printing software for the 

Printronix Graphics Language, designated for 

Printronix printers. PGL provides online forms, 

barcodes, and many alphanumeric text-generation 

capabilities and is compatible with earlier versions 

of Printronix PGL protocol and programming. 
 
Pitch (RFID) In the RFID industry, pitch is defined as the distance from 

one point on an inlay to the same point on the next inlay. 
 
Port A data channel used for receiving data from or 

transmitting data to one or more external 

devices. 
 
Protocol The rules and conventions that govern 

communication between a printer and a host 

computer. A protocol includes codes for printing text 

and graphics and codes instructing the printer to 

perform special operations. 
 
RAM Random-Access Memory. Also called “main 

memory” or “working memory.” It is the active 

memory of the printer into which programs are 

loaded. RAM is saved to volatile memory 

because data in RAM is lost when power is 

turned off or interrupted. 
 
Reflective Sensing Use of the lower media sensor only to transmit and 

receive infrared light off the underside of media to detect 
gaps, notches, holes, or horizontal black marks used for 
determining the Top-of-Form position on labels or for 
indicating a Paper Out condition. 

 
Resolution A measure expressing the number of component units in 

a given range used to create an image; in printing, 
expressed as the number of dots per inch (dpi) 
horizontally and vertically. 

 
RFID Encoder The RFID (Radio Frequency Identification) encoder 

programs smart labels (tags with embedded inlays). 
 
Roll Media Media supplied in a roll format, usually wound on a 1-inch 

or 3-inch cardboard core. The T800 media hanger 
assembly accepts both core sizes. 

 

Gap/Mark Sensor = Mark:  The Sensed Distance value is the physical 

distance from the leading edge of one black mark 

to the leading edge of the next.  

 
SD Card  A small removable device used to store data. The SD 

Card is used for fonts purchased from Printronix and 

the QCMC (Quick Change Memory Card) option. 
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Slew Vertical paper movement. 
 

Standard-Pitch RFID Labels Labels with RFID inlays that typically have a pitch 

from 2.0 to 6.0 inches. These labels support 

encoding of the tag and provide ample space to 

print text, graphics, barcodes, or logos. 
 

Stop Bits The signal which indicates the end of a character 

or element. 

 
Thermal Transfer Media Media specifically designed to work with a ribbon 

for image transfer. In Thermal Transfer mode, 

compatibility between the ribbon and the media is 

critical in producing a high quality, long lasting 

image. 
 
Thermal Transfer Printing A printing method in which the printhead presses a 

specially coated ribbon against the media. The 

printhead elements react with the ribbon and bond 

the image to the media. 
 
Transmissive Sensing Use of the upper media sensor to transmit infrared 

light through the top of media which is then received 

by the lower media sensor to detect gaps, holes, or 

notches for determining the Top-of-Form position on 

labels or for indicating a Paper Out condition. 
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K Communication Notices 

and Warranties 

This information was developed for products and services offered in the U.S.A. 
Printronix may not offer the products, services, or features discussed in this document in other countries. 
Consult your Printronix representative for information on the products and services currently available in 
your area. Any reference to an Printronix product, program, or service is not intended to state or imply that 
only that Printronix product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any Printronix intellectual property rights may be used instead. 
However, it is the user’s responsibility to evaluate and verify the operation of any non- Printronix product, 
program, or service. 
Printronix may have patents or pending patent applications covering subject matter described in this 
document. The furnishing of this document does not give you any license to these patents. You can send 
license inquires, in writing, to: 
 

Printronix Auto ID Technology, Inc. 
3040 Saturn Street, Suite 200 

Brea, CA  92821 U.S.A. 
 
The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law: 
PRINTRONIX PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON- 
INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do 
not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may 
not apply to you. 
This information could include technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein; these changes will be incorporated in new editions of the publication. 
Printronix may make improvements and/or changes in the product(s) described in this publication at any 
time without notice. 
Any references in this information to non-Printronix Web sites are provided for convenience only and do not 
in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not 
part of the materials for this Printronix product and use of those Web sites is at your own risk. 
Any performance data contained herein was determined in a controlled environment. Therefore, the 
results obtained in other operating environments may vary significantly. Some measurements may have 
been made on development-level systems and there is no guarantee that these measurements will be 
the same on generally available systems. Furthermore, some measurement may have been estimated 
through extrapolation. Actual results may vary. Users of this document should verify the applicable data 
for their specific environment. 
Information concerning non-Printronix products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. Printronix has not tested those products 
and cannot confirm the accuracy of performance, compatibility or any other claims related to non-
Printronix products. Questions on the capabilities of non-Printronix products should be addressed to the 
suppliers of those products. 
Printronix encourages owners of information technology (IT) equipment to responsibly recycle their 
equipment when it is no longer needed. Printronix offers a variety of programs and services to assist 
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equipment owners in recycling their IT products. Information on these product recycling offerings can be 
found on our company’s website. 
 

Before using this information and the product it supports, read the information and 

Communication  on page 299. 

 
If you are viewing this information softcopy, the photographs and color illustrations may not appear. 
For online versions of this book, we authorize you to: 
Copy, modify, and print the documentation contained on the media, for use within your enterprise, 
provided you reproduce the copyright notice, all warning statements, and other required statements on 
each copy or partial copy. 
Transfer the original unaltered copy of the documentation when you transfer the related Printronix product 
(which may be either machines you own, or programs, if the program’s license terms permit a transfer). 
You must, at the same time, destroy all other copies of the documentation. 
You are responsible for payment of any taxes, including personal property taxes, resulting from this 
authorization. 
Your failure to comply with the terms above terminates this authorization. Upon termination, you must 
destroy your machine readable documentation. 

Communication Statements 
Federal Communications Commission (FCC) Statement 

This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant 
to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful 
interference when the equipment is operated in a commercial environment. This equipment generates, 
uses, and can radiate radio frequency energy and, if not installed and used in accordance with the 
instructions, may cause harmful interference to radio communications. Operation of this equipment in a 
residential area is likely to cause harmful interference in which case the user will be required to correct 
the interference at his own expense. 

Properly shielded and grounded cables and connectors must be used in order to meet FCC emission 
limits. Printronix is not responsible for any radio or television interference caused by using other than 
recommended cables and connectors or by unauthorized changes or modifications to this equipment. 
Unauthorized changes or modifications could void the user’s authority to operate the equipment. 
This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: 
(1) this device may not cause harmful interference, and (2) this device must accept any interference 
received, including interference that may cause undesired operation. 

This product may contain an intentional radiator as shown below. 

 

RFID Radio Module: 

• Operating Frequency: 866-868MHz or 902 to 928 MHz 

• Typical RF Power: 25 to 100 mW 

• Maximum RF Power: 1 Watt under abnormal conditions 

 

WiFi 802.11a/b/g/n Radio Module:  

• Operating Frequency: 2.412 – 2.484 GHz, 4.9 to 5.845Ghz 

• Typical RF Power: 2dBm 
 

 
 

Note! 
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European Union Conformity 
 

 This product is in compliance with the EU directives for safety, EMC, ROHS, 

REACH, and WEEE. A Declaration of Conformity is available from our 

company’s website. 

 
Printronix Auto ID cannot accept responsibility for any failure to satisfy the protection requirements 
resulting from a non-recommended modification of the product, including the fitting of non-Printronix 
option cards. 
This product has been tested and found to comply with the limits for Class A Information Technology 
Equipment according to European standard EN 55032. The limits for Class A equipment were derived for 
commercial and industrial environments to provide reasonable protection against interference with 
licensed communication devices. 
 

 
Properly shielded and grounded cables and connectors must be used in order to reduce the potential for 
causing interference to radio and TV communications and to other electrical or electronic equipment. 
Printronix cannot accept responsibility for any interference caused by using other than recommended 
cables and connectors. 

Industry Canada Compliance Statement 

This Class A digital apparatus complies with Canadian ICES-003. 

Cet appareil numérique de la classe A conform á la norme NMB-003 du Canada. 

Statement of CISPR 32 Compliance 

Attention: This is a Class A Product. In a domestic environment this product may cause radio interference 
in which case the user may be required to take adequate measures. 

 

 

WARNING 

This is a Class A product. In a domestic environment this product may cause radio

interference in which case the user may be required to take adequate measures. 
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German Conformity Statement 

Handbuchtexte: FCC class A entspricht: EMVG Klasse A 

Text Für alle in Deutschland vertriebenen EN 55032  Klasse A Geräte: 

Zulassungsbescheinigung laut dem Deutschen Gesetz über die elektromagnetische Verträglichkeit von 
Geräten (EMVG) (bzw. der EMC EG Richtlinie 2014/30/EU): 

Dieses Gerät ist berechtigt in Ü bereinstimmung mit dem Deutschen EMVG das EG-Konformitätszeichen - 
CE - zu führen. Verantwortlich für die Konformitätserklärung nach Paragraph 5 des EMVG ist die: 

Printronix Auto ID Technology 

Georg-Wimmer-Ring 8b D-85604    

Zorneding, Germany 

Informationen in Hinsicht EMVG Paragraph 4 Abs. (1) 4: 

Das Gerät erfüllt die Schutzanforderungen nach EN 55024 und EN 55032 Klasse A. 

EN 55032 Klasse A Geräte müssen mit folgendem Warnhinweis versehen werden: “Warnung: dies ist 
eine Einrichtung der Klasse A. Diese Einrichtung kann im Wohnbereich Funkstörungen verursachen; in 
diesem Fall kann vom Betreiber verlangt werden, angemessene Maßnahmen durchzuführen und dafür 
aufzukommen.” 

EN 55024 Hinweis: 

Wird dieses Gerät in einer industriellen Umgebung betrieben (wie in EN 55024 festgelegt), dann kann es 
dabei eventuell gestört werden. In solch einem Fall ist der Abstand bzw. die Abschirmung zu der 
industriellen Störquelle zu öergrvßern. 

Anmerkung: 

Um die Einhaltung des EMVG sicherzustellen sind die Geräte, wie in den Printronix Handbüchern 
angegeben, zu installieren und zu betreiben. 

Korea 
 

Class A 

(Broadcasting Communication Equipment for Office Use) 

As an electromagnetic wave equipment for office use (Class A), this equipment is intended to use in other 
than home area. Sellers or users need to take note of this. 
 

A급 기기 

( 업무용 방송통신기자재 ) 

이 기기는 업무용 (A 급 ) 전자파적합기기로서 판매자 또는 사용자는 이 점을 주의하시기 바라며 , 

가정외의 지역에서 사용하는 것을 목적으로 합니다 . 
 

 
CAUTION: 

This product is equipped with a 3-wire power cord and plug for the user’s safety. Use this power cord in 
conjunction with a properly grounded electrical outlet to avoid electrical shock 
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China 

Declaration: 

This is a Class A product. In a domestic environment this product may cause radio interference in which 
case the user may need to perform practical actions. 
 
 
 
 

 

海拔高度和非热带性气候声明 
 

 

仅适用于海拔 2000M 以下地区安全使用 
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Software License Agreement 
Your printer contains, among other software, Printronix operating software including, but not limited to the 
Embedded Configurable Operating System (the “eCos Software”) as embedded software. The terms of 
this Agreement apply only to the eCos Software, and all other embedded software supplied with the 
printer. You accept the terms of this Agreement by your initial use of your printer. 

1. Object Code License 

Printronix grants you a nonexclusive license to use the Printronix Software, the eCos Software and all 
other embedded software (collectively, the “Embedded Software” or the “Software”) only in conjunction 
with the printer. As the rightful possessor of the printer, you may make a reasonable number of copies of 
the Software as necessary for backup, configuration, and restoration of the printer. You must reproduce 
the copyright notice and any other legend of ownership on each copy of the Software you make. 

You may transfer possession of the Software and its media to another party only with the transfer of the 
printer on which the Software is used. If you do so, you must give the other party a copy of these terms 
and provide all user documentation to that party. When you do so, you must destroy any copies of 
Software not resident in the printer. 

Your license for the Software terminates when you no longer rightfully possess the printer. No other rights 
under this license are granted. 

2. Source Code 

A source code version of eCos Software is available under the terms of a modified version of the GNU 
General Public License (GPL) located under PCM eCos 3.0 from our company’s website. Printronix Auto 
ID grants no rights whatsoever in the source code for the Printronix Auto ID Software. 

3. No. Warranty 

THE EMBEDDED SOFTWARE IS PROVIDED UNDER THIS LICENSE ON AN “AS IS” BASIS, WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, 
WARRANTIES THAT THE EMBEDDED SOFTWARE IS FREE OF DEFECTS, MERCHANTABLE, FIT 
FOR A PARTICULAR PURPOSE OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY AND 
PERFORMANCE OF THE EMBEDDED SOFTWARE IS WITH YOU. SHOULD ANY OF THE EMBEDDED 
SOFTWARE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT RED HAT, PRINTRONIX, ANY OTHER 
CONTRIBUTOR OR ANY DISTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, 
REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART 
OF THIS LICENSE. NO USE OF ANY OF THE EMBEDDED SOFTWARE IS AUTHORIZED 
HEREUNDER EXCEPT UNDER THIS DISCLAIMER. 

4. Conflicting Terms 

You agree that this Agreement provides you no more rights with regards to warranty, support, indemnity 
or liability terms with respect to Printronix Inc, or any contributor to the Embedded Software than that 
provided by any express warranty that may be made by Printronix, Inc. 

5. Limitation of Liability 

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING 
NEGLIGENCE), CONTRACT OR OTHERWISE, SHALL RED HAT, PRINTRONIX, ANY OTHER 
CONTRIBUTOR, OR ANY DISTRIBUTOR OF THE EMBEDDED SOFTWARE, OR ANY PART 
THEREOF, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO YOU OR ANY OTHER 
PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY 
CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK 
STOPPAGE, COMPUTER FAILURE OR MALFUNCTION. OR ANY AND ALL OTHER COMMERCIAL 
DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE 
POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO 
LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY’S NEGLIGENCE 
TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT 
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ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES SO 
THAT EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU. 

6. U.S. Government Users 

The Embedded Software is a “commercial item,” as that term is defined in 48 

C.F.R. 2.101 (Oct 1995), consisting of “commercial computer software” and “commercial computer 

software documentation,” as such terms are used in 48 C.F.R 12.212 (Sept. 1995). Consistent with 48 

C.F.R. 12.212 and 48 

C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users acquire Covered Code 

with only those rights set forth herein. 

7. Miscellaneous 

This Agreement represents the complete agreement concerning subject matter hereof. If any provision of 
this Agreement is held to be unenforceable. This Agreement shall be governed by California law 
provisions (except to the extent applicable law, if any, provides otherwise), excluding its conflict-of-law 
provisions. 

8. eCosSoftware 

eCos is free software; you can redistribute it and/or modify it under the terms of the GNU General Public 
License as published by the Free Software Foundation, version 2 or a later. 

eCos is distributed WITHOUT ANY WARANTY, without even the implied warranty of MERCHANT 
ABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more 
details. 

You should receive a copy of the GNU General Public License along with eCos. If not, write to: 

Free Software Foundation, Inc. 

59 Temple Place, Suite 330 

Boston, MA 02111-1307 USA. 

As special exception, if other files instantiate templates or use macros or inline functions from this file, you 
could compile this file and link it with other works to produce work based on this file. This file does not by 
itself cause the resulting work to be covered by the GNU General Public License. However, the source 
code for this file must be made available in accordance with section (3) of the GNU General Public 
License. 

This exception does not invalidate any other reasons why work based on this file might be covered by the 
GNU General Public License. 

Alternative licenses for eCos may be arranged by contacting Red Hat, Inc. at 
http://sources.redhat.com/ecos/ecos-license/ 

eCos 
 
eCos, the Embedded Configurable Operating System 
Copyright ©  1998, 1999, 2000, 2001, 2002, 2003 Red Hat, Inc. 
Copyright ©  2002, 2003 John Dallaway 
Copyright ©  2002, 2003 Nick Garnett 
Copyright ©  2002, 2003 Jonathan Larmour 
Copyright ©  2002, 2003 Andrew Lunn 
Copyright ©  2002, 2003 Gary Thomas 
Copyright ©  2002, 2003 Bart Veer 
Copyright ©  1982, 1986, 1991, 1993 The Regents of the University of California. All rights reserved. 
©  Unix System Laboratories, Inc. 

All or some portions of this file are derived from material licensed to the Unversity of California by 
American Telephone and Telegraph Co. or Unix System Laboratories, Inc. and are reproduced herein 
with the permission of UNIX System Laboratories, Inc. 
Copyright ©  1995, 1996, 1997, and 1998 WIDE Project. All rights reserved. 

http://sources.redhat.com/ecos/ecos-license/
http://sources.redhat.com/ecos/ecos-license/
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Copyright ©  2000 Brian Somers 

Copyright ©  1998 The NetBSD Foundation, Inc. All rights reserved. Copyright ©  1997 Niklas 

Hallqvist. All rights reserved. 

Copyright ©  1998 Stephen Deering 

Copyright ©  1992, 1993 The Regents of the University of California. All rights reserved. 

This code is derived from software contributed to Berkeley by Stephen Deering of Stanford Unversity. 
Portions of eCos code are distributed under several BSD style licenses. Other portions of eCos code are 
distributed under the terms of the GNU General Public License with a non-copyleft exception with allows 
static links to non-copyleft programs. 

Open SSL 

Copyright ©  1998-2004 The Open SSL Project. All rights reserved. 

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit 

(http://www.openssl.org/) 

Copyright ©  1995-1998 Eric Young. All rights reserved. 

OpenSSL is distributed under the terms of the Open SSL and SSLeay licenses, which are both BSD 

style open source licenses. 

OpenSSL License 

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the 
original SSLeay license apply to the toolkit. 

See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case 
of any license issues related to OpenSSL please contact openssl-core@openssl.org. 

 

Copyright (c) 1998-2011 The OpenSSL Project. All rights reserved. 

Redistribution and use in source and binary forms, with or without modification, are permitted 
provided that the following conditions are met: 

1.  Redistributions of source code must retain the above copyright notice, this list of conditions 
and the following disclaimer. 

2. Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials provided 
with the distribution. 

3.  All advertising materials mentioning features or use of this software must display the following 
acknowledgment: "This product includes software developed by the OpenSSL Project for use 
in the OpenSSL Toolkit. (http://www.openssl.org/). 

4.  The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or 
promote products derived from this software without prior written  ermission. For written 
permission, please contact openssl-core@openssl.org. 

5.  Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" 
appear in their names without prior written permission of the penSSL Project. 

6.  Redistributions of any form whatsoever must retain the following acknowledgment: "This 
product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit 
(http://www.openssl.org/)" 

 

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY 

EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE 

http://www.openssl.org/)
mailto:openssl-core@openssl.org
http://www.openssl.org/
mailto:openssl-core@openssl.org
http://www.openssl.org/
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LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN 
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE. 

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This 
product includes software written by Tim Hudson (tjh@cryptsoft.com). 

Original SSLeay License 

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) 

All rights reserved. 

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com). The 
implementation was written so as to conform with Netscapes SSL. 

This library is free for commercial and non-commercial use as long as the following conditions are 
aheared to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, 
lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is 
covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com). 

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. 

If this package is used in product, Eric Young should be given attribution as the author of the parts of 
the library used. 

This can be in the form of a textual message at program startup or in documentation (online or textual) 
provided with the package. 

Redistribution and use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met: 

1.  Redistributions of source code must retain the copyright notice, this list of conditions and the 
following disclaimer. 

2.  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution. 

3.  All advertising materials mentioning features or use of this software must display the following 
acknowledgement: 

"This product includes cryptographic software written by 

Eric Young (eay@cryptsoft.com)" 

The word 'cryptographic' can be left out if the routines from the 

library being used are not cryptographic related :-). 

4.  If you include any Windows specific code (or a derivative thereof) from the apps directory 
(application code) you must include an acknowledgement: "This product includes software written 
by Tim Hudson (tjh@cryptsoft.com)" 

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO 
EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, 
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT 
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, 
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF 
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE 
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

mailto:eay@cryptsoft.com
mailto:eay@cryptsoft.com
file:///C:/Users/luca_li/AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files/Content.Outlook/X842GUIC/tjh@cryptsoft.com
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The licence and distribution terms for any publically available version or derivative of this code cannot 
be changed.  i.e. this code cannot simply be copied and put under another distribution licence 
[including the GNU Public Licence.] 

 

WPA Supplicant License 

Copyright (c) 2003-2013, Jouni Malinen <j@w1.fi> and contributors. All Rights Reserved. 

This program is licensed under the BSD license (the one with advertisement clause removed). 
Redistribution and use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met: 

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer. 

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the 
following disclaimer in the documentation and/or other materials provided with the distribution. 

3. Neither the name(s) of the above-listed copyright holder(s) nor the names of its contributors may be 
used to endorse or promote products derived from this software without specific prior written 
permission. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND 
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR 
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON 
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, 
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

Brian Gladman AES Library 
This library, written by Brian Gladman (http://www.gladman.me.uk/), contains code for implementing 

encryption and decryption for AES (Rijndael) for block and key sizes of 16, 24 and 32 bytes. The firmware 

contains a version of the library, taken from the following URL: 

  

http://www.opensource.apple.com/source/xnu/xnu-1504.9.37/bsd/crypto/aes/ 
 

Copyright (c) 2003, Dr Brian Gladman, Worcester, UK.   All rights reserved. 

 

 LICENSE TERMS 

 

 The free distribution and use of this software in both source and binary 

 form is allowed (with or without changes) provided that: 

 

   1. distributions of this source code include the above copyright 

      notice, this list of conditions and the following disclaimer; 

 

   2. distributions in binary form include the above copyright 

      notice, this list of conditions and the following disclaimer 

      in the documentation and/or other associated materials; 

 

   3. the copyright holder's name is not used to endorse products 

      built using this software without specific written permission. 

 

 ALTERNATIVELY, provided that this notice is retained in full, this product 

mailto:j@w1.fi
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 may be distributed under the terms of the GNU General Public License (GPL), 

 in which case the provisions of the GPL apply INSTEAD OF those given above. 

 

 DISCLAIMER 

 

 This software is provided 'as is' with no explicit or implied warranties 

 in respect of its properties, including, but not limited to, correctness 

 and/or fitness for purpose. 

 

Google Font Open Sans 

The Google Font “Open Sans” is used in the product for purposes of the front panel display only. Open 
Sans is a humanist sans serif typeface designed by Steve Matteson, Type Director of Ascender Corp. 
This version contains the complete 897 character set, which includes the standard ISO Latin 1, Latin CE, 
Greek and Cyrillic character sets. Open Sans was designed with an upright stress, open forms and a 
neutral, yet friendly appearance. It was optimized for print, web, and mobile interfaces, and has excellent 
legibility characteristics in its letterforms.  

The source is https://www.google.com/fonts/specimen/Open+Sans and is licensed to Printronix under the 
terms of the Apache License, Version 2.0 described at http://www.apache.org/licenses/LICENSE-
2.0.html.  

 

Copyright [yyyy] [name of copyright owner] 

 

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in 
compliance with the License. You may obtain a copy of the License at 
 

    http://www.apache.org/licenses/LICENSE-2.0 
 

Unless required by applicable law or agreed to in writing, software distributed under the License is 
distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either 
express or implied. See the License for the specific language governing permissions and limitations under 
the License. 
 

Cousine Font  

The Cousine Font is a monospaced font used in the product for purposes of the front panel display only.  
The source is found at http://www.fontsquirrel.com/fonts/list/classification/monospaced and is licensed to 
Printronix under terms of the Apache License, Version 2.0 described at 
http://www.apache.org/licenses/LICENSE-2.0.html.  

 

Copyright [yyyy] [name of copyright owner] 

 

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in 
compliance with the License. You may obtain a copy of the License at 
 

    http://www.apache.org/licenses/LICENSE-2.0 
 

Unless required by applicable law or agreed to in writing, software distributed under the License is 
distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either 

https://www.google.com/fonts/specimen/Open+Sans
http://www.apache.org/licenses/LICENSE-2.0.html
http://www.apache.org/licenses/LICENSE-2.0.html
http://www.fontsquirrel.com/fonts/list/classification/monospaced
http://www.apache.org/licenses/LICENSE-2.0.html
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express or implied. See the License for the specific language governing permissions and limitations under 
the License. 

Limited Software Product Warranty 
Printronix Auto ID Technology, Inc. warrants that for ninety (90) days after delivery, the Software will 
perform in accordance with specifications published by Printronix Auto ID Technology, Inc. Printronix Auto 
ID Technology, Inc. does not warrant that the Software is free from all bugs, errors and omissions. 

 

Remedy 

Your exclusive remedy and the sole liability of Printronix Auto ID Technology, Inc. in connection with the 
Software is replacement of defective software with a copy of the same version and revision level. 

 

Disclaimer of Warranties and Limitation of Remedies 

1. THE PARTIES AGREE THAT ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING 
WARRANTIES OF FITNESS FOR A PARTICULAR PURPOSE AND MERCHANTABILITY ARE 
EXCLUDED. Printronix Auto ID Technology, Inc. does not warrant that the functions contained in the 
Software will meet your requirements or that the operation of the Software will be uninterrupted or error 
free. Printronix Auto ID Technology, Inc. reserves the right to make changes and/or improvements in 
the Software without notice at any time. 

2. IN NO EVENT WILL PRINTRONIX AUTO ID TECHNOLOGY, INC. BE LIABLE FOR LOST PROFITS, 
LOST DATA, BUSINESS INTERRUPTIONS, OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THIS 
PRODUCT, EVEN IF PRINTRONIX AUTO ID TECHNOLOGY, INC. HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES, OR ANY DAMAGES CAUSED BY THE ABUSE OR 
MANIPULATION OF THE SOFTWARE. SOME STATES DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE ABOVE 
LIMITATION MAY NOT APPLY TO YOU. 

3. Printronix Auto ID Technology, Inc. will not be liable for any loss or damage caused by delay in 
furnishing a Software Product or any other performance under this Agreement. 

4. Our entire liability and your exclusive remedies for our liability of any kind (including liability for 
negligence except liability for personal injury caused solely by our negligence) for the Software Product 
covered by this Agreement and all other performance or nonperformance by us under or related to 
this Agreement are limited to the remedies specified by this Agreement. 

5. California law governs this Agreement. 

Termination of License Agreement 

This License shall continue until terminated. This license may be terminated by agreement between you 
and Printronix Auto ID Technology, Inc. or by Printronix Auto ID Technology, Inc. If you fail to comply with 
the terms of this License and such failure is not corrected within thirty (30) days after notice. When this 
License is terminated, you shall return to the place you obtained them, the printer and all copies of the 
Software and documentation. 

U.S. Government Restricted Rights 

Use, duplication or disclosure by the government is subject to restrictions as set forth in the Rights in 
Technical Data and Computer Software clause at FAR 242.227-7013, subdivision (b) (3) (ii) or 
subparagraph (c) (1) (ii), as appropriate. Further use, duplication or disclosure is subject to restrictions 
applicable to restricted rights software as set forth in FAR 52.227-19 (c) (2). 
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Acknowledgement of Terms and Conditions 

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTAND IT, AND AGREE 
TO BE BOUND BY ITS TERMS AND CONDITIONS. NEITHER PARTY SHALL BE BOUND BY ANY 
STATEMENT OR REPRESENTATION NOT CONTAINED IN THIS AGREEMENT. NO CHANGE IN THIS 
AGREEMENT IS EFFECTIVE UNLESS WRITTEN AND SIGNED BY PROPERLY AUTHORIZED 
REPRESENTATIVES OF EACH PARTY. BY USING THIS PRINTER, YOU AGREE TO ACCEPT THE 
TERMS AND CONDITIONS OF THIS AGREEMENT. 
 

Product Warranty Information 
Complete product warranty information for printers, accessories, options and consumables can be found 
on our company’s website. 
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